[TP] Creative Gates [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Olof Larsson, Jun 23, 2011.

  1. Offline

    Olof Larsson

  2. Offline


  3. Offline

    Olof Larsson

    Hi. I know there are some bugs with creative gates. I do however have other plugins that I prioritize at the moment.

    Instead of reporting bugs: fix it yourselves.
    Learn java and do a pull request.
  4. Offline


    Yeah ive got the same prob :D Please fix it ;)
  5. Offline


    I am also getting no valid frame for gate using CB#1317 and #1337 with MultiverseCore 2.0 B279 and MultiverseCore 2.1 B326.
    We have only one pair of gates made of MossStoneBrick that link our old world to our new one. I get the message when trying to re-set the gate after updating.
    We also have tested multiverse-nether 2.0 B182 and 2.1 B283 now.

    We are still using CB#1240, CreativeGates 1.3.1, MultiverseCore 2.0B279 and everything is working good.
  6. Offline


    So you're saying that they should learn: Imperative Programming, Object Oriented Programming, Java, learn the bassis of the Bukkit API, and then learn how your code works, oh oh! Don't forget how to make debbuging. Also, it's not "some bug" it's making your plugin unusable in the 1337 build. Sure, that's the correct way to handle the requests of the users of your plugins.

    Anyway, i will give it a try in the weekend, i don't think it's a too complicated bug to solve (for you less time & work obviusly). In the meanwhile, for anybody that's searching a simil plugin, you got Stargate, it has a very very similar function option to Creative Gates, and will work with the old frames using a sign.

    For the record, i really like the plugin, and i don't have problems trying to fix something myself, but it's your attitude and rough answer that bothers me.
    xtre likes this.
  7. Offline


    i followed the intructions correctly, but when i hit the diamond, it keeps saying "there is no frame"
  8. Offline

    Olof Larsson

    I am just making clear that this plugin is open source and I have limited time :)
  9. Offline


    Now, the question is; is it JUST for travelling between worlds ?
  10. Offline


    Nope, it's for the same world too, but it's currently broken for the latest RB (1317), but if you use it in the 1240 it work's.
  11. Offline


    hello, im having a little problem with your plugin
    see, whenever i create a gate in any shape and hit the diamond block with a clock it just says there is no frame...

  12. Offline


    (Look at the end of this post for the interesting stuff, at "EDIT AGAIN")

    I still have working gates in 1337... don't know why but I do, am I the only one with working gates?

    I have noticed a lot of people mentioning they're hitting "diamond blocks", maybe those with problems could try changing the block from diamond to... anything really, unless you already have of course...
    Try changing the block from diamond to mossycobble(it's what I use, number 48) and see if that works.

    My conf.json file:
      "wand": 347,
      "block": 48,
      "maxarea": 200,
      "effects": true

    Just created a test server, Pex v1.15, creative gates 1.3.2, craftbukkit 1337.
    "No valid frame", with both diamond and mossy, so that's not the problem, ignore top half of comment :p

    Got no idea what the difference is though other than the mass of plugins on one server and only 2 on the other...
    Shall keep testing and see what I can find.

    Found the issue!

    This plugin REQUIRES spout, or from my tests it does anyway, I'm not going to say it's 100% accurate/confirmed but from my tests, I'm saying it does.

    My test was as follows:
    Download craftbukkit 1337 and creative gates 1.3.2.
    Run server, try making gate, failed.

    Copy all plugins from working server to test server.
    Run server, try making gate, works fine!

    Remove spout plugin, start server.
    Try making gate, failed.

    Remove everything except creative gates and spout, start server.
    Try making gate, success!!!

    So again, from my tests this plugin REQUIRES spout!!!
  13. Offline


    It also prevents tooth decay.
  14. Offline


    I'm about to test this fix now!
  15. Offline


    well I cant confirm Spout being required but it works fine for me and I use Spout so that may be a work around.
  16. Offline


    I have been coming on here everyday waiting for a fix so I could upgrade my server. Just tested with spout and 1337 and it is WORKING. I have a lot of other plugins installed as well. No errors and portals work fine.

    Thank you for finding this Xmillsa
  17. @jdev21 @Xmillsa

    That is strange that installing spout 'fixed' the plugin for you two as I did not have spout installed and the plugin was working. I will have to do some testing on my test server tonight.

    EDIT: Yep, that seems to be it. My apologies to all, I apparently did install spout at the same time I updated CG and bukkit. Go me, eh? Adding spout does fix the problem.

    However, I am now seeing the non-saved gate bug again. :(
  18. Offline


    Does not work for 1240 correctly. Way much to often Gates arent saved...
    No Probs with Frames, just a lot of Gates that lead to nowhere...
  19. Offline


    Gates work and save fine for me in 1240(as well as 1337), just tested it myself now. (craftbukkit 1240, creative gates 1.3.2, spout 1.0.6 b449)
    The only time gates aren't saved is when I force close the server(i.e. not using /stop)

    Just thought, if you have a saving plugin, try typing /save-all before using /stop, it may or may not help... just a guess. (some saving plugins disable the auto-save on stop)
  20. Offline


    It not working for me... reason: There is no valid frame for the gate
    Please help!
  21. Offline


  22. Offline


  23. Offline


    Yep, Build 1240, Spout 1.0.6 b449, CG 1.3.2.

    Tried an another hour. Its not the Save-Funktion that causes the Issue.

    In 80% when i make 2 Gates, it says for both: This Gate does not lead anywhere..
    In 18% one Gate works, the other does not. So its a One-way-ticket.
    In 2% both worked.

    Seems they do not link correctly to each other. I also noticed, that the file "gate.json" sometimes fills with Parameters and Info's and sometimes not.


    Weird. Broke all Portals, moved to other locations and now they are working...
    But still cant get em to work at some locations. And i am not using any protection at all...neither is there anything special in this Areas. Kinda strange...
  24. Offline


    Ah I think that's a bug in 1240!
    I remember something similar to that myself(some chunks just became dead... they existed but no plugins could 'touch' them), if possible I would suggest you upgrade to 1337, it's the only way I can see it working for you, or hope of it working for you, can't think of anything else it could be.
  25. Offline


    LOL. It wasnt what i ment but that could come in handy.

    No, but what i really ment, is it also possible to travel from 1 position to another in the SAME world ?
  26. Offline


    Why is Spout required? Doesn't seem to be any good reason to force it on users who don't want it, considering plenty of other portal plugins exist and work just fine without...
    Do both the server side and client side Spout need to be installed, or just the server side?
  27. Offline


    Spout isnt required.

    There are two bugs in the code

    foundBlocks.contains(otherblock) <- this does NOT work as the equals operator is bugged

    This works:
            boolean contains = false;
            for( Block b : foundBlocks){
                if ( b.getX() == startBlock.getX() && b.getY() == startBlock.getY() && b.getZ() == startBlock.getZ() )
                    contains = true;
            if (contains)
                return foundBlocks;
    Second thing in isIntact:


                if (block.getType() == Material.WATER || block.getType() == Material.STATIONARY_WATER)

    Edit: Fixed Gate.java : www.kadcon.de/Gate.java
  28. Offline


    If Spout is not required, why does the plugin always say "There is no valid frame for the gate" until Spout is installed?

    I tested with the exact same results as everyone else in the last 2-3 pages. Clean install with just Creative Gates doesn't work, add Spout and the problem is fixed, remove Spout and it's broken again.

    So I added Spout to my live server and problem fixed there too.
  29. Offline


    Every Plugin has the capability to override existing methods. Spout might have redefined the Block.equals and Block.hashCode.

    That could probably fix the problem, i don't want to install spout on my server as it severely slows down the Server somehow - and with up to 50 Players online its a real pain.
  30. Offline


    Yes, my players do this all of the time.
  31. Offline


    Which still brings this back to a bug in Creative Gates 1.3.2 requiring Spout to fix it when it shouldn't be :(

Share This Page