[TP] Creative Gates [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Olof Larsson, Jun 23, 2011.

  1. Offline

    Olof Larsson

  2. Offline


    So true!!
    Rhalar likes this.
  3. Offline


    um i get a weird error it says wheni have an iron gate with a diamond block in the middle and a proper frame but it says there is not a valid frame for the gate can you please help?
  4. Offline


    Creative gates is working just fine for me and I have 1317, only issue I seem to be having is when I use a creative gate to portal to the nether it seems to strip all permissions to the default group, but I think that's a problem with Multiverse as it hasn't yet been updated to 1317.
  5. Offline


    Can someone help
    im new to this plugin thing and i dont know if im doing it right cause when i hit the dimond with the clock it says no valid frame or somthing like that
  6. Hi;
    Im having Trouble with the pulgin, it keeps on saying "There is no valid frame for the gate"
    Please Help
  7. @edyedy

    People, the last two or so pages are about the 'no valid frame' error. There isn't any clear cause for this yet, for some people it works fine, others it doesn't.
  8. Ive been using this for a while, but the update is not allowing me to make a portal.

    It just says: "There is no valid frame for the gate"

    I love this plugin but i want it to work :(
  9. Offline


    I'm getting the same error as everyone else, so I suppose I'll just have to wait for a fix. But in the meantime, I meant to ask, how does one go about changing the material the portal requires? I was hoping to make them require gold blocks rather than diamond to give gold some better use. All I have is the jar file in my plugins folder and I don't know how to edit class files.
  10. It's not a jar file that needs to be changed, it's the config file.

    EDIT: Opps, the first post needs to be updated, my apologies.

    Look in conf.json to change the block used, as well as the item needed to activate the gate.
  11. Offline


    I don't suppose you'd know how to edit that from an FTP sever would you? Haha, completely unrelated, but I'm renting a server and this is my first time running my own server.
  12. Offline


    Plugin isn't working for me. (Same "no valid frame" error) IDK if it's a problem with the latest version of Bukkit or this plugin. Been using it on our server for a while. Plz fix it.
  13. You can't. Best idea right off the top of my head is to edit the file locally then upload it to the server.
  14. Offline


    Rollback to 1240. I left my hosting company because they updated me to 1317 without my permission, I asked to be updated to 1240, then took waaay too long to get back to me to change it back. Servercraft.co, btw.
  15. Offline


    It seems you're the only one posting who it works for, so could you post those old logs of the first errors you got and the next run when it worked? And if you haven't already, the plugins you were using at the time?
  16. Offline


    Thats not true, I edit all my Configs through FTP, Including JSON's Which is the Config type for CreativeGates.

    I suggest you download notepad++, Its free and it is AMAZING, I use it to Edit all my configs and more, and i dont know what else will open JSON files cleanly. Now, in your FTP, go to the Config for CreativGates location(I use Filezilla btw, so i dont know if these instructions will work for other FTPs). Once your there, right click the config and click edit. It should open a box, Browse to Notepad++ and double click it, It should open with the Config, and there you can edit it.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  17. Offline


    Windows notepad works fine on them. Nevertheless, I also highly recommend N++. It's a lifesaver, automatically organizing code into a manageable view and all.

    Also, I notice noone reads anymore... with two pages of practically nothing but "No valid frame", you'd think someone would post something besides it.

    But I'm one to talk, having been the third guy to post that without reading that others are having the problem too.
  18. More than likely, your FTP client is downloading the file locally, calling an editor of some sort, then automagically uploading it. :)

    I will try to do so later tonight (I am not near my testing server at the moment). But as I recall, I was getting the same error as everyone else. I then did some updates of other plugins (Multiverse-core and PEX if I recall correctly). After that, it started up and ran as expected (unless I somehow rolled it back to an earlier version as well and somehow didn't notice it. Boy, would I feel really dumb if that was the case).

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  19. Offline


    hmm, Guess i didnt think of that, Filezilla does do that. But, the server providers i use allow me to edit files through their CP, which im not downloading locally and putting back in when im done. This include JSONs and YMLs

    Really, And its clean and easy to Read?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  20. Offline


    I got mine to work

    Jk i have the same Invalid frame error :(
    One question?
    Do i need a multiverse plugin for this plugin to work even if my gates arent going to other worlds?
    If you do that might be my problem, anyhelp would be appreciated.
  21. Offline


    No this plugin works with out the multiverse plugin.
  22. Offline


    I am simply adding that this plugin does not work with the new updates, the community is in despair. Please fix this plugin, its a staple of many servers.
  23. Offline


    When ever I try to make a Portal, I get a message saying "The is not a valid frame" even if its the most simple of designs.
  24. Offline


    yeah yeah.. "error The is not a valid frame"

    fix please, great plugin! good job
  25. Offline


    this plugin is vital to the transport system of my server, please fix it.
  26. Offline


    So... he's ignoring us? u.u

    A reply of him to calm the waters will be nice.
  27. OK, I did some looking around in my logs, and here is what I found:

    2011-10-12 19:40:16 [INFO] [CreativeGates v1.3.2] === ENABLE START ===
    2011-10-12 19:40:16 [INFO] [CreativeGates v1.3.2] Will use this plugin for permissions: PermissionsEx v1.15
    2011-10-12 19:40:16 [INFO] [CreativeGates v1.3.2] === ENABLE DONE (Took 54ms) ===
    I believe this is the first time I started the server with the 1.3.2 version.

    After a few stop and starts, I seem to recall that I updated Multiverse-Core to v2.0-b279 from Version 2.0-b265. No where in the logs did I find the message about the frame being invalid, it was strictly via the client.

    My conf.json:
      "wand": 347,
      "block": 57,
      "maxarea": 200,
      "effects": true
    My gate.json:
      "2": {
        "sourceCoord": {
          "worldName": "creative",
          "x": 14,
          "y": 32,
          "z": -1
      "1": {
        "sourceCoord": {
          "worldName": "survival",
          "x": -187,
          "y": 70,
          "z": 235
    The list of plugins I use is on my profile, with the only difference is my test server is running bukkit 1318. So far, the only problem I have run into was the old water escaping the frame bug, but that only affected the test gate I made with multicoloured wool, and only one of the gates. The main gate (all glowstone) has been fine.

    Anything else I can provide or turn debugging up on?
  28. Offline


    i tried to make one of these gates and it did not work i am pretty sure i did everything as it was said in description can anyone clear up how to make a gate earlier?
  29. Offline


    Installed the plugin, restarted server, tried many different frames, did exactly as shown in video and still cant get it to work. All that it says after I hit the diamond block with the clock is ..."There is no valid fram for the gate." In red.
    I'm running Craftbukkit 1317
  30. Offline


    hey can i have help my gates are structured correctly but when i hit them with a clock it says there is no vlid frme for the gate
  31. Offline


    I have the same problem since I use 1317.

Share This Page