[TP] Creative Gates [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Olof Larsson, Jun 23, 2011.

  1. Offline

    Olof Larsson

  2. Offline


    What did you do? I'm still getting errors.

    Lol, follow the advice of your signature and post a couple logs?

    O_O Oddly enough it works great with bukkit 1240.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  3. Offline


    Big thanks for updating this plugin, a must have on a server !
  4. Offline


    I had to go back to the 1240 build as well.
    With 1317 I keep getting the "...no valid frame..." response.
  5. Offline


    There is no valid frame for the gate in 1317 using 1.3.2
  6. Offline


    Still getting the same error even in the update
  7. So SSP players are just invisible here? Great. Thanks so much, you've all been a great help.
  8. Offline


    Well considering this is a Bukkit forum and Bukkit is, in my view, a Minecraft Beta Server; it would make sense that the plugin wouldn't really work in SSP, I could be wrong of course...

    Also it's not hard to download bukkit, add a plugin, run bukkit and join it. It's all local so there's no firewall config required, no port forwarding required, no risk, just download, run and play!

    Oh about about creative gates... I've managed to get 1.3.2 working in bukkit 1317, I've had to start with a new bunch of config files however... a long process awaits me for reactivating all the gates!
    At least it's working though and I can make gates.
  9. Offline


    Build #1336 bukket
    There is no valid frame for the gate V. 1.3.2
  10. I wouldn't have the slightest idea of how to integrate this into an SSP .jar, but it seems like a lot of work given that you could very easily, as Xmillsa said, just run a private bukkit server for yourself with this plugin.
  11. Oh. Cool. Thanks.
  12. Offline


    Why when I try to build a gate it says: There is no valid frame to build a gate? I building gate like on video and it don't work. Sorry, I'm from polish and my english isn't very good.
  13. Offline


  14. Offline


    bc the version of bukket u r using cant b used, it works in 1235..
    Olof, plz make it work in 1337
    1235 bukket version
    pple, want another version, n u know what # it is, just change "1235" to the version u want in the link and u will get it
  15. Offline


    Couldn't tell you why it's not working for you, all I know is that it's working for me with this setup:

    Creative Gates Version: 1.3.2

    CraftBukkit Version: 1317

    Permissions: PermissionsEx
    Version: 1.15

    World Management: Multiverse-Core
    Version: 2.0-b279

    I originally deleted everything inside my CreativeGates folder in Plugins, I then edited the config.json file to change the diamond block to mossy cobblestone, (as that's what I use on my server for making gates).
    After that just started up the server and it all just worked, gave myself a clock/watch, hit the activation block(default diamond, for me it's mossy cobble) and the portals were made.

    If you can't get it working it might be a good idea to delete your CreativeGates folder, or the contents within it and try again; yes it's a pain to remake all the gates again but at least if that fixes it, you will have working gates, or the ability to make them. :p

    If that's not working it might be a good idea to give the information I gave above, creative gates seems to depend partly on a permissions plugin and a world management plugin, so maybe it's simply a conflict/problem between some of them.

    If we see a pattern of users reporting the same problem with the same plugins, perhaps Olof Larsson could make a quick patch/workaround for that specific plugin or maybe the developer of the problematic plugin could update theirs, but this is all just wild guesses, I think we just need to find out as much information as we can about the problem.

    All I can think of, if it's working for me, then there's no reason it shouldn't work for anyone else, as long as they're using the same setup as me.

    Oh and if you're NOT using craftbukkit 1317, then that's most likely why it doesn't work for you :p
  16. Offline


    Craftbukkit: 1317

    CreativeGates: 1.3.2

    Permissions: PermissionsBukkit 1.2 with SuperpermsBridge 1.2

    World Management:
    Not too sure, I haven't installed one, but here are my installed plugins:

    iConomy 6

    I still get that error (no valid frame) even after deleting the folder and allowing CreativeGates to make a new one. I have 3 files in my creativegates folder:

      "wand": 347,
      "block": 57,
      "maxarea": 200,
      "effects": true
    "l": "<green>",
    "a": "<gold>",
    "n": "<silver>",
    "i": "<yellow>",
    "g": "<lime>",
    "b": "<rose>",
    "h": "<pink>",
    "c": "<aqua>",
    "p": "<teal>"
  17. Offline


    Craftbukkit: 1317

    CreativeGates: 1.3.2

    Permissions: PermissionsEx 1.5 (latest)

    World Management: MultiVerse-Core & DimensionDoor (tried both, stuck with MultiVerse-Core)

    Still getting the same error as everyone else, irregardless if I remove the plugin folder or not.
  18. Offline


    Permissions 3 and world manager.

    And by the way, it seems that 1317 is in part the problem.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  19. I don't think anything in my signature is going to help with this one. :)

    Here is what I have installed that might apply to this:

    Bukkit 1318
    CreativeGates 1.3.2
    PermissionsEx (AKA PEX) 1.15
    Multiverse-Core 2.0 Build 279

    My gate warps players from the survival world to the creative/freebuild world. As an added bonus, I tried making a gate out of multi-coloured wool using the 1.3.2 version of CG and not only does it work, it also works totally separate from the earlier gate I had made from glowstone.

    I'm going to assume that the plugin doesn't look at the damage value for the wool as both gates do not have the same colour pattern but still connect as expected.

    I have noticed that on occasion, the gate doesn't seem to work (I go in but I'm not teleported), but usually giving it a few seconds and trying again does seem to 'wake up' the plugin. This seems to happen mostly when the server is first started/restarted.
  20. My test server's running Bukkit 1317, CreativeGates 1.3.2, PermissionsBukkit, and DimensionDoor without any problems. Existing gates exist and new gates create fine. For those this isn't working for, I'd list out all your plugins to see if there's any common plugin between you that might be causing the problem.
  21. Offline


    I have one question, is it possible to disable the multiworld support? Because I basicly want my players to only be able to travel on the world they're on, and only be able to teleport worlds trough the central gates in a world ( I'm using Wormholes for them ).

    Thanks in advance :D
  22. Offline


    I have tried a clean install with only the plugins you have and it still gives me There is no valid frame for the gate
    Tried it on both linux and windows so that's not it either
  23. Huh, you're right. Okay. I didn't want to throw any spam, but my test server's plugins:
    Plugins (open)
    Planetoids, Spout, WorldEdit, NoDeathMessage, CFBanner, BananaCakeTown, BananaChunk, SphereWorld, getID, RemoteToolkitPlugin, Cenotaph, Glowstone Lanterns, obuShutTheHellUp, BananaNordic, WorldGuard, SpawnMob, milkAdmin, BananaGen, DimensionDoor, BlocksOnGlass, MeasuringTape, PermissionsBukkit, Blink, CleanroomGenerator, DisableIt, Vanilla, PortalLink, AutoRepair, BananaImageToMap, PlayerEditor, Creeperheal, MultiHome, NaturalGiants, LagMeter, iMOTD, CraftBukkitUpToDate, MineBackup, CreativeGates.
    I really can't imagine which of them is actually helping to make CG work, but I can copy my entire test server over where CG is working, delete all the other plugins than the ones I mentioned before, and then when I turn the server on CG tells the console '[INFO] [CreativeGates v1.3.2] §cThere is no valid frame for the gate. Gate was removed.' several times and I get the same error as everyone else. No working gates in game and I get the 'no valid frame' error in-game.
  24. Offline


    I have it working with CB 1240
    Creative Gates 1.3.2
    I was not able to get it working with CB 1317 and the above plugins. I did try deleting the CG folder and starting from scratch, but to no avail.
    I don't have a permissions plugin though, so if there is some dependency there, please let me know.
  25. Offline


    "There is no valid frame for the gate."
    Shit man you gotta fix this my server dies without this plugin!
  26. Offline


    Maybe it's World Manager's fault? Or World Edit and extensions of it?
  27. Offline


    Use craftbukkit 1240 the plugin works just fine there
  28. Offline


    1235 works perfectly for me..
    btw, Olof Larsson, theres a problem, each time i shut down my server and bring it back up, the water is there for the portal but, when i go to it, it doesnt tp me to the other portal, i have to retap the diamond block with the compas in hand, which i realy dont want to do that.
  29. Offline


    Since I updated Craftbukkit and installed version 1.3.2 of your plugin, the console says: "There is no valid frame for the gate", whenever I try to make a frame, and even on frames used in the past for portals with your plugin. Please fix ASAP, my server is heavily dependant on your plugin.
  30. Offline


    As "The_Basilisk" said, please fix it as fast as you can.
  31. Offline


    Dude don't say it's 1317 compatible if it isn't, I just blew all of my portals.
    Rhalar likes this.

Share This Page