[TP] Creative Gates [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Olof Larsson, Jun 23, 2011.

  1. Offline

    Olof Larsson

  2. Offline

    Olof Larsson

    yes you have missed something :) Read the OP.
    Edit: By the way, it is perhaps not obvious from reading the OP. It says that they are connected in a circular manner but not really what the order is determined by.

    It is determined by the geo-location.
  3. Offline


    most probably asked a lot of times but is there possibly any horizontal gates possibility? would be great for my stargate
  4. Offline


    GroupManager suport please :)?
  5. Offline


    already exists, using one myself. use the groupbridge and it will think it is permissions and support it
  6. Offline


    ah okey thx ;)
  7. Offline


    I'm really sorry, but after reading some of the post I realised I might still have this problem, I'm running the 1185 build, 1.8.1 minecraft and the 1.3.0 version of Creative Gates, but I still seem to have the problem where one of my gates in another world seem to "unload", everytime I reload all my server plugins. I have a gate in another world that works no matter how many times I reload the server, and I wish the other gates would do the same. Will you please, look at this again?, because I really like this plugin and it fits my server perfectly!

    Regards, Kevin.
  8. Offline


    Ok even with the latest version I still get: http://www.pastie.org/2612280

    I have absolutely everything up to date ... permissions, craftbukkit, this plugin, etc, etc. The gates won't work at all because the plugin dies at this state.

    Nevermind. I trashed my entire config and restarted and it works now. Thanks!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  9. Offline

    Drei Gyuu

    Do you have a link for the fixed version? Thanks ;]
  10. Offline


    Olof Larsson likes this.
  11. Offline

    Drei Gyuu

  12. Offline


    here's what i get...

    yes, it says 1.1.4, but it happens on 1.3.1 as well... from reading the thread, it seemed like 1.1.4 might work...

    2011-09-29 21:48:00 [SEVERE] Could not load 'plugins\CreativeGates 1.1.4.jar' in folder 'plugins':
    java.io.FileNotFoundException: Jar does not contain plugin.yml
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:64)
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:213)
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:136)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:138)
    at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:103)
    at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigurationManager.java:52)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:136)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
  13. The github files are .zip files and should be unzipped.
  14. Offline


    there's no jar in there though, but i'll try it

    Edit: I'm not really sure how this plugin is supposed to work unzipped... Why can't we just download a straight up .jar that works right after you drop it on the server? Just like every other plugin. Why does this one need an extra step?
  15. Umm, what are you typing about?:)

    I just tried to download it by clicking on the download link in the first post. That got me a file named CreativeGates 1.3.1.zip. Unzipping that file resulted in another file named CreativeGates.jar, which is what is copied into your plugins directory. That's it.
  16. Offline


    ok, im on a mac and it actually gives me a folder... let me try a different uzipper​
  17. So am I. :) I'm running Lion (10.7), but the behavior was the same in Snow Leopard (10.6) using the built-in archive utility. If you are using something else, then I don't know.

    Oh, I'm also using firefox, but safari does the same thing, unless 'open safe files' is on, in which case it automagically unzips the file and leaves the .jar in the download directory (which I strongly suggest turning that off if it's on. Very Bad Idea(tm) from a security standpoint).
  18. Offline

    Drei Gyuu

    Will it be possible in the future to have horizontal gates where you can jump into. Thanks Much! :D
    maciek2045 likes this.
  19. Offline


    There's a good chance that you have a plugin loading the world with the working gate, and no plugin loading the world with the gate that crashes everytime you reload the server.
    The only solution is to load the server, use a world loader to load the world with the broken gate, then reload plugins to have creative gates start the gate properly.

    It would be nice, however, if creative gates would just handle unexpected missing gates a little more smoothly, instead of entirely crashing ;)
  20. Offline


    Creative gates do not work with multiverse... Like you can go to a separt world from the Main world. ex: Main Building to PVP but then you cant come back it says "This gate does not lead anywhere" But later it will not work at all, From both sides.
  21. Offline


    Creative Gates DOES work with MultiVerse.

    I have seen what you describe in only one of my worlds and only after restarts, Clocking all gates in the sequence gets them working again.

    I have a theory for what might cause this but not enough info. So please tell me:

    Are the gates having this issue near the spawn area for their respective worlds? Can you tell me the distance in blocks?
    How about the gates in your main world? Distance from spawn?
    What version of Creative Gates are you using?
    Do you use the plugin ForeverALoad?

    I'm thinking this: World.getBlockAt( int x, int y, int z) returning a block with type AIR when the chunk isn't loaded might be the cause.

    (To @Olof Larsson, I'm thinking the issue is running gate.open() <or whatever function activates gates> on a gate in an unloaded chunk and having getBlockAt() return AIR instead of a diamond block. One would still see water as that was never removed during the restart. Thus it would be a valid gate just not 'active'. I have a possible fix, it just needs more testing.)
  22. Offline


    Both: They are at the spawn area.
    Main world:they are like 20 blocks below spawn
    I am using 1.3.1 with RB: 1185
    I do not know nor use the "ForeverALoad" plugin.
    it works only with world to the same world but it has issues with multiworlds.
  23. Offline


    Thanks for the info.

    In worlds.yml (MultiVerse config) do you have 'keepspawninmemory' set to true?
    In the server log does MultiVerse load [the worlds and their spawns] before Creative Gates?

    From what you've said, I'm not sure my theory is right anymore. :( Would you be willing to make a copy/backup of your server and send it to me (plugins, worlds and all) for testing purposes? (For testing purposes only; will delete when I am done. If yes just PM me.)
  24. Another affirmative for CreativeGates working with Multiverse. When I was having problems with 'Gates shutting down a gate I built, the console would show that the plugin loaded, but for some reason didn't detect the diamond block.
  25. Offline


    It would take to long to upload all of my files. And due to me hosting my server on my pc it will make the server lag too.

    Also, Keepspawninmemory is on in every world

    These are my plugins:
    Show Spoiler


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  26. Offline


    i have dimension door installed and i have 1.3.1 of creativegates but i get this error
  27. Shot in the dark here. What build of bukkit are you running? If you're not sure just post your entire bukkit startup sequence. It'll at least give us some info if you include everything.
  28. Offline

    Olof Larsson

    Update your craftbukkit version.
  29. Offline


    An interesting thought: would it be possible to have horizontal gates?
    maciek2045 likes this.
  30. Offline


    oh sorry i have 1185 had it before it hit home page lol
  31. Offline


    Ok please bare with me I just started modding MC today, but I can't figure out for the life of me how to edit permissions for this, I am using McAdmin on a Servercraft.co server using Bukkit and Essentials. If anybody could point me in the right direction on how to edit permissions I would be extremely grateful. I keep trying to copy paste the

    children: creativegates.create: true creativegates.destroy: true creativegates.use: true creativegates.create: description: create gates default: true creativegates.destroy: description: destroy gates default: true creativegates.use: description: use gates default: true

    Into my different permissions folder and I'm pretty sure that's not correct... again sorry for the newb question. I love this mod! It works great! I just can't get it to work for anybody else but me on my server.

Share This Page