Inactive [TP] ButtonWarp v1.1 - Teleport using buttons with price/reward/custom messages [953]

Discussion in 'Inactive/Unsupported Plugins' started by Codisimus, Mar 18, 2011.

  1. This page will no longer be updated. Please follow this project at the Bukkit Dev Page

    ButtonWarp (Previously DungeonReward) - Teleport using buttons with price/reward/custom messages:
    Version: 1.1 (7/16/2011)
    Supports iConomy, BOSEconomy, Essentials, Permissions
    Download Page

    This plugin is used to reward a player with money for reaching a certain region of the world.
    Or you can use it as a simple teleport using buttons.
    Money is added/subtracted when the user presses the button, the user is then teleported to a set location.

    If you are interested in this plugin be sure to check out PhatLoots.

    • Buttons can also teleport users without giving any reward.
    • Deny taking items to a new World
    • Custom messages
    • Option to not teleport on button press (only charge/display message)
    • Set a cooldown time
    • Rewards can be negative to charge users to warp.
    • Set different reward values for different dungeons.
    • List and locate teleport locations.
    • Send money to player/bank account
    • Take money from player/bank account
    • Uses iConomy, BOSEconomy or Essentials to give users money.
    • Permissions to limit players from using, getting rewards, and using commands.
    • Included in CraftBukkitUpToDate for easy updating (make sure you come check the changelog if somthing is not working right)
    Commands can be written as /buttonwarp or /bw
    Show Spoiler

    • /bw make [Name] - Makes Warp at current location
    • /bw make [Name] nowarp - Makes a Warp that doesn't teleport
    • /bw move [Name] - Moves Warp to current location
    • /bw link [Name] - Links target button with Warp
    • /bw unlink [Name] - Unlinks target button with Warp
    • /bw delete [Name] - Deletes Warp and unlinks buttons
    • /bw amount [Name] [Amount] - Sets amount for Warp
    • /bw source [Name] server - Generates/Destroys money
    • /bw source [Name] [Player] - Gives/Takes money from Player
    • /bw source [Name] bank [Bank] - Gives/Takes money from Bank
    • /bw msg [Name] [Msg] - Sets message recieved after using Warp
    • /bw time [Name] [0'0'0'0] - Sets cooldown time for using Warp
    • /bw type [Name] [Type] - Sets cooldown type for using Warp
    • /bw list - Lists all Warps
    • /bw locate [Name] - Gives location of Warp
    • /bw rl - Reloads ButtonWarp

    Permission Nodes:
    Show Spoiler

    • buttonwarp.use - Needed to be able to use the warp
    • buttonwarp.getreward - Needed to be able to receive money
    • buttonwarp.make
    • buttonwarp.amount
    • buttonwarp.source
    • buttonwarp.msg
    • buttonwarp.time
    • buttonwarp.type
    • buttonwarp.admin.move
    • buttonwarp.admin.list
    • buttonwarp.admin.locate
    • buttonwarp.admin.freewarp

    NOTE: New Tutorial video, please watch before asking a question.

    Old Versions + ChangeLog can be found at Download Page
    Show Spoiler

    Version 1.1 (7/16/2011)
    • Fixed nowarp
    Version 1.0 (6/26/2011)
    • Improved OP options
    • Updated Economy support
    • Fixed custom messages
    • Added rl command
    Version 0.9 (6/15/2011)
    • Added option of denying warp if trying to take items to a different world
    • Event is now cancelled if the warp event is cancelled
    Version 0.8 (6/12/2011)
    • Cleaned up code/fixed errors
    Version 0.7.5 (6/4/2011)
    • Cleaned up errors and added error messages
    Version 0.7.4 (6/3/2011)
    • Various fixes and code cleanup
    Version 0.7.3 (6/3/2011)
    • Added Essentials econ support
    Version 0.7.2 (5/20/2011)
    • Fixed ArrayIndexOutOfBounds '12' error
    Version 0.7.1 (5/16/2011)
    • Fixed creation of 'nowarp' warps
    Version 0.7 (5/15/2011)
    • Fixed location saving (no more looking straight up/down)
    • Actually fixed /bw make
    • Changed permission nodes
    • Added commands such as /bw source
    • Fixed all money issues
    Version 0.6.1 (5/4/2011)
    • Updated to iConomy 5
    • Few various fixes
    Version 0.6 (4/29/2011)
    • Fixed reload issues
    • Added custom messages
    • Fixed bank support
    • Added option to not teleport on button press (only charge)
    • Added cooldown
    • Renamed to ButtonWarp
    • Rewrote/Cleaned up code
    Version 0.5 (4/15/2011)
    • Improved Multiworld support
    • Many various fixes
    Version 0.4.1 (3/31/2011)
    • Few minor fixes
    • Works with build #612
    Version 0.3.3 (3/24/2011)
    • Fixed payment issues
    • Fixed Permission issues
    • changed dungeonreward.reward permission node to dungeonreward.amount
    Version 0.3.2 (3/22/2011)
    • Added confirmation messages (took out that you could set your own message)
    • Added a check to make sure the balance has enough money
    Version 0.3.1 (3/20/2011)
    • Fixed negative value adding money to account
    Version 0.3 (3/19/2011)
    • Fixed unknown command spamming chat
    • Fixed no Economy message spamming
    • Improved /reward list output
    • Added /reward msg (dungeonreward.msg) to set a custom message for when to press the button
    • Add option of negative value for paying to use warp
    Version 0.2 (3/19/2011)
    • Improved /reward make command (no more targeting, saves direction you are facing)
    • Added multiworld support
    Version 0.1 (3/18/2011)
    • Initial Release
  2. Offline


    Hey man, I'm really looking forward to use this plugin, although it installed fine (created the files etc.) it doesn't read my permission nodes, I added the use nodes for everyone and the creation nodes for admins, though any command we try we get the "You do not have permission" message. It doesn't give any errors in the console and it loads fine. I'm using the latest bukkit version aswell for permissions.

    Edit: I'm using the latest of Groupmanager
    Edit 2: Works fine now after a couple of reloads, except, while running your plugin all of my /money & /bank commands won't work, however the iConomy system itself keeps running.
  3. Offline


    Could you add a feature that allows a button to teleport someone to their /sethome
  4. UPDATE!

    I added a reload command but I doubt it will help :(
  5. Offline


    Aww no essentials /home support?
  6. Essentials doesn't have a good API to work with :(
  7. Offline


    Updated to 1.0, though still no /money & /bank commands, any clue what this might be? No console errors either. It just tells me: Unknown console command: type "help" for help.

    And when I turn off buttonwarp the commands return.

    Thanks in advance.

  8. Offline


    Darn, well if you get around to it that would * GREATLY * appreciated.
  9. The only reason I was able to support essentials econ was thanks to coding done by Niji
  10. Offline


    Why would anyone use Essentials Eco :)
    Codisimus likes this.
  11. Offline


    Seems like it needs an update to work :3
  12. Offline


    I'm getting this error ... everything is up to date, i'm using Recommended Build: 953 (MC: 1.7.2)

    Code (Text):
    1. 2011-07-02 22:23:35 [SEVERE] Error occurred while enabling ButtonWarp v1.0 (Is it up to date?): tried to access field ButtonWarp.Warp.economy from class ButtonWarp.ButtonWarp
    2. java.lang.IllegalAccessError: tried to access field ButtonWarp.Warp.economy from class ButtonWarp.ButtonWarp
    3.     at ButtonWarp.ButtonWarp.loadConfig(
    4.     at ButtonWarp.ButtonWarp.onEnable(
    5.     at
    6.     at
    7.     at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    8.     at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    9.     at org.bukkit.craftbukkit.CraftServer.enablePlugins(
    10.     at net.minecraft.server.MinecraftServer.e(
    11.     at net.minecraft.server.MinecraftServer.a(
    12.     at net.minecraft.server.MinecraftServer.init(
    13.     at
    14.     at
    Any idea?
  13. Offline


    time after time the warps get brocken and anyone that warp there with button got stuck into ground and dies.. why and how to fix it?
  14. are you using the latest bukkit build?
  15. Offline


  16. Offline


    hey @Codisimus
    my server has been having random lockups and a few times now my players have said that it has happened at the exact moment they pressed a button warp button, there's nothing in the log so I can't give any more info than that unfortunately, but maybe know that you know there's a problem if you looked you might find the cause?
  17. Offline


    Codismus on my server won't work! Why not? [creeper] [lava]
  18. Offline


    >:O It still doesn't work on my server >:O
  19. Offline


    :mad: I'm mad now.
  20. Offline


    This is so amazing! It helped my server so much! It opened the door for so much more stuff I can do!

    Come join my server that has this mod:
    No Hamchi! On From 10,11,or 12 a.m to 10,11, or 12 p.m eastern standard time united states
  21. Offline


    Hey everything sets up correctly but when i go to use it, i get a error,

    22:38:04 [SEVERE] Exception in thread "Thread-30"
    22:38:04 [SEVERE] java.lang.NullPointerException
    22:38:04 [SEVERE] at ButtonWarp.Warp.receive(
    22:38:04 [SEVERE] at ButtonWarp.Warp.access$200(
    22:38:04 [SEVERE] at ButtonWarp.Warp$

    I set it to a test warp at 5 but here is the error I get. any advice?
  22. Offline


    I use essentials also and can not get it to work.
  23. Your plugins are kind of runescape-minecraft mix, its great!
  24. Offline


    Getting this error,

    19:47:07 [INFO] [ButtonWarp] Load failed, saving turned off to prevent loss of data
    19:47:07 [SEVERE] java.lang.ArrayIndexOutOfBoundsException: 11
    19:47:07 [SEVERE] at ButtonWarp.SaveSystem.loadFromFile(
    19:47:07 [SEVERE] at ButtonWarp.ButtonWarp.onEnable(
    19:47:07 [SEVERE] at
    19:47:07 [SEVERE] at
    19:47:07 [SEVERE] at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    19:47:07 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    19:47:07 [SEVERE] at org.bukkit.craftbukkit.CraftServer.enablePlugins(
    19:47:07 [SEVERE] at net.minecraft.server.MinecraftServer.e(
    19:47:07 [SEVERE] at net.minecraft.server.MinecraftServer.a(
    19:47:07 [SEVERE] at net.minecraft.server.MinecraftServer.init(
    19:47:07 [SEVERE] at
    19:47:07 [SEVERE] at
    19:47:07 [INFO] ButtonWarp 1.0 is enabled!
  25. Offline


    Every time I 'stop' the server and restart it.. My .save gets corrupted or something?
    I'm using build 953.

    Code (Text):
    1. 14:51:22 [INFO] [ButtonWarp] Load failed, saving turned off to prevent loss of data
    2. 14:51:22 [SEVERE] java.lang.ArrayIndexOutOfBoundsException: 11
    3. 14:51:22 [SEVERE]     at ButtonWarp.SaveSystem.loadFromFile(
    4. 14:51:22 [SEVERE]     at ButtonWarp.ButtonWarp.onEnable(
    5. 14:51:22 [SEVERE]     at
    6. 14:51:22 [SEVERE]     at
    7. 14:51:22 [SEVERE]     at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    8. 14:51:22 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    9. 14:51:22 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.enablePlugins(
    10. 14:51:22 [SEVERE]     at net.minecraft.server.MinecraftServer.e(
    11. 14:51:22 [SEVERE]     at net.minecraft.server.MinecraftServer.a(
    12. 14:51:22 [SEVERE]     at net.minecraft.server.MinecraftServer.init(
    13. 14:51:22 [SEVERE]     at
    14. 14:51:22 [SEVERE]     at
    15. 14:51:22 [INFO] ButtonWarp 1.0 is enabled!
    16. 14:51:22 [INFO] [ButtonWarp] Successfully linked with Permissions!
    17. 14:51:22 [INFO] [ButtonWarp] Successfully linked with iConomy 5!
    This is my save.
    Code (Text):
    1. FRAHFRAH;;0;ikkyino;world;-338.26678139369784;52.0;-285.77737595668316;7.949937;116.69653;none;user;world,-334,53,-285,ikkyino,187'14'47'34,~;
    2. testages;;0;server;world;-346.4490329126073;52.0;-288.15347120526025;10.649938;73.34654;none;user;;
    3. testages2;;0;server;;;;;;none;user;;
    When I do /bw list, it only shows FRAHFRAH:0, testages:0, I'll try and find out exactly what does this and try to replicate it's behavior each time.

    EDIT: Also when using /bw rl, it duplicates everything :/ (which might be causing the issue in the first place)

    EDIT2: Okay, I've narrowed it down to everytime I make a warp that doesn't warp you (nowarp), after reloading the server it throws out that error up top.
  26. Offline


    Hey im having problems getting the warping between worlds to work. I make it perfectly and it says you cant take items to another world. I have looked everywhere to try and fix this any ideas?
  27. there is a setting in the config to turn that off
  28. Offline


    hey could u update this and phatloot? i really want them on my server ;P thanks.
  29. I just updated them, is something not working?
  30. Offline


    it says that its not up to date :eek:

Share This Page