Inactive [TP] BedHome v0.4 - /home returns to bed [1.2.5 R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by freman, May 19, 2011.

  1. Offline

    freman

    BedHome - /home returns to bed

    Version: v0.4
    1. Make a bed
    2. Sleep in the bed
    3. Using /home will return you to that bed
    Features:
    • /home
    • /bed - does the same as /home
    Download BedHome

    Changelog:
    Version 0.4
    • Updated or Bukkit 1.2.3 R0.2
    Version 0.3
    • Hardcoded locale
    Version 0.2
    • Added command alias bed
    • Switched to using player location not bed location - should prevent falling through floors.
    Version 0.1
    • Releasing my awesome plugin
    Support:
    Alcohol makes coding in Java more fun, Caffeine makes it possible to do after a day of coding in other languages at work - both of these habits are expensive - Want to help me feed my addictions and make more, better plugins faster? Consider hitting the button below.
    [​IMG]
     
    Tomuxass, conzantis and dark_hunter like this.
  2. Offline

    Yobraza

    Dont work
     
  3. Offline

    angus22397

    I don't really see much point in this, but most of ur plugins are great Freman.
     
  4. Offline

    freman

    How so?


    we have no other home/spawn plugins, and I generally oppose using commands - this is a simple drop in that works off the beds, with low overheads and no real other features than what it says on the box. (If the compass pointer setting ever gets fixed, it'll also set your compass to point at the bed, figure that's your home after all)
     
  5. Offline

    angus22397

    I oppose commands too =P
     
  6. Offline

    Lomz

    Requesting permissions. :)
     
    tjb0607 likes this.
  7. Offline

    Liger_XT5

    With the warps and player teleporting, I've left the the home plugins alone. But this I see of use. Would be nice for permissions. I've got mine set that the default group is very limited and no building. I'd rather keep that group as limited as possible. I'm not a fan of the whitelist. I like visitors, but not random joining griefers and exploiters.
     
  8. Offline

    freman

    And exactly how do you see permissions working? nothing about this plugin alters anything in the world. I will support permissions when bukkit has permissions.
     
  9. Offline

    DrBowe

    Out of curiosity, is this multi-world aware? AKA, you can have two 'bed spawns' in two separate worlds?
     
  10. Does this work with the latest craftbukkit build?
     
  11. Offline

    sukosevato

    Could you edit this so that /bed does the same thing?

    I use beds as respawn point and I want people to be able to go back to their spawn point by doing /bed or something.

    Without sacrificing the /home plugin we have.
     
  12. Offline

    dagasc

    I'm sorry to say, but the plugin don't work. Would you please update?
    1) I got error message after trying to use /home command. (after sleeping to set the bed as home)
    2) Server went mad, it got into a restarting server loop. I had to delete the plugin to join server again.

    I would also like to see the option to choose between /home, /bed (as sukosevato say) or just use both. :)
    And, an optional send text to chat "<user> just got home by command" in yellow or something, would be neat!

    Thanks.
     
  13. The other admin from my server complied a modified version of this plugin that uses /bed instead.

    If freman is no longer active, he might upload it to mediafire for a few people.
     
  14. Offline

    dagasc

    I would love that.
     
  15. Offline

    Lykkepillen

    Works great, but would be neat if it worked in the Nether too now that its a part of the regular minecraft server.

    Thanks in advance
     
  16. Offline

    freman

    I have to update the plugin before it works in multi-world/nether or however it's being done.

    Sorry there's been no reply to the posts in this thread I must have forgotten to watch it.
     
  17. It works multi-world for us.
     
  18. Offline

    Semirotta

    does not work.
     
  19. Offline

    dagasc

    Don't work, I have the same problems as before.
    1. Makes server go into a reboot-loop when I try to stop the server, all fine when I deactivate the plugin.
    2. Also got error message when trying to go /home after sleeping and setting home.
     
  20. Offline

    freman

    Does not help... What is your issue?
    I've never experienced (1), and I suspect (2) is a conflict with another plugin? try using the new /bed alias
     
  21. Offline

    Semirotta

    slept in bed, /home or /bed didnt bring me back to my bed :/
    gives me internal error occurred
     
  22. Offline

    freman

    Can you paste the error please?
     
  23. Offline

    Semirotta

    Code:
    2011-07-18 15:13:07 [INFO] Starting minecraft server version Beta 1.7.3
    2011-07-18 15:13:07 [INFO] Loading properties
    2011-07-18 15:13:07 [INFO] Starting Minecraft server on 5.199.229.112:25565
    2011-07-18 15:13:07 [WARNING] **** SERVER IS RUNNING IN OFFLINE/INSECURE MODE!
    2011-07-18 15:13:07 [WARNING] The server will make no attempt to authenticate usernames. Beware.
    2011-07-18 15:13:07 [WARNING] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    2011-07-18 15:13:07 [WARNING] To change this, set "online-mode" to "true" in the server.settings file.
    2011-07-18 15:13:07 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-945-g73697a4-b1000jnks (MC: 1.7.3)
    2011-07-18 15:13:07 [SEVERE] Could not load 'plugins\CommandBook.jar' in folder 'plugins': 
    java.lang.NoClassDefFoundError: com/sk89q/minecraft/util/commands/CommandException
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Unknown Source)
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:168)
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:207)
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:130)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:128)
        at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:97)
        at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigurationManager.java:51)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:132)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.ClassNotFoundException: com.sk89q.minecraft.util.commands.CommandException
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        ... 11 more
    2011-07-18 15:13:07 [SEVERE] Could not load 'plugins\MinecraftRestartController.jar' in folder 'plugins': 
    java.io.FileNotFoundException: Jar does not contain plugin.yml
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:64)
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:207)
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:130)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:128)
        at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:97)
        at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigurationManager.java:51)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:132)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    2011-07-18 15:13:07 [INFO] [Permissions] (Phoenix) was Initialized.
    2011-07-18 15:13:07 [INFO] Preparing level "world"
    2011-07-18 15:13:07 [INFO] Preparing start region for level 0 (Seed: -1623774494)
    2011-07-18 15:13:08 [INFO] Preparing start region for level 1 (Seed: -1623774494)
    2011-07-18 15:13:08 [INFO] Preparing spawn area: 52%
    2011-07-18 15:13:08 [INFO] BedHome version 0.2 - Copyright 2011 - Shannon Wynter (http://fremnet.net) is enabled :)
    2011-07-18 15:13:08 [INFO] BOSEconomy: Located Phoenix Permissions 2.7.4.
    2011-07-18 15:13:08 [INFO] BOSEconomy 0.6.2 enabled.
    2011-07-18 15:13:08 [INFO] CraftBukkitUpToDate version 2.5.7 is enabled!
    2011-07-18 15:13:08 [INFO] [Permissions] version [2.7.4] (Phoenix)  loaded
    2011-07-18 15:13:09 [INFO] CButD: CraftBukkit is up to Date
    2011-07-18 15:13:09 [INFO] Found and will use plugin Permissions v2.7.4
    2011-07-18 15:13:09 [INFO] CursedLands version 0.9 is enabled!
    2011-07-18 15:13:09 [INFO] FenceDoor By Ashour version 2.5 enabled.
    2011-07-18 15:13:09 [INFO] [GravelClay] version 1.3.1 by [Darklust] is enabled.
    2011-07-18 15:13:09 [INFO] HigherExplosives: Using Permissions plugin that looks like version 2.7.4
    2011-07-18 15:13:09 [INFO] HigherExplosives: There is no default config for Creeper. Those explosions will be left unaffected unless they have a world specific configuration.
    2011-07-18 15:13:09 [INFO] HigherExplosives: Default config for TNTPrimed is:
    Conf(
      activeBounds=Bounds(),
      radiusMultiplier={  
        (chance:1.0, value:2.0)
      },
      playerDamageMultiplier=no multiplier configured. will leave unaffected,
      creatureDamageMultiplier=no multiplier configured. will leave unaffected,
      itemDamageMultiplier=no multiplier configured. will leave unaffected,
      tntFuseMultiplier=no multiplier configured. will leave unaffected,
      preventTerrainDamage=not configured, will be left unaffected,
      fire=not configured, will be left unaffected,
      yield=100.0,
      yieldSpecific=no specific block yields configured,
      tntPrimePrevented=not configured, will be left unaffected,
      tntPrimeByHand=no sub-configuration specified,
      tntPrimeByFire=no sub-configuration specified,
      tntPrimeByRedstone=no sub-configuration specified,
      tntPrimeByExplosion=no sub-configuration specified,
      creeperCharged=no sub-configuration specified,
    )
    2011-07-18 15:13:09 [INFO] HigherExplosives: There is no default config for Fireball. Those explosions will be left unaffected unless they have a world specific configuration.
    2011-07-18 15:13:09 [INFO] HigherExplosives 2.0 primed and ready
    2011-07-18 15:13:09 [INFO] Loading Config File...
    2011-07-18 15:13:10 [INFO] [mcMMO] Permissions enabled.
    2011-07-18 15:13:10 [INFO] mcMMO version 1.0.35 is enabled!
    2011-07-18 15:13:10 [INFO] Memory max: 1037959168 bytes
    2011-07-18 15:13:10 [INFO] Memory total: 1037959168 bytes
    2011-07-18 15:13:10 [INFO] Remote Toolkit Plugin V0.45b enabled!
    2011-07-18 15:13:10 [INFO] [MobBounty] v4.05 (Oxygen) enabled.
    2011-07-18 15:13:10 [INFO] [MobBounty] Developed by: [Mattera, Steven (IchigoKyger)].
    2011-07-18 15:13:10 [INFO] [MobBounty] Special Thanks to: nijikokun for the Register API.
    2011-07-18 15:13:10 [INFO] [MobBounty] Config loaded.
    2011-07-18 15:13:10 [INFO] [MobBounty] Permission plugin was found (Permissions v2.7.4).
    2011-07-18 15:13:10 [INFO] [MobBounty] Payment plugin was found (BOSEconomy v0.6.2).
    2011-07-18 15:13:10 [INFO] Pigasus: Permissions 2.7.4 found
    2011-07-18 15:13:10 [INFO] Pigasus v0.1 is enabled for worlds: [world]
    2011-07-18 15:13:10 [INFO] PC: Loading PluginControl Version 1.0
    2011-07-18 15:13:10 [INFO] PC: Using Nijikokun's Permission plugin
    2011-07-18 15:13:10 [INFO] Read level-name: world
    2011-07-18 15:13:10 [INFO] PC: PluginControl started
    2011-07-18 15:13:10 [INFO] Shattered version 1.0 loaded.
    2011-07-18 15:13:10 [INFO] SignHeal V1.6 Enabled!
    2011-07-18 15:13:10 [INFO] SignLift - Copyright 2011 - Shannon Wynter (http://fremnet.net)
    2011-07-18 15:13:10 [INFO] SignLift version 0.7 is enabled :)
    2011-07-18 15:13:10 [INFO] Stackable: Configuration file loaded.
    2011-07-18 15:13:10 [INFO] Stackable: Version 0.5.1 enable.
    2011-07-18 15:13:10 [INFO] Done (0,286s)! For help, type "help" or "?"
    2011-07-18 15:13:14 [INFO] semirotta [/5.199.229.112:52393] logged in with entity id 121 at ([world] 57.03125, 120.0, -22.59375)
    2011-07-18 15:13:14 [SEVERE] Could not pass event PLAYER_JOIN to BedHome
    java.lang.NumberFormatException: For input string: "120,099998,-22,500000"
        at sun.misc.FloatingDecimal.readJavaFormatString(Unknown Source)
        at java.lang.Double.parseDouble(Unknown Source)
        at au.net.fremnet.bukkit.BedHome.BedHomeLocation.loadLocation(BedHomeLocation.java:94)
        at au.net.fremnet.bukkit.BedHome.BedHomePL.onPlayerJoin(BedHomePL.java:37)
        at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:244)
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:332)
        at net.minecraft.server.ServerConfigurationManager.c(ServerConfigurationManager.java:124)
        at net.minecraft.server.NetLoginHandler.b(NetLoginHandler.java:97)
        at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:74)
        at net.minecraft.server.Packet1Login.a(SourceFile:43)
        at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
        at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:40)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:91)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    2011-07-18 15:13:19 [INFO] The automatic update-Check only work every 6 hours, the last check was 57 minutes ago.
    2011-07-18 15:13:22 [INFO] semirotta: Added 25000 to time
    2011-07-18 15:13:26 [INFO] semirotta: Added 1000 to time
    2011-07-18 15:13:31 [INFO] semirotta: Added 3000 to time
    2011-07-18 15:13:54 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'bed' in plugin BedHome v0.2
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:320)
        at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:713)
        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:677)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:670)
        at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
        at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.NumberFormatException: For input string: "120,099998,-22,500000"
        at sun.misc.FloatingDecimal.readJavaFormatString(Unknown Source)
        at java.lang.Double.parseDouble(Unknown Source)
        at au.net.fremnet.bukkit.BedHome.BedHomeLocation.loadLocation(BedHomeLocation.java:94)
        at au.net.fremnet.bukkit.BedHome.BedHome.onCommand(BedHome.java:57)
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
        ... 12 more
    
     
  24. Offline

    freman

    Don't know what CommandBook's problem is... but... commas? that's why it's complaining - you guys use "," for a decimal separator there?

    Try this version, I force the locale (yes, I'm lazy)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jul 16, 2016
  25. Offline

    Semirotta

    wait what? now im confused, ive not changed commandbook's stuff or anything :D all other stuff works just fine but not this plugin of urs ^^

    try what version? force the locale what? :D
     
  26. Offline

    GameFreakDude

    He just updated BedHome from 0.2 to 0.3. Try and see if 0.3 works now.
    First note however the message in the OP about updating to 0.3.
     
  27. Offline

    freman

    Sorry, I should have made myself clearer (It's midnight here)

    I've just updated the plugin to 0.3 - before using the new version please delete the BedHome directory from your plugins (most other people can simply convert their files, but in your case deleting it will be easier in the long run)

    The reason you were having problem with this plugin is I was using String.format("%f,%f,%f") to write the locations to disk, in your part of the world you use , where we use . so instead of writing "21.46292,0.4727,-20.937" it was writing "21,46292,0,4727,-20,937" and getting awfully confused when it came to reading it back in.

    I've gone the lazy way and told java to pretend you live in the US just for writing that string to disk so it writes as I expect (I hope, I should have gone AU at least I can be positive what happens here lol)
     
  28. Offline

    Semirotta

    so what im gonna do is download this plugin again, remove all bedhome stuff and put the stuff all over again and it should work? :D


    EDIT:

    deleted, redownloaded. WORKS. thank you for fast response!
     
  29. Perfect, thanks!
     
  30. Offline

    Xickle

    If the player has multiple beds, typing /home will only tp him to the last bed he slept in, or to any bed he ever slept on(if he types /home multiple times)?
     

Share This Page