Tool items malfunctioning (Residence, WorldEdit, CreativeStick)

Discussion in 'Bukkit Help' started by Retricide, Jun 5, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    CB: 818 | Worldedit: 4.6 | Residence: 2.2 | CreativeStick: .0.6.8


    Since the update to MC 1.6, I've noticed that all the tool items, for nearly all plugins except TelePlusPlus, have stopped working or have started malfunctioning.
    For example, only one tool will work per login, and sometimes it will not work at all for everyone, in which case a server reload usually fixes it.
    On the rare chance the tool does work, it works for every item in the inventory, until the inventory is cleared of the REAL tool item.

    For example, If I give myself the worldedit tool (#269) and the Residence tool (#268), but click first with the worldedit tool, one of two things will happen:
    1) All items will act as the worldedit selection tool, including the residence tool
    or 2) It will not work and no tool will work.

    This isn't specific to this combination, and the same thing happens for the all the worldedit tools (navigation, selection, etc), all residence tools, and iStick/Creative Stick.

    With IStick and Super pick, all items will act as the iStick or Superpick. Right click also does not work for Istick, as it acts as a left click.

    Permissions are setup perfectly as they've worked perfectly before the update, but for some reason all tools are malfunctioning now.

    The tools either stop working entirely (for one person, during their login; or for everyone on the server) or malfunction so all inventory items act as the tool.

    There are no errors.

    Any help/ideas would be much appreciated.

    Just another note: All teleplusplus tools work perfectly, but for some reason WorldEdits navigation tools dont.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  2. Offline


    You might want to post in each of those plugin's threads about the issues. Our support is pretty limited here.
  3. Offline


    I did. It seems like a bukkit problem because it's affecting all of those plugins. Has anything changed in the newest update that could affect items being dedicated as tools?
  4. Offline


    Not really, I'm running a self-compiled version of the 820 source and my world edit and epiczone bone and stick work just fine. Its gotta be a configuration or plugin issue.
  5. Offline


    I've tried reinstalling all three of then with blank data and configs. Still no success.
    Are you using permissions 3.0? I havnt heard of anything else causing problems.
    Maybe essentials?
  6. Offline


    I might try P3 later tonight.
  7. Offline


    Are you using permissions 2.7.4 on a 1.6.6 build?
    What are you using for permissions?
  8. Offline


    using permissions v3 with CB 818 and worldedit is working fine (both left and right clicks)
  9. Offline


    Ugh, thats disgruntling.
    I'll go ahead and list my plugins, I'd appreciate it if someone could list theirs as well, and I could compare for differences...that way I don't need to test every single plugins.

    Plugins: WorldEdit, PvPToggle, WorldGuard, MCDocs, TelePlusPlus, BukkitContrib, VanishNoPickup, HeroChat, Backup, OpenInv, FalseBookExtra, AutoPlant, Residence, FalseBookIC, mcbans, FalseBookCart, FalseBookCore, LogBlockQuestioner, RemoteToolkitPlugin, iConomy, CreativeStick, MagicCarpet, Permissions, Lockette, dynmap, FalseBookBlock, LogBlock, NoWeather, Essentials, Citizens, EssentialsSpawn
  10. Offline


    Still suggest posting in the threads for those plugins, but here ya go regardless:
    • BorderGuard
    • CommandBook
    • ControllerBlock
    • CookieMonster
    • CraftBukkitUpToDate
    • DataLog
    • dynmap
    • EpicZones
    • Factions
    • iChat
    • iConomy
    • iZone
    • Jail
    • Landmarks
    • Locker
    • MCDocs
    • Permissions (2.7 or w/e)
    • PermissionsPlus
    • Reporter
    • SimpleHome
    • WorldEdit
  11. Offline


    Hmmm.. I must think. Try, with JUST WorldEdit, no Permissions, nothing. You can just op yourself and have the commands, derp. I'm trying to see if it's WorldEdit or another plugin that's messed up.

    I also recommend using an older version of Permissions. Find ThrYeti's Permissions thread and get one of those. Oh and Essentials, well, dump it... Lol

    Oh, then try with just Residence, nothing else.
  12. Offline


    @Zaros I already have posted, and ive gotten the same response eveything time, that it must be a bukkit problem. Thank you for your plugins though.

    @sillyrosster I am going to start testing as you adviced, I was just hopig to avoid testing all of my plugins, like I've had to in the past.
    I'm going to start with WE and Residence, then add in P3, then essentials, the the rest...hopefully Ill catch the problem in a preliminary test phase though ^_^.

    Thanks for the help guys, I'm going to start testing when I get home, later today, and I'll tell you how it goes.
  13. Offline


    I hate testing too, but sometimes it's the only way to solve it. Hopefully you find your problem!
  14. Offline


    I've fixed it, and I'm pretty sure it was do to a plugin called PvPToggle, or OpenInv. I installed both of those in the switch to 1.6.6, so it makes sense that I was never plagued by this problem before that. I'm not sure if it's due to both of them, but I know for sure it was one of them, and I've tested too many to go back and figure out which one it was.

    Thanks for all the help guys ^_^
  15. Offline


    No problem.
  16. Offline


    Your Welcome =D
Thread Status:
Not open for further replies.

Share This Page