"the system cannot execute the specified program"

Discussion in 'Bukkit Help' started by Avara Wonderwing, Feb 28, 2013.

Thread Status:
Not open for further replies.
  1. I'm having this issue where everytime I try to run the run.bat file the command line comes up saying "the system cannot execute the specified program" I am using the currently reccomended build and I followed the instructions on the wiki page for installation and creating the run.bat file and have searched all over the internet to no avail. I use windows 7 64bit, I don't really understand what architecture is as I'm using a 64 bit system but my program files folder says x86 so I'm not sure which of those numbers refers to the architecture of my OS. As for the architecture of my java I followed the instructions in the "you need help?" thread but I got this:
    Capture.JPG

    So I don't know if I did something wrong or was in the wrong area or what.

    here's an image of the window I get when trying to run the run.bat file:
    Capture2.JPG

    edit: I took another look at the wiki page and saw the note that stated the craftbukkit.jar part of the run.bat file needs to have the same name as the file I'm using however when I made the changes to the run.bat file to have the exact file name I got the same result: "the system cannot execute the specified program"
    I currently have both the run.bat file and the bukkit server file in a folder on my desktop with nothing else in it.

    edit2: I coppied the java -version comand line directly from the "you need Help?" thread in order to make sure it was entered exactly into the command prompt. Turns out there was a space missing that I didn't see earlier however when I hit enter I got the same issue as with the run.bat file "the system cannot execute the specified program"
    Also with the whole java thing based on my searches all I can make sense of and say is that I just installed both the 64-bit and 32-bit versions of java and the java site said I may be running a 32-bit browser. not sure if that helps.

    edit3: sorry, just saw the rest of the info needed list so I'll post all that here as best I can:
    I'm not using any "wrappers" that I know of
    I am using the craftbukkit-1.4.7-R1.0 version
    I can't find any of the files asked for in step 6
    the command I'm using to run the server is double clicking the run.bat file which contains the text from the wiki page:
    java -Xms1024M -Xmx1024M -jar craftbukkit-1.4.7-R1.0.jar -o true
    PAUSE
    I'm not using any plug-ins
    The only things I've tried have been moving the minecraft.exe and .jar files into the same folder as bukkit and moving the bukkit and run file into my .minecraft folder and .minecraft/bin folder

    as for the other things to try since I'm not using any plug-ins most of it doesn't apply. I have the most recent version of Bukkit and as for the vanilla minecraft server the instructions I found for running that reccomended not doing it unless I was fairly computer savvy, which I'm not, so I haven't done that yet as I'm afraid I might break something working with all that port stuff and everything.

    So can anyone help me out with this? I'll try to get my java thing figured out(my computer has always had difficulties with java) but all in all I'm currently at a loss and I'm afraid I'm not all that computer savvy.

    Thanks in advance

    nevermind, it's fixed now. seems it was a problem with the path java thingy

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 31, 2016
  2. Offline

    Sweatyzana

    Thanks in advance[/quote]
    Try This:
    - Go to Start
    -Right Click Computer
    -Click properties
    -Click Advance settings
    -Click enviromental variables
    -Find PATH and click it
    -Paste what is in there into notepad
    -Change what's in there to C:\Windows;C:\Windows\system32
    -Click Ok
    -Try now.
    -Once you have found out what IPV4 address or Java Version you are using, Paste what you pasted into notepad back into the PATH. (don't keep C:\Windows;C:\Windows\system32 in there).


    I hope this works. :) Reply if you need further help

    Did it work?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 31, 2016
Thread Status:
Not open for further replies.

Share This Page