The Bukkit Consulting Firm - Solving all your Bukkit-related challenges! Thread #2

Discussion in 'Bukkit Help' started by ShootToMaim, Jun 21, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    RiotShielder

    Okay, well I am using /say in the console, it will show up there but NOT in the chat, I gave myself '*' in permissions and use /say in the console, and I was able to see it but other players could not, I was wondering if there is a permission I am missing? Plug-ins that touch chat on my server are HeroChat, Factions, and Essentials.
    Thanks in advance

    EDIT: I gave the default group bukkit.* and we were able to hear it, gonna narrow it down
    EDIT 2: I gave the default group bukkit.command and it is unable to hear, WTF? There are no other nodes for bukkit! Everything listed is a child of bukkit.commandhttp://wiki.bukkit.org/CraftBukkit_commands
     
  2. Offline

    ImminentFate

    you would have to use "bukkit.command.*"
    using "bukkit.command" without the "*" will only give them access to bukkit.command. Which doesn't exist really.
     
  3. Offline

    RiotShielder

    I know! I did give bukkit.command.* and it still didn't work! I was saying that Everything listed on the wiki page is a child of bukkit.command!
     
  4. Offline

    Delocaz

    I heard hawkfalcon likes cute Asian boys.

    Can i join the new BCF? I was member of the original one for a short time.

    Hmm... FOR GOD'S SAKE STOP USING GROUPMANAGER! Also, what's My Worlds? If it's what i think it is, use MultiVerse instead.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 26, 2016
    Williscool98 and chaseoes like this.
  5. Offline

    Omnitv

    ?? da faq?
    Yeah erm.. Ill just do this...

    Feel free to ask maim though.
     
    ShootToMaim likes this.
  6. Offline

    Delocaz

    The cute Asian boys thing? It's a joke in a plugin one of the servers i like uses. When you type /pong it broadcasts a message saying "I heard <player name> likes cute Asian boys."
     
  7. Offline

    hidork

    I tryed to put the ant farm survival map into my bukkit server but it wont spawn me in the right spot. It said to set spawn radius to 0 in bukkit.yml and i did but it just says bukkit.yml empty ignoring it. Please help me and my friend would really like to play this map ty.
     
  8. Offline

    chaseoes

    It's a feature from CommandBook.
     
    Delocaz likes this.
  9. Offline

    Omnitv

    O' Sangeta!
     
  10. Offline

    yourcace

    Hello, I need help aigain with the residence plugin. Does some1 knows how to disable residence in 2 world? Obviously cuz i have multiverse!
     
  11. Offline

    Omnitv

    Not sure if that plugin is multiworld applicable.
     
  12. Offline

    yourcace

    Yes it is
     
  13. Offline

    Omnitv

  14. Offline

    jacklin213

  15. Offline

    Omnitv

    Rawr
     
  16. Offline

    jacklin213

    (Hunter shoots tiger.....). BANG
     
  17. Offline

    Omnitv

    so apple pie?
     
  18. Offline

    jacklin213

    whered that come from?
     
  19. Offline

    lBluel

    I need help with my permissions.
    Could someone tell me what is wrong with my permissions?

    Thank You
     

    Attached Files:

  20. Offline

    Omnitv

    Please post youre permissions.yml at pastie or pastebin.
    Pastebin http://pastebin.com/
    Pastie http://pastie.org/
    Or at the code box Symbol {}#
    and then link them here
     
  21. Offline

    mmorton89

    I keep getting this java error, think you could help me fix it?

    I have already tried java 6 and 7 and they both seem to get java errors.

    Full Java Error Here
     
  22. Offline

    ShootToMaim

    Have you tried re-installing Java?
     
  23. Offline

    mmorton89

    yes I have installed and re-installed java 6 and uninstalled java 6 installed java 7 and re-installed java 7

    and every time I still get this message.

    edit - i have been using sun java jdk maybe i should try openjdk?
     
  24. Offline

    lBluel

  25. Offline

    s4tch

    OK, I've got a challenge that I've been fighting with for days now. Let's call it "phantom logins."

    I have my server running on my media center pc (64-bit Debian stable with 64 bit OpenJDK, java 1.6.0_18, 4GB RAM, Pentium Dual Core). I can log into the server from my desktop in another room over my local network just fine. My friends (remote) can see my server online, and can log in... but they are phantoms!

    Once they're logged in, they can't see my avatar or any actions I take (including killing them). They might appear to me to move around, or just run in place. They can post to the in-game chat, but they can't see messages from me. They see the world chunks loading VERY slowly, they can run around but can't collect items, they don't see animals, and after a minute or two they end up being disconnected (endOfStream).

    In attempting to troubleshoot, I started a (1.3.1) vanilla server, updated a remote client and my own client, and have the same exact problem. I did catch this on the console, which may offer a clue:

    java.io.IOException: Received string length longer than maximum allowed (7168 > 16)
    at db.a(SourceFile:221)
    at bu.a(SourceFile:30)
    at db.a(SourceFile:179)
    at bb.i(SourceFile:240)
    at bb.c(SourceFile:15)
    at bc.run(SourceFile:93)
    However, it could also be unrelated--I haven't seen that error before in the craftbukkit log, and a subsequent login by the same remote player yielded no errors.
    I have the latest craftbukkit running with the latest permissionsbukkit, Multiverse (core, netherportals, portals), and dynmap. I've unloaded all plugins, and it didn't fix the problem. TCP and UDP ports are forwarded; "canyouseeme" confirms it. I start the server with -Xms1048M -Xmx2096M. I've restarted my router. I've restarted my server. I've restarted everything! I've even checked to see if I hit my bandwidth cap!

    Some more backstory: This server was rock solid for a long time--periods of months--until I moved it off of a wired connection and onto a wireless one. I had a lot of trouble (dropped connections, random IP address changes, lost DNS lookups, etc) until I lobotomized NetworkManager and did all my configuration at the lowest possible levels.

    In the middle of dealing with all of this, the phantom login problem started. I thought it was connected to my networking troubles, and continued attacking them (with, I believe, success). Now I have good internet connectivity on my server otherwise (web surfing is fine, spotify works fine, dynmap and minecraft work fine on LAN). In fact, for a few days, everything worked *perfectly* and the minecrafting was going great for local and remote connections.

    And then, out of the blue, the phantom logins started happening again, and they've crippled my server for remote use. I can't tell if it's yet another problem with my Debian networking, or if it's a minecraft/craftbukkit problem.

    Help me, BCF! You're my only hope!
     
  26. Offline

    jacklin213

    s4tch cough
    Code:
    -Xms1048M -Xmx2096M
    well try changin them so that they are same ??

    when are u getting the error code?

    @lBluel use pastebin plzcause ur link is not loading for me
     
    mmorton89 likes this.
  27. Offline

    mmorton89

    The easiest way to reproduce it, is just fly around the chunks will eventually stop loading on my client then it will crash.
     
  28. Offline

    jacklin213

    how much ram do u have and how much ram are u giving the server?
     
    mmorton89 likes this.
  29. Offline

    mmorton89

    8 GB DDR3 and I allocate at max 6 GB but I haven't gone over 2 GB on this server yet.
     
  30. Offline

    jacklin213

    may i c what u use for ur start.bat or run.bat
     
    mmorton89 likes this.
Thread Status:
Not open for further replies.

Share This Page