Problem/Bug Text inside [code] tags may be broken.

Discussion in 'Forum Feedback' started by Zombie_Striker, Aug 8, 2016.

Thread Status:
Not open for further replies.
  1. Whenever someone posts code using the [code][/code] tags, the text is missing line numbers, it's font/color (the text is now black), and it no longer keeps whitespaces/line order when quoting (lines now can stack up on eachother). Example
    Code:
    Code;
       another line with whitespaces;
    
    these lines will stack when quoting;
    these lines will stack when quoting;
    these lines will stack when quoting;
    
    Was this intentional? Are you updating the code tags, or is this a bug?[/code]
     
  2. Errrr...

    Code:
    Test1
    Test2
    Test3
    Code:
    Syntax1
    Syntax2
    Syntax3
    Code:java
    1. SyntaxTag1
    2. SyntaxTag2
    3. SyntaxTag3


    The code tags are broken... Not sure what is happening there, @timtower any idea if Curse is doing something?
     
    Last edited: Aug 17, 2016
  3. Offline

    timtower Ninja on the waves Moderator

    Last edited: Aug 8, 2016
    Zombie_Striker likes this.
  4. Offline

    timtower Ninja on the waves Moderator

    Not yet, I am also just a man in the middle with this stuff.
     
  5. Use
    [syntax=java] code [/syntax] instead.
    Code:java
    1. method();
    2. String variable = "string";
    3.  
    4. for (int i = 0; i < 5; i++) {
    5. if (i %2 == 0) // comment
    6. }

    Btw, it looks much better than the code tags (before they broke) in my opinion ;)
     
  6. @FisheyLP
    It looks nice, but it can easily break your formatting if you edit it or copy and paste it.
     
  7. @Zombie_Striker True so just don't ever edit your post and if you do, repaste the code.
     
  8. Necro-ing this thread, since it has not been fixed yet. Are there any plans on fixing this issue?
     
Thread Status:
Not open for further replies.

Share This Page