! SUPER SIMPLE PLUGIN NEEDED !

Discussion in 'Archived: Plugin Requests' started by master9819, Apr 14, 2014.

  1. Offline

    master9819

    Hello, wondering if some know of or can create a plugin where it stops players from creating Hoppers and beacons. Like when they put the stuff in the item doesn't show up to create.
    I need the latest one possible 1.7.4+
     
  2. Offline

    Decimator

    Essentials has an item blocker section read the config if you have it installed on your server. Just add the item to the banned items list and it will block the crafting and use of them.
     
  3. Offline

    master9819

    I know it will be banned, but I want it to still be in the game as a rare item. There will vote and have a 1/75 of getting it and if they do then its considered a rare item for the server. I just want to disable the crafting of it.
     
  4. Offline

    BartMiner

    Hello master9819

    Is this what you are looking for?

    BanRecipe

    Note: I used the search funtion ;)
     
  5. Offline

    undido

    made the plugin for you jar is in the attached file if you want to compile it yourself or make your own changes I've put the project source on github here https://github.com/undido/mcrecipeblacklist

    If you want to know more about the permission nodes compatibility ect I tried to put as much info as I could on the readme file found here https://github.com/undido/mcrecipeblacklist/blob/master/README.md

    If anyone wants to contribute to it feel free to send pull requests the issues I've had were with planks I also realized that because of the way it reloads it might remove custom added recipes from other plugins

    It was made using bukkit 1.7.8
     

    Attached Files:

    • rbl.zip
      File size:
      2.3 KB
      Views:
      0
  6. Offline

    master9819


    Thanks :)

    undido I don't see the /jar file

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jun 7, 2016
  7. Offline

    undido

    master9819 hey I tried uploading the file to my post but it didn't show up for some reason I've updated the plugin again today so the /rbl reload command shouldn't interfere with other plugins that add custom recipes I've uploaded the jar to github you should be able to download it here https://github.com/undido/mcrecipeblacklist/releases
     
  8. Offline

    master9819

    undido [22:54:43 ERROR]: Could not load 'plugins/recipeBlacklist-v0.1.1.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: undido/recipeblacklist/RecipeBlacklist : Unsupported major.minor version 51.0
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[bukkit.jar:git-Bukkit-1.7.2-R0.3-44-g2f46749-b3067jnks]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:328) ~[bukkit.jar:git-Bukkit-1.7.2-R0.3-44-g2f46749-b3067jnks]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [bukkit.jar:git-Bukkit-1.7.2-R0.3-44-g2f46749-b3067jnks]
    at org.bukkit.craftbukkit.v1_7_R3.CraftServer.loadPlugins(CraftServer.java:357) [bukkit.jar:git-Bukkit-1.7.2-R0.3-44-g2f46749-b3067jnks]
    at org.bukkit.craftbukkit.v1_7_R3.CraftServer.reload(CraftServer.java:799) [bukkit.jar:git-Bukkit-1.7.2-R0.3-44-g2f46749-b3067jnks]
    at org.bukkit.Bukkit.reload(Bukkit.java:288) [bukkit.jar:git-Bukkit-1.7.2-R0.3-44-g2f46749-b3067jnks]
    at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:23) [bukkit.jar:git-Bukkit-1.7.2-R0.3-44-g2f46749-b3067jnks]
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:180) [bukkit.jar:git-Bukkit-1.7.2-R0.3-44-g2f46749-b3067jnks]
    at org.bukkit.craftbukkit.v1_7_R3.CraftServer.dispatchCommand(CraftServer.java:703) [bukkit.jar:git-Bukkit-1.7.2-R0.3-44-g2f46749-b3067jnks]
    at org.bukkit.craftbukkit.v1_7_R3.CraftServer.dispatchServerCommand(CraftServer.java:690) [bukkit.jar:git-Bukkit-1.7.2-R0.3-44-g2f46749-b3067jnks]
    at net.minecraft.server.v1_7_R3.DedicatedServer.aB(DedicatedServer.java:296) [bukkit.jar:git-Bukkit-1.7.2-R0.3-44-g2f46749-b3067jnks]
    at net.minecraft.server.v1_7_R3.DedicatedServer.v(DedicatedServer.java:261) [bukkit.jar:git-Bukkit-1.7.2-R0.3-44-g2f46749-b3067jnks]
    at net.minecraft.server.v1_7_R3.MinecraftServer.u(MinecraftServer.java:558) [bukkit.jar:git-Bukkit-1.7.2-R0.3-44-g2f46749-b3067jnks]
    at net.minecraft.server.v1_7_R3.MinecraftServer.run(MinecraftServer.java:469) [bukkit.jar:git-Bukkit-1.7.2-R0.3-44-g2f46749-b3067jnks]
    at net.minecraft.server.v1_7_R3.ThreadServerApplication.run(SourceFile:628) [bukkit.jar:git-Bukkit-1.7.2-R0.3-44-g2f46749-b3067jnks]
    Caused by: java.lang.UnsupportedClassVersionError: undido/recipeblacklist/RecipeBlacklist : Unsupported major.minor version 51.0
    at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.6.0_65]
    at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637) ~[?:1.6.0_65]
    at java.lang.ClassLoader.defineClass(ClassLoader.java:621) ~[?:1.6.0_65]
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) ~[?:1.6.0_65]
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:283) ~[?:1.6.0_65]
    at java.net.URLClassLoader.access$000(URLClassLoader.java:58) ~[?:1.6.0_65]
    at java.net.URLClassLoader$1.run(URLClassLoader.java:197) ~[?:1.6.0_65]
    at java.security.AccessController.doPrivileged(Native Method) ~[?:1.6.0_65]
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190) ~[?:1.6.0_65]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:77) ~[bukkit.jar:git-Bukkit-1.7.2-R0.3-44-g2f46749-b3067jnks]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:62) ~[bukkit.jar:git-Bukkit-1.7.2-R0.3-44-g2f46749-b3067jnks]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306) ~[?:1.6.0_65]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247) ~[?:1.6.0_65]
    at java.lang.Class.forName0(Native Method) ~[?:1.6.0_65]
    at java.lang.Class.forName(Class.java:249) ~[?:1.6.0_65]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:40) ~[bukkit.jar:git-Bukkit-1.7.2-R0.3-44-g2f46749-b3067jnks]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:127) ~[bukkit.jar:git-Bukkit-1.7.2-R0.3-44-g2f46749-b3067jnks]
    ... 14 more

    I need it to be 1.7.9

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jun 7, 2016
  9. Offline

    RZeroX

    It Doesn't need to be 1.7.9 i use plugins for 1.7.4 and 1.7.2 and they work Perfectly fine.
     
  10. Offline

    Garris0n

  11. Online

    timtower Moderator Moderator

  12. Offline

    xbenas

    Banning vanilla Minecraft features and mechanics is the best way to lose players.
    IMO you should drop this idea right way.
     
  13. Offline

    KureLK

    Depending on the server.
     
  14. Offline

    master9819

    It's factions xbenas I am banning only the creation of it... It's considered a rare item. They can only obtain it by voting and getting 1/75 chance of getting it.
     

Share This Page