Solved Stuck with "Logging in..."

Discussion in 'General Help' started by Namikon, Dec 4, 2014.

Thread Status:
Not open for further replies.
  1. Offline


    Hello all,

    Maybe I'm wrong here but I will try anyways. Please guide me if this shouldn't be asked here.
    So I have this modpack that I'd like to run on a linux box, and I started to play around with bukkit and cauldron. Since I had serious problems to find out what file has to be placed where and I didn't know how to set it up at all, I thought I'd better setup a vanilla server and play around with that first.
    So I did, but I ran into the following problem:
    When I run the vanilla server, all works fine. I can login, run around, perfect.
    When I run the server with cauldron, I get stuck at the "Logging in..." screen and nothing happens.
    Not even a timeout, the music just plays, the console says "UUID of player .. is ..." and... Nothing.

    There is no error, no exception I can try to fix.
    There are no mods, and no plugins. I have the following files in my server dir:


    I use vanilla Minecraft 1.7.10 client, fresh install from mc launcher.

    This is the logfile "latest.log":
    And here fml-junk and fml-server:

    I added all config files, but they are untouched. They are "vanilla" as they are created by the .jar's.

    So, can anyone tell me what I am missing here?


    Attached Files:

  2. Offline


    Namikon What your missing is an 'ops.json,' 'banned-ips.json,' 'banned-players.json,' and 'whitelist.json' file.
  3. Offline


    Skionz: Right, the log files are made after i completely reset everything to make sure nothing else could cause problems. The current root-folder looks exactly like this:

    When i run :
     java -Xms2048m -Xmx2048m -XX:PermSize=256m -jar cauldron-1.7.10-1.1207.01.198-server.jar
    It boots up, but i can't join as it gets stuck in "Logging in...". But when i do
    java -Xms2048m -Xmx2048m -XX:PermSize=256m -jar minecraft_server.1.7.10.jar
    I can login and play. However, no mods/plugins are available.
    I also just verified it on another Computer, same problem, as described. I'm pretty sure something is wrong with these cauldron jar's. Only option would be to try some other cauldron/bukkit/whatever version for 1.7.10.
    Maybe i'm trying to do the wrong thing; Is this the correct way to setup a server that can handle both bukkit plugins and forge mods? I used to have MCPC+ with 1.6.4 (had TPPI for a while) and it worked just fine. I thought Cauldron is the successor of mcpc so I decided to use that

    Oh, by the way, here is the up to date logfile of the 5-minute-ago try to login to this cauldron server:

    Update: I found out why it is not working. Of course I cannot connect with a Vanilla Client; It has to have Forge Installed. So consider this question as "Solved"
Thread Status:
Not open for further replies.

Share This Page