Solved Strange errors on plugin update check?

Discussion in 'Plugin Development' started by shades161, Aug 5, 2016.

Thread Status:
Not open for further replies.
  1. Offline


    Hey, this is strange. I have several public plugins, all of which have used dev bukkit to check for updates.

    It reads the .rss feed, checks if the versions match, if not, tells the server staff a new update is out.

    This has worked forever, but then within the last couple of weeks, it broken on all of my plugins.

    Here's the error its printing: (Note this is for one plugin, but all of them have the same error, only difference is the class being referenced in the plugin, UpdateChecker, just different location)

    And here is the update checker class:

    It's worked since I starting posting plugins on dev bukkit, and just now it started breaking. I have no idea what could have caused this.

    Did dev bukkit change their rss format (it didn't look obviously different)?
    Anyone else having these issues?? I'd like to fix it... I just have no clue what happened that is causing it to fail in every single one of my plugins.

    Thanks for all the help!
  2. Offline


  3. Omg I'm facepalming so hard right now :D Didn't read your name before.
    shades161 likes this.
  4. Offline


    The error is coming from the "parse" method on this line :
    Document document = DocumentBuilderFactory.newInstance().newDocumentBuilder().parse(input);
    The reason why you are getting this error is because the input is too short/ ends prematurely.
    lineNumber: 1; columnNumber: 1; Premature end of file.
    This is an issue with what is being returned. If there is an online parser, try seeing if the input is valid.
  5. Offline


    Oop, think I found it, looks like they switched from http to https.
    Strange that they changed that now, but whatever. It works again. Looks like it was just a dumb on my part at not noticing they changed the url.
    Anyway, thank you!
Thread Status:
Not open for further replies.

Share This Page