Solved !SOLVED! PermissionsBukkit, check the Config.yml!

Discussion in 'Bukkit Help' started by UnluckyStorm, Feb 13, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Hi there,

    I really, desperately need help.
    I've been spending the night configuring server files that were recently given to me by my server's founder. I was updating plugins and such smoothly, checking all files and exiting them to see what was what. I added a few new plugins...

    In the root Minecraft folder, on FileZilla, for the server, I opened a 'permissions.yml', now, I amn't sure, but all the old permissions that were on the server are now completely gone. No one has their name's colour-coded, everyone is a visitor that can't do anything or interact with anything at all.

    I amn't sure what did this. One minute, the server's fine, the next, I restart, and I can't use the /permission command. If I could, I would add each person to the right groups. But it just spams the "/permission" commands on the chat when I do. Regardless of the command I enter.

    Please, please, please help me. I amn't sure what to do. And my server files are a complete mess.
    Come onto "",

    I honestly need help. I can't sleep without fixing this, and it's 4:40am.
    Please, please...
  2. Offline


    Im not an expert at it but your friend might have used different permissions, check the plugins folder and look for bpermissions, group manager, or any other type of permission folder
  3. Offline


    Of what seems relevant, I have:
    Simple Prefix,
    TradeCraft (One of the things I removed before the server restarted into everything not working. Now I've re-added it).

    These are some of the things I thought relevant.
    In the server's root Minecraft folder, I opened that permissions.yml, it had nothing in it. Are you sure it's nothing to do with that? I think there may have been coding in there, and when I exited and said "Save to local" or whatever the option is, it deleted all the "invisible" information.
  4. Offline


    permissions bukkit is your permissions than :p not permissions.yml
  5. Offline


    Well, I had reformatted a section of code in the permissionsbukkit > permissions.yml,
    It had said:

    " true" I changed the true to false.
    And I didn't save a copy before hand, as I assumed this would have been fine...It was changing one word. I don't understand.

    Bump, honestly, I really need help with this.
    I can't rest easy right now.

    Bump, I still need help with this. Anyone give me some insight?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 24, 2016
  6. Offline


    Hey little kid, or if you're not little stop acting like one. Bumping it and spamming your own post is making me NOT want to help you. You'll have to rewrite your Permissionsbukkit file.
  7. Offline


    Ironic, you're on the Bukkit Help forums, and yet you've not helped at all?
    I bumped twice, once 12 hours ago, once right now.

    If you haven't got anything else constructive to say, perhaps you best not say it.
    And, bumping a thread is far from acting like a "kid", if somebody needs urgent help, they'd like best to make it known.

    Saying that you've not helped at all may be an over-dramatization, thank you for telling me I should rewrite the PermissionsBukkit file.

    Aside from that, "Be mo' constructive with yo' feedback" ~
    Flight of the Concords, Hiphopopotamus Vs. Rhymenoceros.
  8. Offline


    All I have to say to that is look at your thread title. You sound like a kid who just pushed the buttons that turn your monitor upside down and thinks the computer is broken. I'm looking through your op to see what I can do. -.-

    As the other guy said your permissions file seems to be have wiped, this happens occasionally when it has errors, I recommend redoing them or trying bPermissions which lets you add all your permissions ingame.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 24, 2016
  9. Offline


    Responding with insults isn't going to help, you can't seem to grasp this.
    The server was fixed a while ago, it's all been taken care of. Again, thanks for the clarification of what needed to be done, I'll bear that in mind for future reference. I wasn't to keen on reformatting that document, as it was a complete mess.

    Now, despite me trying to respond in a calm manner, you've once again insulted. Perhaps the reason why you have so many posts and yet so little likes is this.
    Also, don't insult someone's intelligence, that's a no-go. "Helpers" don't do that. If you're wanting to become a moderator or admin for this place, perhaps you should try a little harder not to insult, or, assuming you have no patience (which it seems you don't), this really isn't for you.

    And finally, admittedly, the thread title isn't exactly the most well-written thing out there, but, it grabbed the attention of many people and a solution has been found, furthermore, if it was "written by a kid", the title would most certainly have some spelling errors.
Thread Status:
Not open for further replies.

Share This Page