[Solved] Connection Refused: Connect

Discussion in 'Bukkit Help' started by Godleydemon, Jun 9, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Ok this is my problem, I have firewalls turned on my computer along with antivirus for testing purposed only for the time being. I have fire walls turned off on the modem as well. Because I have the Clearwire wimax, I had to go through and port forward the port to the router first. Using the Routers Wan IP address given to it by the modem. I went into the router, port forwarded the IP address with two separate entries of udp and tcp, of at 25565. I started up the server, server connects fine on local machines connecting to the network using the local ip address of But cannot connect using the DNS of my internet. canyouseemy reports my port is infact open and not being blocked by my isp so this has to be a setting somewhere I"m currently missing. I have the server.properties setup correctly as well, I will include this in the post. I am running Java 1.6.0_23-b05 and Craft version 1.6.6 (least thats what is says in the log)

    As I said seems to be correctly configured. This is the router port page.


    As I said previously, its setup correctly as well.

    Server Log:

    Current Server Files:


    It also can't be the computer, because the computer is locally hosting correctly and the firewall and antivirus software is turned off. I'm either missing a setting in my wimax, which I doubt, or I"m missing a setting else where that i have no idea about. Any help is horribly appreciated. Because connecting to outside the house would be grand, but that nasty little connection refused error is driving me bonkers. Thank in advance.

    Attached Files:

  2. Offline


    Make sure the domain name is pointing to the right IP address. If the computer has a dynamic IP address, make it dynamic. As for extenal IP addresses, make sure your ISP gives you a static one aswell. If not, your DN will not work. Also try specifying the port in the DN. Can you connect from outside the LAN using it's IP address?
  3. Offline


    the computer does indeed have a dynamic IP address, and static DNS doesn't matter on whether or not its going to connect or not. Just means it changes from day to day or how long there lease is. Lets say for testing purposes I do not, and I will be using no-ip.com in the future to update the dns when it changes. The port, I've tried that as well when typing in the address. still does not connect. I've done like so.

    [Deleted for Protection]
    [Deleted for Protection]:25565

    neither works as I stated. I get connection refused. Thankfully I do in fact have two separate internet connections in the house. neither is able to see the server when trying to connect.

    after posting this, I had a wtf thing happen. It works >.o no idea how, I didn't even do anything to it, it just suddenly worked for no absolute reason what so ever. sooo.. I guess its fixed? I'll do some further testing, but if anyone wants to put in there input, let me know.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  4. Offline


    If you have a dynamic external, the DNS points to the wrong place.

    If site.net points to your IP at and your lease expires, its not pointing to you anymore.

    Anyways, glad its working.
    Wish every one's problem threads had this much detail.
    klutch2013 likes this.
  5. Offline


    with no-ip.com they have a program that auto updates the dns when it changes so you never have to worry about it. But yeah, guess its working. I know I had tested it before and it hadn't worked, but apparently I can't connect with the Mine Craft client to the server if its locally attached to the network. But machines outside the network can connect. Strangeness really, but it works and I"m happy it works. Hopefully this all helps a few people to be honest, I struggled through the port forward part for some reason. I'm usually pretty good at it, but I think what through me off was the extra steps in the modem. Thanks for responding though ^^
  6. Offline


    Tell me about it.... Im a Networking major and can't figure out how to port forward my (POS) router...

    Glad it works. Hopefully it keeps working.
  7. Offline


    Yeah, I majored in Microsoft certified systems engineering. Which covers servers and networking, so I usually breeze through this stuff. But I actually had to call my service provider to set up the port forwarding on the modem because we're using a strange internet service that really threw me off. But yeah, I guess if anyone else is having problems with Wiimax this will help them XD.
  8. Offline


    I'm having this problem to! help
Thread Status:
Not open for further replies.

Share This Page