[Solved]AW COMMON!@!!!! - this is getting beyond a joke here with nether

Discussion in 'Bukkit Discussion' started by ledhead900, Jun 8, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    ledhead900

    Right No doubt u all hardly noticed my other thread about nether being broken

    well now im using bukkits latest dev build not 818 and apprently nether was fixed some where around early 830's


    I now running bareboned with only essentials installed and for last time I HAVE every part of mulitworld disabled in essentials I am removing my nether folder to let it generate a spanky terriffic new one each time I test bukkits notch nether.

    If anyon tells me to do this again im gonna snap necks.

    look at this crap

    http://pastebin.com/HamCLdbR


    This is what happens on start up and god forbid if anyone dares enter a portal.


    I don't know wtf is going on but ever since 1.6 nether has broken to hell and back when not using a plugin to handle it.


    Edit:

    Does the same BS on a new install of bukkit with nothing not even a pre made map of world.

    It does it worse then in 818 at least then it only crashed server when portal was used now it crashed on generation of world full stop.

    How on bloody earth are you people making nether load and work.
     
  2. Offline

    Lolmewn Retired Staff

    I use OR
    MultiWorld's nether
    Notch's nether
    My own nether from SP.
     
  3. Offline

    Pencil

    Why not get rid of essentials? (Guessing you mean the plugin called) It's shit anyways as it causes 45345345 errors and has 45345 features you probably wont need. Maybe it works then
     
  4. Offline

    ledhead900

    Tempting but I find SKQ plugins error out FAR more then essentials ever has.

    I never had any seriouse issue with essentials and I use all of it well mostly just couple commands I dont use.

    I'm open to moving away but not until Permission 3.x stops acting a like retarded monkey and gets stable until then im sticking on GM


    EDIT

    Tested again on 100% NEW bukkit install touched not a single setting.


    It appears essentials are triggering the on load issue but I think its deeper in bukkit then you think.

    Essentials does even get time to intialize or generate plugin folders before the error happens.
    Funny thing is if you remove essentials and then start server it still stuffs up.

    otherwise it loads fine with out essentials ever installed on first generate, But I have a seriouse issue with how freaking LONG it takes to intitalize the spawns for the worlds using Bukkits method, EW

    I have never seen the Prepearing spawn ever last for more then 2s EVER until now.
    It says prepearing spawn even after its already 100% generated the two worlds.

    I'm going to have chat with Snowloe I think. But Id be damned if im going to wait almost 20s for worlds to prep using noths nether.


    EDIT:

    Re tested on another 100% new generated standard and nether world bukkit install this time with out essentials ever going near it again.

    Guess what seems to dissprove my theory that essentials is a issue for it, as this time it did not even get to 20% on level1 "what assume was nether spawn" preperation it passed thru level 0 but hung on 19% for like 20s then continued then crashed again with the EXACT same issue I posted on OP.

    Seems more like a core BUKKIT bug to me then anything else can anyone else grab bukkit
    DEV and give it a go about 5x on 100% clean installs.

    Mind you I did this on two computers same effects happend to both.

    I just wish a representaive of the bukkit development team would take me seriously and come take a look at this thread, I'm not trying to be a wanker about I just want to help iron this out.
     
  5. Offline

    Pencil

    Lol never said SQks plugins are better, I use whatever I need Not plugin "packages"

    and lol, I never had any issues generating a nether :p I prefer the Bukkit nether anyways as it gives me control over who can put portals ;D
     
  6. Offline

    ledhead900

    Guess but what I need it has and I use all of it the day it gets in the way I will think otherwise I guess till not not gonna mess with a good thing.

    so any new ideas on issue it seems obviouse something is not right that or Im doin it wrong prob the later but I dont see how..

    Latest dev build No good eaither for me wth is wrong me or bukkit I dont get it I really don't everyone it works but.

    Is this not enough Proof, Two pcs so far it does this on.

    here is an upload of 100% Fresh jar.

    Question - is anyone using Java 7 when using this new nether ? I am its only thing I can think of.
    could somone please test it on java 7.

    It looks like an error creating chunks I dont't know wonder if testing this with a pre made nether will fix it.


    Edit:
    F*** my life even one of my many pre made prev smp nethers wont start at all.

    Solved get this it appears 1.6.6 ruined java 7 support no that it did support it but the I always preffered java 7 and I'm sure some of you admins will agree, but I simply installed java 6 and then it all worked 100% fine.


     

    Attached Files:

    Last edited by a moderator: May 16, 2016
  7. Offline

    GmK

    am running 1.6.6 and latest cb and whatnot with java 7 fine, no errors (CentOS)

    But if Java 6 works for you - all good ;)
     
  8. Offline

    ledhead900

    lol yea actually It was a fluke I take back my statement, It appears to be my stackflow is set to low. See I tested java 6 with default java startup bat file.

    Not My servers one with the -xss 128k the issue is due the fact generating a new chunks of nether in 1.6.6 overflows the stack size I set and errors out.

    I increased stack size to 15m and so far it has generated nether from scratch just fine along side the many other java tuning elements I have setup.

    going to test java 7 again.


    I'm not going complain I made mistake it happens I can be thankfull I learned something new about java tho :)
     
Thread Status:
Not open for further replies.

Share This Page