Signs Being Erased in Random Chunks

Discussion in 'Bukkit Help' started by James Lawrence, Jul 5, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    hiro24

    <3

    thanx all for the hard work
     
  2. Offline

    shell64

    if you have a fix, put the link here please, im watching this thread.
     
  3. Offline

    HadrienM

    Does the #974 version contains the fix ?
     
  4. Offline

    Rigby90

    No builds contain the 'fix'.

    Turns out the supposed fix wasn't actually a fix and the problem still exists.
     
  5. Offline

    Ihmemies

    So there is no fix and one probably won't come soon enough. 1.7 has been one big bugfest so far... this is what you get when you upgrade too hastily to new, untested beta builds :S
     
  6. Offline

    Odjit

    We'll be home tonight in a few hours and see what was up with jebs fix.
     
    LlmDl likes this.
  7. Offline

    Ratchet

    looking forward to a fix! :(
     
  8. Offline

    Grimmy777

    Thanks for the update
     
  9. Offline

    hiro24

    has anybody made any progress on this? it's a pretty big problem for us on my server.
     
  10. Offline

    Ratchet

    same
     
  11. Offline

    Ihmemies

    Same :-P Altough in some people's opinion this is perfectly normal and should not be talked about... like the issue would go away or it didn't exist at all.

     
  12. Offline

    hiro24

  13. Offline

    Odjit

    EvilSeph and the bukkit team are all working to try to figure it out, but they're hampered by the fact that this bug isn't really reproducible consistently on normal Minecraft. Hard to see how to fix it, when you can't reliably invoke the problem to occur.

    Yesterday was absorbed by updating AdventureCraft to 1.7.3 (and grocery shopping. Empty post-trip-fridge was =( ), so there hasn't been time to see if Jeb's fix has a different result that the original hacky fix on AC. If you read the blogspot post about it, you'll know so far, its the only way I've seen to actually be able to reproduce the bug. @_@

    So at the moment, its just ear to the floor for AC users having anymore map problems, and testing the different results. This isn't the ideal way to troubleshoot a bug (using singleplayer mod to try to pinpoint a bug mostly affecting SMP), but with this one being so elusive... D: You work with what you've got.

    I too am sad that this won't be as swift a fix as I was hoping. Doesn't help with Jeb on vacation, not that that is bad, but the timing just blows.

    People tend not to talk about things that are out of their control. At this point, any sane server admin knows when to resign themselves to that fact and do the elegant thing and... point at Notch. ;D
     
  14. Offline

    James Lawrence

    yeah, I've had to disable pailstone on mine for now till it's fixed, I hate that cause PS is a great plugin to make things easier.

    with pailstone I could recreate the bug anytime I wanted... I did so 3 times in a row one day just to see if I could..
     
  15. Offline

    hiro24

    hmm.. I don't have pailstone, but I do have redstonechips and falsebook, both of which handle ICs, etc like pailstone. Wonder if it's related.
     
  16. Offline

    Ratchet

    I got the bug a lot more when using PreciousStones, I thought that was the cause, so there must be some link between what these plugins do and the bug. hope that helps :/
     
  17. Offline

    Steeleyes

    I've been having this problem too on the server I admin. It followed a big server crash we had and I initially
    thought it was related to that.

    I have two chunks of chests and signs (in my workshop of all places) that get reset absolutely every time
    I shut the server down and bring it back up again. I unloaded groups of plugins and narrowed it down
    in my case to Redstone chips. I'm not saying it's a redstone chips bug (I think it's a brilliant plugin),
    just that my chests (and signs) are fine when it's disabled and get cleared (or half cleared) every
    server reset when it's resident. I'm not sure if it's a server startup or a server shut down problem
    (MCedit might be able to help me narrow that down).

    Anything I can do to help?
     
  18. Offline

    IncendiaDrakon

    Someone should try reproducing this bug on a freshly generated map. I'm about to generate a new map and place signs/chests everywhere to see if anything happens. :O

    I had this error happen to me. All chests and signs were wiped clean in a general area. (I'm guessing within a specific chunk(s).) I just tried reproducing it by placing a sign with text, then restarting the server, but nothing got erased. I JUST updated to MC 1.7.2 and CB 953 last night.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 17, 2016
  19. Offline

    lukehib

    Happens to me aswell. Seems to happen in one chunk and carry on going.

    It's really bad for my server as players lose all there stuff.

    Any update on the bugfix?
     
  20. Offline

    JanTTuX

    lets just wait and wait until the fix :(
     
  21. Offline

    Flenix

    All the shops in my town have been wiped, we use towny so each shop is perfectly placed into a chunk...

    Not sure about the other shops, but my shop had:
    27 full sets of Diamond and iron armour
    about 18 stacks of TNT
    over 50 stacks of arrows

    Plus all my spare stock of sulpher and ores in the store room.

    As you can imagine, i'm not a happy boy right now. Apparently Jeb gave the Bukkit team something to help with fixing this bug, so i'm hoping they at least release something to fix this soon even if nothing else =/
     
  22. Offline

    Oscarius

    #987: Possibly fixed crashes caused by tile entities under certain circumstances again.
     
  23. Offline

    hiro24

    I can confirm that this does NOT fix the problem
     
  24. Offline

    zipfe

    That's because it has absolutely nothing to do with the chests/signs bug. No idea why Oscarius posted this here.
     
  25. Offline

    Jombi

    I have the issue as well, and brought it up about 1.5 weeks ago. The problem I have is that I have chests/signs all in my house, and in a shop. The shop is maybe 25 blocks from my house. The signs NEVER get erased in the shop. If/when my signs are erased in my house, only half of them get erased. And its not like they're all along a line... they skip around. Sometimes the signs along 1 wall will be erased, and then the next time its the others. The Spawn is almost directly between my house and the shop.

    Another player on the server had it happen. His house is about the same distance from the shop, but on the other side.

    So far its only happened to me after updating Essentials, however I'm sure that's just a coincidence, not an issue with Essentials. However, could it be something that is triggered when Essentials is updated on the server?

    Again, I'm just shooting some suggestions out there. Here's a few pics for reference...

    Facing North East:
    [​IMG]
    Upstairs, standing directly above the chests on the right side in the 1st picture (facing North West):
    [​IMG]
     
  26. Offline

    nubpro

    It's a issues occured in Version 1.7.4
     
  27. Offline

    Jombi

    ...what?
     
  28. Offline

    hiro24

    Similar to the person who posted earlier about unloading Pailstone, I don't use this plugin. HOWEVER, I disabled Redstonechips and the issue is no longer present on my server.
     
  29. Offline

    stellarfirefly

  30. Offline

    monir

    Is there some way to get rid of this bug yet? im running 953
     
Thread Status:
Not open for further replies.

Share This Page