[SEVERE] Cipher data failed. Error report. No one can log in

Discussion in 'Bukkit Help' started by SargentGuava, Aug 16, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Hello! I have found a major problem that apears to only apply to me. But it's still a problem and I'd apreciate help.

    So here is the problem:
    Whenever someone tries to log into my server this error message appears
    Look at what happens when someone tries to log in.

    But before I go more in depth I'd like to give you all he information you might need.

    I have a windows 7

    X64 bit windows home premium

    I have java 7 (or whatever the newest one is)

    I do not have any wrappers. It's a port forward

    The version of craftbukkit is the Recomended build (git-Bukkit-1.3.1-R1.0-b2320jnks)

    I'm not sure what "command" I'm using to run my craftbukkit server with. But I start it with a run.bat file, it's not a host it's a port forward if that's what is meant by "command"

    I am running: world guard, world edit, essentials spawn, essentials chat, essentials, magical spells, virtual chest, PermissionEx, and vault

    Here is the error: http://pastie.org/4500469

    I have tried every logical conceivable thing that I have their of to fix this. Only one worked. And I'll explain that later here is the list:
    Restart server
    Restart computer
    Restart router
    Re-do my port forward
    Redo my port forward with a different port
    Re download craftbukkit
    Have like 15 people see if they could get on (all no)
    Consulting the all knowing google
    Restarting computer and router
    And all the small thing I'm forgetting. If I remember I'll update this

    Then I did 2 things that confirmed it is a craftbukkit issue.

    First I ran craftbukkit with fresh everything and no plugins. The error still occurred.
    So I did one last thing, I ran my old 1.2.5 craftbukkit server. And my friend and 2 others still in 1.2.5 were able to get on.
    Id like to add I had a server for a month or 2 and there were no problems. When I updated to 1.3.1 craftbukkit is when this problem began.

    This error is not on the forums and it is not online anywhere I googled 5 different parts of the error and nothing shows up.

    If any additional information is needed please ask.
  2. Offline


    maybe it has something to do with whitelisting?
  3. Offline


    First, Thank you for providing ALOT of information to us, this will help many Bukkiteers to help resolve your issue. I may use this thread for future reference. :)

    That being said, Looking at some of the errors. HERE these are your main errors.
    I personally have never encountered this types of errors.
    With their first line and end line of their stack trace being this.
    2012-08-15 13:32:30 [SEVERE] javax.crypto.BadPaddingException: Data must start with zero
    ##Ending with this.
    2012-08-15 13:32:30 [SEVERE] Cipher data failed!
    So try removing one of the plugins one by one and try using this command.
    /weather sun 
    This may be the cause of this tack trace on error one I stated on the link.
    Once you have isolated it, and found what plugin that is. Remove it. and test if all is good. :)
    If the problem still persists try sending the error HERE and then you may not be able to use 1.3.1 craftbukkit R1.0, So you may need to wait for the new update and see if the problem is gone.
    some times it is caused by the commuter, It happed to me on another software. Its just a minority.
  4. Offline


    Ok thank you for the help :) once I get back home I'll try removing the whitelist and removing plugins one by one.

    But he thing is, I downloaded a brand new craftbukkit Recomended build. Made a new folder, a new run.bat added no plugins and the problem still persisted. But when I started up my old 1.2 server filled with plugins I'm really surprised never conflicted. For some reason I encountered no problems.

    That's why I believe that it has something to do wih the craftbukkit build. Nice job noticing the /weather sun. I would think that has something to do with essentials but this still happened without any plugins.

    This problem has me stumped so thanks again for he help I really want to resolve this and I'll try all your guys ideas when I get home. (surprise road trip :/ thanks dad)
  5. Offline


    Indeed, this may be an issue with the craftbukkit 1.3.1 R1.0, This is why If all else failsreport the two errors to the link, and run your server on 1.2.5.
    As an add on, the 1.3.1 R 1.0 has Tons of bugs in-em and im not very surprised about it. :p
  6. Offline


    Hi! im back from vacation and i tested more stuff, it still doesn't work :( I did find something out that is quite wierd.

    so here is what works:
    craftbukkit 1.2.5-R4.0
    vanilla 1.2.5

    here is what does not work:
    craftbukkit 1.3.1-R.1.0
    craftbukkit 1.3.1-R2.0
    1.3.1 vanilla

    so yea.... im stumped... again :I i think it has to be something jeb did to 1.3 that might make my rounter not compatible with 1.3 servers? i really dont know
Thread Status:
Not open for further replies.

Share This Page