Serwer Crash[1185]

Discussion in 'Bukkit Help' started by Koksons, Sep 23, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    My server is crashed, In the console I see:
    Maps restart did not help
    I have plugins:
  2. Offline


    Have you tried without your plugins loaded?
  3. Offline


    Turn off another. Until now, the crash was after a long time. Now, immediately after starting the server. Sorry for my English. I use google translator

    After removing all the plugins the problem persists. This wine bukkita.

    I made update to 1190 The problem still exists:
    I ran a copy of the map with 22:13 left bukkit 1190th There is no longer crashed. But I know it breaks down again. Before restarting the map in error was indicated dispenser. I have 100 players onlnie non-stop. I can not have such a malfunction, because I will lose players.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  4. Offline


    i'm having this crash also:
    01:03:34 [SEVERE] java.lang.NullPointerException
    01:03:34 [SEVERE] at net.minecraft.server.EntityLiving.s(
    01:03:34 [SEVERE] at net.minecraft.server.EntityMonster.s(
    01:03:34 [SEVERE] at net.minecraft.server.EntityZombie.s(
    01:03:34 [SEVERE] at net.minecraft.server.EntityLiving.s_(
    01:03:34 [SEVERE] at net.minecraft.server.EntityMonster.s_(
    01:03:34 [SEVERE] at net.minecraft.server.World.entityJoinedWorld(
    01:03:34 [SEVERE] at net.minecraft.server.WorldServer.entityJoinedWorld(
    01:03:34 [SEVERE] at net.minecraft.server.World.playerJoinedWorld(
    01:03:34 [SEVERE] at net.minecraft.server.World.cleanUp(
    01:03:34 [SEVERE] at net.minecraft.server.MinecraftServer.h(
    01:03:34 [SEVERE] at
    01:03:34 [SEVERE] at
    01:03:34 [SEVERE] Unexpected exception
    at net.minecraft.server.EntityLiving.s(
    at net.minecraft.server.EntityMonster.s(
    at net.minecraft.server.EntityZombie.s(
    at net.minecraft.server.EntityLiving.s_(
    at net.minecraft.server.EntityMonster.s_(
    at net.minecraft.server.World.entityJoinedWorld(
    at net.minecraft.server.WorldServer.entityJoinedWorld(
    at net.minecraft.server.World.playerJoinedWorld(
    at net.minecraft.server.World.cleanUp(
    at net.minecraft.server.MinecraftServer.h(

    i think, this commit breaks stability:

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  5. Offline


  6. Offline


    Implementation of update to version 1190 and brings a result of our backup. With 30-50 people online at night, no error occurred. In case of problems will put more logs.
  7. Offline


    It has to do something with.. a Furnace and a Chest.
    So maybe any protection plugin doesn't works correctly?
    Do you know if one of the plugins actually does something with chests, furnaces?
    If you do please replace that one with another plugin and look if it still gives the same errors.
  8. Offline


    I too am having this problem, the server started crashing with the error below, and eventually it wouldn't start at all. I updated the server to 1190, and tried it without any plugins but I still get this when I try to start the server:
    13:01:07 [SEVERE] java.lang.ClassCastException: net.minecraft.server.TileEntityFurnace cannot be cast to net.minecraft.server.TileEntityChest
     13:01:07 [SEVERE] at net.minecraft.server.TileEntityChest.h(
     13:01:07 [SEVERE] at net.minecraft.server.TileEntityChest.h_(
     13:01:07 [SEVERE] at net.minecraft.server.World.cleanUp(
     13:01:07 [SEVERE] at net.minecraft.server.MinecraftServer.h(
     13:01:07 [SEVERE] at
     13:01:07 [SEVERE] at
     13:01:07 [SEVERE] Unexpected exception
     java.lang.ClassCastException: net.minecraft.server.TileEntityFurnace cannot be cast to net.minecraft.server.TileEntityChest
     at net.minecraft.server.TileEntityChest.h(
     at net.minecraft.server.TileEntityChest.h_(
     at net.minecraft.server.World.cleanUp(
     at net.minecraft.server.MinecraftServer.h(
    EDIT: The world won't even load with vanilla minecraft server
  9. Offline


    Next server crash:
    Anyone have any idea? This error can cause the WorldEdit or WorldGuard. Backup map helps to not more than 12 hours

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  10. Offline

    Stevil Knevil

    That certainly does seem to work around the problem, but given that the map doesn't load on vanilla, it looks like this chest/furnace corruption is baked into the saved world data. There must be a better fix that can make sure that the data saved is correct.
  11. Offline


    Yes this fixes the issue. However, it is something Bukkit may need to find a more perm solution for. @Grum ;)
  12. Offline

    Stevil Knevil

    I've done some further work on this and while initially the server appears stable, when I went to the bugged chest and tried to destroy it the server crashed in Chunk.a() (line 417) as it tried to remove the chest by ID. Obviously the ID for this chest is still being reported as Furnace, so the furnace's remove function was called for the chest, resulting in a crash.

    I managed to work around the destruction problem by special casing the remove code for furnaces:

    if (l1 != 0) {
    // CraftBukkit start
    // Check to see if it's a chest as it may be broken
    TileEntity entity =, j, j2);
    if (entity instanceof TileEntityChest) {
    l1 =;
    if (entity instanceof TileEntityFurnace) {
    l1 =;
    // CraftBukkit end
    Block.byId[l1].remove(, i2, j, j2);

    Having done this I was able to destroy the offending chest and that allowed me to restart the map with a vanilla server.

    There may be more elegant ways of fixing this, and it still doesn't explain how it got this way in the first place... as the initial commit msg from Dinnerbone says :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  13. Offline


    How were you able to pin point the chest/furnance so quickly?
  14. Offline

    Stevil Knevil

    I modified the code to output the co-ordinates whenever it found a broken chest. Though there are a number of other places that can crash because of this error, so your best bet so far is probably to remove the chest/furnace in MCEdit.

    To be honest I think a fix that's better than Aforess's is to use this.getTileEntity() rather than as there is better error reporting in there.
  15. Offline


    Hmm.. is my stack trace.
  16. Offline

    Stevil Knevil

    Looking at that stack trace it seems that you're hitting another manifestation of the same issue! It would be nice if someone better than me could come up with a more solid fix (I'm thinking of something like checking for these broken chests when the world loads and patching them up (or even deleting them!) then.

    I'll raise a bug ticket for this, but in the mean time I'll try and roll you a custom CB when I get home tonight to give you a chance of finding the chest that's at fault.

    I couldn't find a bug report about this, so I added one here:

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  17. Offline


    Sounds fair - we have a fix in right now but if Bukkit doesnt pull it - we'll keep having to change the NSH - which isnt an option. I'd rather fix the chest and pray it doesnt come back up.
  18. Offline


    I'm getting this stack trace whenever a player enters a specific area on my server:

    java.lang.ClassCastException: ok cannot be cast to ic
        at ic.h(SourceFile:117)
        at ic.h_(SourceFile:136)
        at eh.e(SourceFile:1197)
        at net.minecraft.server.MinecraftServer.h(SourceFile:369)
    I used MCP to de-obfuscate the class names and got this:
    java.lang.ClassCastException: TileEntityFurnace cannot be cast to TileEntityChest
        at TileEntityChest.h(SourceFile:117)
        at TileEntityChest.h_(SourceFile:136)
        at World.e(SourceFile:1197)
        at net.minecraft.server.MinecraftServer.doTick(SourceFile:369)
    I've run bukkit on this server in the past for 1.7 and previous versions, but have not installed it for 1.8 yet. Could this be the same issue? If so, would either of the solutions proposed by Stevil Knevil or Kainzo fix my problem? I'm familiar with Java but I've never done anything with minecraft past admin stuff, and would appreciate any guidance anyone could offer.

    Edit: Save file is at <Edit by Moderator: Redacted multiupload url>
    Last edited by a moderator: Mar 26, 2019
  19. Offline


    I'm a player in Buce's server and I'm trying to follow Steve Knevil's idea of logging the chest's location through an exception error log message. I've never made a plugin with the Bukkit API before although I'm a little familiar with Eclipse and Java since I've made a few little android apps. I'm mostly familiar with C#.

    I've done the following so far:
    install CraftBukkit that runs a copy of our server's map
    install the Bukkit API and link it to eclipse through a mock up plugin project as per these instructions:

    and now I'm stumped. in what class should I put my code to intercept exception errors? I'm thinking in the blocklistener class but I really am clueless to what I should use as a class+method to 1) extract the faulty chest coords and 2) output stuff in the server's log.

    Bear with me as I crawl forward with my understanding:
    I want to do Steve Knevil's suggestion, which is: "I modified the code to output the co-ordinates whenever it found a broken chest."

    Currently, I'm looking at ways to override a method in to do that but I have little clue as how to start on that. Do I make my own project class using an extends keyword in the declaration, or what?

    The quickest patch we can make to our server would just to output the faulty chests' coordinates and we could just remove them with a map editor. I'm not enough knowledgeable to really help with a more permanent patch solution.

    edit - I have to implement my own event listener. Which kind of event is triggered right before the exception? A chunk loading event? A physics check?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  20. Ok guys, lovely talk of code and bug fixes and all that, But how about us who are on a hoster with which we cannot choose what version of CB we use? Im on 1185. How do I fix my world?
  21. Offline


    We have the same problem now :( Unable to start the server....
  22. Offline


    I modified craftbukkit to remove corrupted chests from the map when it finds them. Here's the patch:

    I'm wondering, is this a sane way to go about things? Can anyone spot any errors or oversights I may have made? It's been a while since I've done anything in Java, and I've never touched any code that comes anywhere near minecraft, so if I'm doing something extremely stupid I'd like to know before it bites me.
  23. Offline


    Guys what are the options here? Is the map corrupt or what exactly is the problem?
    Should I restore to older backup? Or should I use Afforess' fix?
    HELP :(

    edit. Currently running, bukkit with Afforess' fix but this is only temporary solution.
  24. Offline

    Stevil Knevil

    I tried something similar with some success, but it's not perfect. We used MCEdit to remove the chest and whilst that worked for a while, as soon as a chest is placed at that spot again then we hit the same problem I'm afraid.

    I'm still investigating and at the moment I'm trying to knock up a c# app to let me view the internals of the world data sensibly and see if there's a better way of fixing it up.
  25. Offline


    I got an experimental build from a bukkit dev here that attempts to fix the issue whenever it comes up:

    It seemed to work, at least at first. When I navigated to the area the chest was in, a message in the server logs spewed out the coords of the chest and said it was attempting to fix it. I then located the chest and opened it, placed items inside, relogged, and verified the items were still there. Then I broke it and made a big show of tossing it into lava for my players. :p
    I haven't tried placing a new chest in the same location, but I'll give it a go tonight after work.

    Everything ran fine for about three hours after DinnerBone's build fixed the chest, and then the server crashed. I couldn't log into McMyAdmin or even ssh, so it's likely that it was a system problem. The server logs were getting spammed with these before the crash, though:

    2011-09-28 21:57:17 [INFO] Attempted to place a tile entity where there was no entity tile!
    2011-09-28 21:57:18 [INFO] Attempted to place a tile entity where there was no entity tile!
    2011-09-28 21:57:18 [INFO] Attempted to place a tile entity where there was no entity tile!
    A cursory search shows other people with the same messages, and some are saying it's not adversely affecting them, so it could be unrelated to my crash.

    Sorry for the double post -- just thought of something.

    Have you tried placing and breaking a furnace before placing a new chest? Maybe that would clean up the block's data correctly.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  26. Offline

    Stevil Knevil

    Yeah - that may well help, but it all seems a little flakey! :) We got our server up and running with a variety of hacks, but I'll let you know how I get on with making a more robust offline world validity checker/repairer.
  27. Ok, Ill try again.

    Im on a hoster, on which i cannot change what version of bukkit i use. So patches, Dev builds, what not are of no use to me.

    Last time i restored a backup, but its happened again. What can i Do?

    Can someone please help me?
  28. Offline


    None of the stopgap measures that I've come across so far address the root of the problem, so there's risk involved in anything you might try.

    If you can download a copy of your map to a computer at home, you could try setting up a bukkit server yourself to fix it.
    You could talk to your host's tech support if you haven't already.
    You could start a new map.
    You could also try to find a clean backup to restore from, but it sounds like you already attempted that.
    I can't think of any other options aside from waiting for bukkit to make a stable release that fixes it (and then waiting for your host to upgrade to it).
  29. What a complete and utter Fool i have been. Why did i not think of this?

    I already have a number of Different Bukkit setups on my pc at home, For recording Adventure maps with friends, Testing new plugins etc, (and i used to run my main server from home)

    I shall do that now sir. But i have also Upped my world backups from once a day, to once an hour, just while this bug exists. Better the occasional lag, than losing up to 24 hours of work for my 50+ players.

    Thanks for pointing out the Completely Obvious to an Oblivious Idiot:)

  30. Offline


    We have fixed our server by using Dinnerbone's "highly experimental" version of bukkit. It was only 1 buggy chest that I removed. After that, we rolled back to 1185 and everything seems to be OK. :)
    Thanks for help.
Thread Status:
Not open for further replies.

Share This Page