Question Server Won't Show on Server Lists

Discussion in 'Bukkit Help' started by ZortexYT, Dec 3, 2016.

Thread Status:
Not open for further replies.
  1. Offline


    Okay so my minecraft server is all good. Took a whole day setting it up. I got a static ip, portforwarded with my public ip, and then got a free domain with noip. I however cannot connect through the word domain/ip, and I have to connect using my static ip, but other players can connect through the word one. That's my first issue. Second, when I try to register it on server lists it shows as invalid and can't ping my server, however when I put in my static IP it will work.

    Not sure the problem here as it lets other players connect using the word domain/ip, but not me and the server lists can't validate it.


    Sometimes it says this:

    <p>SyntaxError: Unexpected token < in JSON at position 0</p>

    And it also says:

    This server cannot be added / updated. Probably due to spam or use of a free hosting provider.
    Last edited by a moderator: Dec 3, 2016
  2. Offline


    Since your server is home hosted, when you join it you are joining a server on the same network that you are on. This means that you need to join with "localhost", "0", or your internal IP. It is not an issue, you don't have to worry about that.

    Also I'd like to clear this up for you, so that you can use the correct terminology:

    Look around to see if no-ip has problems being added to server lists. If you can't figure it out then a cheap alternative is to purchase your own domain so that you can setup something like or something like that. If you choose to go that route it is very cheap as you can get domains for < $15 a year.
  3. Offline


    Alright thanks I figured that out. Do you know anything about votifier though? I can't seem to get that working at all, worked fine when I had a host but now since I'm hosting local I can't get anything to work with it.
  4. Offline


    Try my plugin TsunamiListener, I built it against 1.10.2, so it should work on 1.11 as well. I'm guessing that you've set up Votifier correctly, but basically just make sure that you've set the IP in your config to be the same as your external IP. Make sure the port you're using for it is not in use. In this case, you can definitely use the default port (8192) since it's locally hosted and I doubt anyone else in your host is using Votifier's default port ;) Make sure you've portforwarded for that port as well!
    If you need any help, let me know.
  5. Offline


    I tried using various listeners and I currently have yours but it still won't work, I've asked multiple people and watched dozens of tutorials and I'm doing everything right. I even portforwarded the votifier's port. Still not working. I think my firewall may be blocking it somehow, a connection with Votifier? No clue, would you have any idea?
  6. Offline


    Try with your firewall completely turned off.
Thread Status:
Not open for further replies.

Share This Page