Server Will Not Run in Online Mode

Discussion in 'Bukkit Help' started by Sabinno, Jul 14, 2013.

Thread Status:
Not open for further replies.
  1. Offline

    Sabinno

    I'm using OS X 10.8.4 and my Java version is 1.7.0_25.
    I am not running any wrappers, and my CraftBukkit build is 2814.
    The server log is too large to post in pastebin, but I'm not getting any errors either way, the server simply states that it's running in offline mode despite my setting it to run otherwise on startup.
    My server.properties: http://pastebin.com/SemmKUBj
    My bukkit.yml: http://pastebin.com/9BtMuL0u
    Plugin list: CustomMessages, PermissionsEx, Random Spawn, CombatTag, RealisticChat, PingList, OtherBounds, CustomHelp
    I run the server with this command:
    Code:
    #!/bin/bash
    cd "$( dirname "$0" )"
    java -Xmx3G -jar craftbukkit.jar -o true}
    I have tried running stock craftbukkit (no plugins), and I have ran the vanilla minecraft_server.jar.
    Stock craftbukkit has the bug, yet the vanilla server doesn't, leading me to believe it's a bug on the behalf of CB itself.

    Am I missing something?

    EDIT: My intent is to run the server in online-mode, but it isn't doing so.

    I'm not sure what "Awaiting moderation" means. .-.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jun 3, 2016
  2. Offline

    TnT Retired Staff

    Sabinno
    Remove the -o true and set it in the server.properties instead.
     
    Sabinno likes this.
  3. Offline

    Sabinno

    TnT Thank you. ^-^
     
Thread Status:
Not open for further replies.

Share This Page