Server RUN.bat file doesn't recognize CraftBukkit-1.0.0-R1.jar!

Discussion in 'Bukkit Help' started by rogvid700, Dec 13, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    rogvid700

    I wouldn't call myself a pro on Bukkit servers, but I've had a good year and a half working on them, and this just puzzles me.....I know I have the setup correct in my RUN.bat file in my server....but for some reason I get this error:
    ProblemPic1.PNG

    Not sure what this quite means, I noticed the references of 32 and 64-bit platforms however.

    Here is my RUN.bat file
    ProblemPic2.PNG

    I have done it this way, and the long way were you put %ProgramFiles%/java/jre6/bin/java.exe.....and I still get the EXACT same error

    And finally, here is my server's files.
    ProblemPic3.PNG

    Not sure what is going on here, but I know some talented individual out there could help me. :) If you need any more information, please, don't hesitate to ask me. Thanks!

    -Rogvid700 - Owner of YouCraft Minecraft Server
     
  2. Offline

    ClichedBluefish

    I'm not that good with reading errors, but I'm seeing something about the java versions being wrong? It basically is saying "Can't load 32 bit program with 64 bit system" I think, which is really strange....
     
  3. Offline

    bigbass1997

    try using this in the batch file that you use to start the server:
    Code:
    @echo off
    java -Xms1024M -Xmx1024M -jar craftbukkit-1.0.1-R1.jar nogui
     
  4. Offline

    zipron

    update java and use the command bigbass posted =)
     
  5. Offline

    rogvid700

    When I enter your suggestion in, the server opens then shuts down immediately. I notice that you didn't add "PAUSE" on the last line of the text, so I entered that, and the same problem error pulls up. ):
     
  6. Offline

    TnT Retired Staff

    Reinstall java and try again.
     
  7. Offline

    NDSLITE

    Hello guys! I mixed some stuff and i got it to work! Here is the code:


    @echo off
    C:\Windows\SysWOW64\Java.exe -Xms1024M -Xmx1024M -jar craftbukkit-1.0.1-R1.jar nogui
    PAUSE

    If that code doesnt work just serch for java.exe on the computer, check where it is
    (Like for me in: C:\Windows\SysWOW64\Java.exe) and switch that text to where the java.exe is!

    Please reply for furter problems :)
     
Thread Status:
Not open for further replies.

Share This Page