Server not working, failed to bind port

Discussion in 'Bukkit Help' started by BlizzStar, Oct 6, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    BlizzStar

    Help, I had a hamachi server before but now hamachi stop working for me so i decided to buy minecraft and i did, i made new bukkit server but it doesnt work. Always when i try to run it it says
    Failed to bind port.
    PICTURE:
    [​IMG]

    I did added my external ip and 25565 port to my virtual server in my router..i tried it with simple port forward program but still doesnt work it says (in simpleportforward program) FAILED

    PICTURE:
    [​IMG]

    i checked my port if its open in some other websites and with PFportchecker but still doesnt work.

    PICTURE:
    [​IMG]

    HERE IS THE PICTURE OF MY VIRTUAL SERVERS:
    [​IMG]


    I tried with server ip=<blank> it worked fine but my friends couldnt join.
    I tried with server ip=<ipv4> it worked fine but my friends couldnt join.

    MY SERVER.PROPERTIES:
    [​IMG]

    Few days ago i port forwarded it sucessfuly until i changed some plugins and files in my server folder..I checked the planetminecraft "Verify Server Ownership" it worked...but now it doesnt.
    PICTURE:[​IMG]


    PLEASE HELP!
     
  2. Offline

    JamesBoyd21

    what do u use for internet
     
  3. Remove server ip from the server.properties. leave it blank.
     
  4. Offline

    BlizzStar

    What do u mean?
    If u mean my router brand its Encom/enkom A1521I_1.1.56

    No, i want it a public server!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 29, 2016
  5. Offline

    JamesBoyd21

    so not verizon

    i dont think that portfoward is going to work u need to find your router settigns

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 29, 2016
  6. Removing the server-ip feild leaves it public, trust me.
    Ive run a server like this for two years. just set it to blank and start the server.
     
  7. Offline

    BlizzStar

    how they gonna know what is the ip to it?
     
  8. BlizzStar
    In the server.properties file, the only reason the server-ip needs to be filled in is if the computer has two or more internal IP addresses (Which 95% + of computers don't).

    Leave it blank, the router automatically sends the players to the computer with the server.
     
    zack6849 likes this.
  9. Offline

    BlizzStar

    but what will my ip be?
     
  10. Your internal or External?
    All you need to worry about is your external (For others to connect), leave the server-ip blank, start the server, and give the players you external IP (and sometimes the port)
     
  11. Offline

    Plague

    your IP will be your IP, or do you think that bukkit changes your real IP address? :) The option only tells minecraft which IP to use, it uses *all* of them by default.
     
    zack6849 likes this.
  12. htttp://www.whatsmyip.org/
    That will give you the ip adress the users need to use to connect.
     
  13. Offline

    BlizzStar

    Ok, so i tried with leaving the serverip blank, server was able to start but i cant connect with my external ip only with ipv4!
     
  14. Then you haven't port forwarded correctly, or have missed a step, have you opened the ports in your firewall?
     
  15. Offline

    BlizzStar

    my firewall is always off
     
  16. Offline

    BlizzStar

    Error: I could not see your service on ********* on port (25565)
    Reason: Connection timed out
     
  17. Simple put, something is blocking incoming connections to the server.
    Do you/Have you;
    1) Have a 3rd party firewall/anti virus (AVG, Kaspersky, BitDefender)?
    2) Have a modem and router, or just a modem?
    3) Double checked the port forwarding is right/IP is right. You more than likely have a dynamic IP which causing your computers IP to change at times when it's turned on.
     
  18. Offline

    BlizzStar

    1) i have AVAST but its offline..
    2) i have both
    3) i checked it and is all good..
    so what should i do?
     
  19. Just a thought, but maybe something has gone wrong when port forwarding between the modem and router. Try something like this;
    Internet > Modem (All ports open) > Router (Choose which ports are open) > Server

    If that makes sense...

    Also, do you have TeamViewer? It might make things a little easier to do.
     
  20. Offline

    BlizzStar

    "Internet > Modem (All ports open) > Router (Choose which ports are open) > Server"
    What do u mean with this?

    Yes, i have :)
     
  21. Maybe it might be easier for me to take a look though it with TeamViewer, PM me the login details? (If you want)
     
  22. Offline

    BlizzStar

  23. Offline

    Pixela7

    Hi I have the same problem I opened the port in my firewall and on canyouseeme.org it replied "Connection refused"
     
  24. Offline

    sebidebi4567

    Using hamachi for a public server isnt recommended, either get a server on 24/7 with port forwarding, buy hosting, Or Dont bother. Hamachi Hostin for big public servers aint good less you pay hamachi for more slots
     
  25. Offline

    Iroh Retired Staff

    Add your internal ip to server ip in server.properties then wait 5 minutes start server again and only use stop in the console to stop server. Connect using external ip
     
  26. Offline

    wawalig11

    Solution:
    1)go to cmd and type in "ipconfig"
    2) go to IPv4 address and what ever it is, copy it.
    3)go to your server.properties and type the IP on the server-ip: line.
    4)run your server, and it should work!

    Hope this helps!
     
  27. Offline

    GodBlokker98

    i put my ipv4 address in the server properties but now when i attempt to start up bukkit, i says ''server cant keep up , did the system time change or is the system overloaded? plzz help. how do i fix this
     
  28. Offline

    NoahDTheHorse

    it doesn't matter that much it just means alot is happenning on your server and it is too fast i think
     
  29. Offline

    techguy948

    Ok, if you have a modem and router, try portforwarding a lower port (180) and then in server.properties change port to 180. When people join your server, the ip will be <external ip>:180 ex: 68.68.201.213:180
    Sometimes a router can't open high ports... Try, if not, I can't help you ;)
     
Thread Status:
Not open for further replies.

Share This Page