Server lagging a lot

Discussion in 'Bukkit Help' started by ibab, Jul 12, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    ibab

    Since I updated to bukkit #953 from #860, to get my server 1.7 compatible, it started to lag a lot. The odd thing about it is that the server is just fine when I relaunch it, it runs smoothly for around 2 hours, but after that it starts to lag so much so its almost impossible to play with that kind of lag.
    The current server has been running 30 players on the same map before, but just now it has started to lag this bad.
    I've been trying to find solutions for this the whole week, but can't just find any, so I had to add an automatic restart plugin on my server. Whatsoever, it seems like sometimes the server fails to launch up after being restarted, so it stays down for around 10 hours.

    I've been talking with another guy who hosts he's Minecraft server and has the exact same build of bukkit as I do and he said he's server is experiencing some lag aswell and he had to setup an automatic restart aswell.
    I was mainly wondering if there is anything to help get rid of this lag and possibly know if one of my current plugins is probably not compatible with another plugin and would cause lag.

    So heres some basic information of my server.
    Bukkit version: CraftBukkit #953
    Java: openjdk-6
    Plugins:
    MagicCarpet, LWC, mcMMO, CommandBook, Minequery, WorldEdit, iAuction, FalseBookCore, ScheduledAnnouncer, Datalog, FalseBookChat, mcbans, Permissions, FalseBookBlock, iConomyChestShop, EpicGates, PluginControl, Lottery, WorldGuard, PrivateWarp, BorderGuard, Citizens, PermissionsPlus, Essentials, VanishNoPickup, iConomy, nSpleef, SimpleRestart, Votifier, iChat, EssentialsSpawn

    If there is anything that I could do to reduce this lag, I would like to hear. I would appreciate all the help.
     
  2. Offline

    eastonch

    Firstly, I would need to know your OS.
    Secondly, it's a common issue, mine reboots every 3 hours just for the lulz, but i've noticed many servers CRASH or even become unstable, with the latest bukkit & it's only a dev build for the builds that are 1.7.3, another thing is, McMyAdmin seems to be causing some of the bugs many of the users are getting, just a heads up.
     
    ibab likes this.
  3. Offline

    ibab

    The server is running on Ubuntu and I am not using McMyAdmin.
    Anyway, thanks. Helps to know that its not atleast just me having this problem.
     
  4. Offline

    efstajas

    Maybe you have a very old version of java installed? Check the version with java -version in the computers console.
     
  5. Offline

    eastonch

    Hmm, we use CentOS and the OpenJDK :) I'll do some more investigating for you.
     
  6. Offline

    ibab

    Heres what I got from java -version.
    Code:
    java version "1.6.0_20"
    OpenJDK Runtime Environment (IcedTea6 1.9.7) (6b20-1.9.7-0ubuntu1)
    OpenJDK 64-Bit Server VM (build 19.0-b09, mixed mode)
     
  7. Offline

    jaboy

    get the same problem ... but found out that CommandBook's time command every time it is used the server lags more and more try not allowing anyone access to that command and see what happens ;)
     
  8. Offline

    ibab

    I have the modified package of CommandBook which includes only the /compass, /rocket, /slap, /shock and /barrage. But I guess I could just try removing the CommandBook for a while.
     
  9. Offline

    TowelieDOH

    Having a similar problem :\
    Please let me know if /time is the culprit, or something else.

    PS: You may want to ditch Essentials, i've heard it's quite a resource hog.
     
  10. Offline

    ibab

    @jaboy
    Thank you a ton! I removed CommandBook and the server is running with no lag!
     
  11. Offline

    jaboy

    glad i could help :D
     
Thread Status:
Not open for further replies.

Share This Page