Server Crashing - No Real Reason I can See

Discussion in 'Bukkit Help' started by syonxwf, Apr 5, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    syonxwf

    09:14 AM [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    09:14 AM [INFO] <*Forte (Knight) Buttonroast> mine just crashed
    09:14 AM [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    09:14 AM [INFO] Connection reset
    09:14 AM [INFO] Snurf_Goggler_1 lost connection: disconnect.quitting
    09:14 AM [INFO] [MCBans] Snurf_Goggler_1 has disconnected!
    09:14 AM [INFO] Connection reset
    09:14 AM [INFO] bear0525 lost connection: disconnect.endOfStream
    09:14 AM [INFO] [MCBans] bear0525 has disconnected!
    09:14 AM [SEVERE] [LogBlock Consumer] SQL exception on UPDATE `lb-players` SET onlinetime = onlinetime + TIMESTAMPDIFF(SECOND, lastlogin, FROM_UNIXTIME('1333642467')) WHERE lastlogin > 0 && playerid = 1259;:
    09:14 AM [SEVERE] [LogBlock Consumer] SQL exception on UPDATE `lb-players` SET onlinetime = onlinetime + TIMESTAMPDIFF(SECOND, lastlogin, FROM_UNIXTIME('1333642467')) WHERE lastlogin > 0 && playerid = 637;:
    09:14 AM [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    09:14 AM [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    09:14 AM [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    09:14 AM [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    09:15 AM [INFO] Connection reset
    09:16 AM [INFO] Read timed out
    09:28 AM [INFO] Connection reset
    09:41 AM [SEVERE] java.io.IOException: Bad packet id 71
    09:41 AM [SEVERE] at net.minecraft.server.Packet.a(Packet.java:75)
    09:41 AM [SEVERE] at net.minecraft.server.NetworkManager.h(NetworkManager.java:149)
    09:41 AM [SEVERE] at net.minecraft.server.NetworkManager.c(NetworkManager.java:268)
    09:41 AM [SEVERE] at net.minecraft.server.NetworkReaderThread.run(SourceFile:76)
    09:45 AM [INFO] Connection reset
    10:13 AM [INFO] Read timed out
    10:13 AM [INFO] Connection reset
    10:24 AM [INFO] Read timed out
    10:47 AM [INFO] Connection reset​
    I started experiencing this error a few days ago, my server will run anywhere from a couple hours to 12 hours without issue, and then basically crashes without crashing. The console stays up, it shows all the players that were on when the server stopped working, I can save it like I used to be able to, but I cannot stop the server without force closing (task manager) and no one can connect during this time.


    I am running the 1.2.5 Recommended build (2149). It started happening when I upgraded from the 1.2.4 dev build I was using to the 1.2.4 Recommended build (which was removed not long after being posted). I assumed it had to do with that so I downgraded back to the build I was using (I don't remember which at this point) and I continued to have the same issue. I decided at that point to go ahead and upgrade everything to 1.2.5. I updated all plugins that had updates, updated craft bukkit, minecraft_server.exe, everything. Same issue.

    This is a full list of plugins I have installed:

    Backup 0.7.5
    ChatManager
    DeathTpPlus
    DynamicEconomy
    Essentials (Core Only)
    Factions
    iConomy
    Lockette
    Logblock
    mcbans
    McMMO
    Modifyworld
    Pail
    PermissionsEx
    ReservedList
    SimpleTips
    VanishNoPacket
    Votifier
    WorldEdit
    WorldGuard
    XrayInformer

    A hefty list lol.
    The only plugin modifications I made prior to this issue was updating Factions, iConomy, McMMO and Essentials, all of which I rolled back and continued to experience this issue.

    Is there anything known to cause this issue that I am missing? It's hard to test by removing plugins, though it is feasible, because the crash might not occur for 12 hours or more after restarting the server. It could be 1 plugin that is gumming it up, but starting up the server by adding a plugin at a time could take over a week. I just don't know at this point what to do, other than start completely fresh (not ideal).

    Quick edit: I am aware of the severe error with logblock, and it is not the cause; I have had that since Diddiz stopped updating Logblock for guardian when 1.2 hit.
     
  2. Offline

    LHammonds

    I would recommend looking at your sever and how you are using it before looking at the plugins.

    How much RAM does your server have? How much RAM are you give Java to run your server? How much of that RAM is being used when the server is running? Is your server 64-bit hardware? Is it a 64-bit operating system? Are you using a 64-bit version of Java? Are you telling java to run in 64-bit mode and how much RAM it can use?

    Your upload speed of your Internet connection can also play a major part in poor performance (but typically not server crashes)

    LHammonds
     
  3. Offline

    Luwiego

    Hey ! I have a very similart problem, the server just crashes (That can`t be a ram problem for me since, i have 4gigs of ram and the server crashes even with few players online). I think its some of the plugins fault, i have these plugins from your list : Essentials spawn,iConomy,VanishNoPacket,WorldEdit and WorldGuard.One of the plugins is causing the problem.
     
  4. Offline

    cuddylier

    I also have this problem, I saw somewhere worldguard causing issues so update it to the latest dev build.
     
  5. Offline

    Luwiego

    I have the newest WG dev build :/ Pm me if you find a fix. Maybe i should remove WG for a while to check if it will crash?
     
  6. Offline

    cuddylier

    Have you updated worldedit to the latest dev build as well?
     
  7. Offline

    Luwiego

    Im using the one from bukkitdev.
     
  8. Offline

    syonxwf

    I have 16gb RAM in my server.
    I allocate 12gb RAM through the start.bat file.
    The amount of ram typically fluctuates depending on the amount of people, anywhere from 450mb when first started, to 6gb when full and under heavy load, but typically it stays in the 1gb range.
    Server is using 64 bit hardware (4 x Dual Core Intel Xeon 7020's @ 2.66Ghz ea)
    It is Windows Server 2008 R2 Enterprise 64 bit.
    Using Java 1.6.0_31-b05 (6u31) 64 bit. As far as I know, the start.bat while won't work with more than 1.5gb allocated if you do not have 64 bit everything, I tried it before on another server I had a while back and it would always yell and not start if it wasn't all 64 bit.

    My upload speed is 15mbps, but if anything I have less players now than I did before because my server keeps crashing and it's frustrating my users :/

    I will try updating worldguard and see if that works for me :)
     
  9. Offline

    tombik

  10. Offline

    syonxwf

    I updated both worldguard and worldedit to the latest builds this morning, and my server just crashed again about 5 minutes ago.

    Edit: I just copied all my files to a new test server, opened it up on a new port with 0 plugins but the same world file and everything else.

    My server has been crashing every few hours (between 2 and 12 hours) so I should know for sure by tomorrow morning or tomorrow afternoon if it's a plugin or if it's bukkit/minecraft.

    I will keep this updated.
     
  11. Offline

    syonxwf

    I ran a test server with no plugins, had no crash. I am now running two test servers, one with half the plugins, the other with the other half, and neither of them have crashed yet. I will give them both until tomorrow morning to see if either of them crash, and if they don't I will try taking a different set of half the plugins for each server to see if maybe its a pair of plugins that arent working together or I don't know what...I am usually pretty good at figuring this kind of stuff out, but this has me thoroughly confused...if anyone has any further insight on this I am all ears.

    Neither test server crashed, so it must be two plugins reacting to each other somehow.

    I started up a new test server with all plugins enabled again to make sure it isn't just some weird glitch with my current server...but I'll likely have the same issue again.

    I will start another test server as well with a different 50% of the plugins to see if I can somehow get this to duplicate...really frustrating to have my server continue going down...I've lost most of my playerbase because I cannot keep this stupid server up...never had so many issues before :/

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 25, 2016
  12. Offline

    Luwiego

    Since my server is also crashing, i think that you should look at those plugins that you and i have. I wrote them in the previous post. Im running my test server now with just LWC,xauth,essentials,essentialsspawn. No crash yet.

    My theory is that maybe its world edit and world guard ? Since they are both from the same author and one of them isnt officialy updated so maybe they are causing the lag... Its just a wild guess.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 25, 2016
  13. Offline

    syonxwf

    That could be, but I ran both of them in one of my test servers and that test server never crashed, so I dont know :/
     
  14. Offline

    Luwiego

    Then maybe essentials?

    BTW, Essentials,essentialsspawn,lwc and xauth didnt cause crash. There must be another reason...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 25, 2016
  15. Offline

    dsmyth1915

    At what point does it crash? Is someone in a corrupted chunk? To test the chunk check to see if you crash within 3 minutes Or so of a single person logging in. do multiple people use the same thing(a plugin not being able to process alot of players)? Did someone ignite a massive amount of TNT?

    Just trying to help :)
     
  16. Offline

    syonxwf

    There is no real point at when it crashes, it is completely random from what I can tell. I can start the server and have it work fine from 7am until 10pm one day, start it the next day at 7am and it will crash at 9am, 12pm, and 7pm (just examples, not exact).

    It's not a corrupted chunk because when I remove all the plugins on a test server (that no one goes on) the server doesn't crash, but if I put all the plugins in on a test server (again that no one goes on ever) it will crash at random again.

    As posted above, I tried doing 50% of the plugins (top 50% and bottom 50% alphabetically) and neither server crashed.

    I have now taken 2 servers using every other plugin 1,3,5,7, etc and 2,4,6,8 (as best as it will work, because some plugins depended on each other) and I did have one of the server's crash again.

    Server 1 that crashed had these installed:

    ChatManager Luwiego doesn't have
    DynamicEconomy Luwiego doesn't have
    Factions Luwiego doesn't have
    Lockette Luwiego doesn't have
    Mcbans Luwiego doesn't have
    Modifyworld Luwiego doesn't have
    PermissionsEx Luwiego doesn't have
    ReserveList Luwiego doesn't have
    VanishNoPacket
    Vault Luwiego doesn't have
    WorldEdit
    WorldGuard

    Server 2 that did NOT crash had these installed:

    Backup
    DeathTpPlus
    Essentials
    EssentialsChat
    EssentialsProtect
    EssentialsSpawn
    iConomy
    LogBlock
    LogBlock Questioner
    mcMMO
    Pail
    SimpleTips
    Votifier
    XrayInformer

    By process of elimination, none of Server 2's plugins are causing the crash. It is a combination of 2 (or maybe more) plugins from server 1. It is not WorldEdit and WorldGuard alone, because they ran together on one of my previous test servers just fine, though that doesn't rule out one of the other plugins and WorldGuard/WorldEdit not getting along.

    Edit: Because Luwiego is having the same issue, and he is using LWC, I am going to effectively rule out Lockette at this point as well.

    Edit 2: Going through luwiego's previous post, he said he has Essentials Spawn (ruled out by both of us), iConomy (ruled out because it is not in my list of plugins from my server that crashed), VanishNoPacket, WorldEdit and WorldGuard. I am going to go ahead and remove VanishNoPacket from my production server and see if that fixes the issue.
    Hopefully through our elimination process this out to be the one.

    Edit 3: Please correct me if you do actually have a plugin that is striked out so I can make sure I don't miss it :)
     
  17. Offline

    dsmyth1915

    I'm not entirely sure what's going on here. I said it could be a corrupted chunk because that ends up causing massive amounts of lag and crashing the server. And unless someone is near that chunk causing it to load. It should not crash on a test server unless someone is in that chunk. I remember an old server I was on dropped mcbans because it was causing all kinds and sorts of errors and lag. Try removing that from your server 1 and see if that fixes it.
     
  18. Offline

    andrewpo

    Is someone connected to your server using a modded client sending malformed TCP data packets?

    WorldEdit/WorldGuard won't cause these issues, I use these with no problems whatsoever - sk89q is an amazing plugin developer.

    I use VanishNoPacket but I haven't used it long enough to give a reliable statement on how stable it is.
     
  19. Offline

    syonxwf

    I'm hoping that through our process of elimination, barring Luwiego doesn't have a plugin that I have striked out (after going through his previous post), it is likely being caused by VanishNoPacket. Why that would cause the server to crash when no one is using it, I don't know, but I have seen some weird shit cause crashes (pair of single quotes around a word in simpletips caused my server to stop turning on completely until I figured that one out).


    Regarding the first part, short answer is no. I've been testing plugins in servers that are unaccessible to my users, so no one is able to get on to those servers and I was still able to get them to crash as well. Users are completely ruled out at this point.

    Sk89q is an amazing plugin developer, I'm not saying anything is wrong with his plugins. As I said previously as well, I tested a server with both WE and WG installed and that server did not crash the first time. It wasn't until I changed up the 50% worth of plugins that the server with WE and WG installed crashed. My theory is that it is not a single plugin that is causing the crashes, but two plugins combined causing the issue. Through our process of elimination, the only logical answer left is VanishNoPacket and WE/WG. Nothing wrong with any of the plugins, I just don't think they are working together right now.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 25, 2016
  20. Offline

    andrewpo

    Code:
    2012-04-13 03:16:14 [INFO] Plugins (36): ShireFaker, MultiInv, WorldEdit, ShireSheep, VoxelSniper, Vault, PermissionsEx, XcraftGate, WorldGuard, HeroicDeath, VoxelUpdate, DisguiseCraft, Permissions, BookWorm, LimitedCreative, BKCommonLib, AdvancedWarning, FalseBookCore, MonsterBox, Herochat, MobDisguise, mcMMO, Essentials, Factions, WorldBorder, EssentialsProtect, Courier, EssentialsSpawn, FalseBookBlock, dynmap, Dynmap-HeroChat, HawkEye, Train Carts, Dynmap-Essentials, JSONAPI, 
    My server dies at least once every 48 hours, those plugins are installed. Does that help at all?

    Make sure you're using the latest plugin versions and update regularly.

    Can you give me the output of the " gc " command in the console please?
     
  21. Offline

    syonxwf

    08:19 AM [INFO] Maximum memory: 12,261 MB
    08:19 AM [INFO] Allocated memory: 274 MB
    08:19 AM [INFO] Free memory: 107 MB
    08:19 AM [INFO] World "world": 495chunks,285entities
    08:19 AM [INFO] Nether "world_nether": 625chunks,112entities
    08:19 AM [INFO] World "world_the_end": 625chunks,82entities
     
  22. Offline

    andrewpo

    Hang on..... you have 12.2GB of available memory but you're only using 274 of it? And you have all those plugins?!

    Where are you hosted?
     
  23. Offline

    syonxwf

    Hmm...that makes me wonder if it is something else then, because you don't appear to have Vanish.

    The plugins we share in common:

    Essentials Ruled out because it was not on my server that crashed.
    Factions
    mcMMO Rule out because it was not on my server that crashed
    WorldEdit
    WorldGuard
    PermissionsEx
    Vault

    Plugins on the server of mine that crashed:

    ChatManager Ruled out because you don't have it.
    DynamicEconomy Ruled out because you don't have it.
    Factions
    Lockette Ruled out because you don't have it.
    Mcbans Ruled out because you don't have it.
    Modifyworld Ruled out because you don't have it.
    PermissionsEx
    ReserveList Ruled out because you don't have it.
    VanishNoPacket Ruled out because you don't have it.
    Vault
    WorldEdit
    WorldGuard

    I will try my test server with everything but Vault and Factions and see what becomes of that.

    Home hosted. I work in IT as a server admin, so local companies are banging down my door trying to sell me shit, so I got a good deal on an HP Proliant DL580 G3.

    Ah so you do have Vanish as well, maybe that is the cause then. My crashes are a little more frequent, but also unannounced. The only reason I can tell sometimes is because it has 5-6 players listed but no console activity for spaces of 30 or more minutes.

    How do I allocate more RAM? It does appear something is off there, seeing as it says 274mb are allocated and only 107Mb are free...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Aug 20, 2018
  24. Offline

    andrewpo

    The lack of allocated RAM will probably be causing your can't keep up issues, as minecraft is pretty RAM-heavy.

    My plugins (I get unannounced crashes every 48-72 hours
    Code:
    Plugins (36): ShireFaker, MultiInv, WorldEdit, ShireSheep, VoxelSniper, Vault, PermissionsEx, XcraftGate, WorldGuard, HeroicDeath, VoxelUpdate, DisguiseCraft, Permissions, BookWorm, LimitedCreative, BKCommonLib, AdvancedWarning, FalseBookCore, MonsterBox, Herochat, MobDisguise, mcMMO, Essentials, Factions, WorldBorder, EssentialsProtect, Courier, EssentialsSpawn, FalseBookBlock, dynmap, Dynmap-HeroChat, HawkEye, Train Carts, Dynmap-Essentials, JSONAPI, VanishNoPacket
    I would suggest allocating more RAM to your server. -Xms2G -Xmx2G

    Please post your start file in code tags.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Aug 20, 2018
  25. Offline

    syonxwf

    Code:
    @ECHO OFF
    SET BINDIR=%~dp0
    CD /D "%BINDIR%"
    java -Xincgc -Xmx12G -jar craftbukkit-1.2.5.jar
    PAUSE
     
  26. Offline

    owenftw

    My server can also be smooth at times but it randomly starts lagging quite alot and have crashed atleast 3-4 times in past week.

    Hosted by verygames.co.uk
    Maximum memory: 15,991MB
    Allocated memory: 779MB
    Free memory: 259MB

    Plugins: AlphaChest, AutoRank, BuyCraft, Chairs, ChatManager, DeathControl, DisguiseCraft, Enchantanything, Essentials, EssentialsSpawn, FalseBookBlock, FalseBookCore, Lockette, LogBlock, LogBlockquestioner, MaxTPS, McGroovy, Multiverse-Core, NoCheat, NoSwear, Otherdrops, PermissionsEX, physcialshop, protectionstones, ReportRTS, SimpleHat, SkyLandsPlus, stargate, VanishNoPacket, Vault, Votifier, WorldBorder, WorldEdit, WorldGuard

    Also getting this in console every like 10mins:
    >15:41:38 [WARNING] Your server appears to be running slowly. Server tick took 14.75 seconds longer than expected.
     
  27. Offline

    andrewpo

    Stop your server, add -Xms12G to your start script to instantly allocate 12GB to minecraft. Then start it and run gc in the console and post it here.

    java -Xincgc -Xms12G -Xmx12G -jar craftbukkit-1.2.5.jar
     
  28. Offline

    syonxwf

    Wow that's awesome!

    Code:
    08:49 AM [INFO] Maximum memory: 12,261 MB
    08:49 AM [INFO] Allocated memory: 12,261 MB
    08:49 AM [INFO] Free memory: 12,063 MB
    08:49 AM [INFO] World "world": 625chunks,327entities
    08:49 AM [INFO] Nether "world_nether": 625chunks,112entities
    08:49 AM [INFO] World "world_the_end": 625chunks,82entities
     
  29. Offline

    andrewpo

    If your problems continue, please reply to this topic or start a new one and we will try to help you out.

    _______
    Thanks for using Bukkit's Voluntary Technical Support!
    If your issue is resolved, please change the prefix of your topic title to Solved by going to Thread Tools then 'Edit Thread'
    [​IMG]
     
  30. Offline

    syonxwf

    You think that is what is causing the crash rather than the plugins?

    Edit: Just for shits and giggles, I started up my test server without making a change to the initial RAM allocation, but removed Vanish to see if it does or doesn't crash as well.
    I have vanish removed from my production server as well as the RAM change, so I want to make sure I know which caused it (if either did).
     
  31. Offline

    andrewpo

    Well you had a very small amount of RAM being allocated, that might increase automatically when needed but I am not totally sure how it works (Your can't keep up messages would suggest that it wasn't being allocated of its own accord).

    Now you have a definite 12G of ram which will alleviate stress on the server and improve performance.

    Unless you have any [SEVERE] entries in your server.log, it doesn't look like a plugin issue. If you have SEVERE errors, please post them in full.

    I run vanishnopacket on the server mentioned in my forum signature (check out the cool looking dynmap :p) and it has been stable so far for a few days.

    As long as you keep plugins up to date (I update my plugins every Thursday night) there should not be many problems.
     
Thread Status:
Not open for further replies.

Share This Page