Inactive [SEC] PermissionsPlus v3.2.5p - Alternative commands to modify Permissions in-game now w/MWS [1337]

Discussion in 'Inactive/Unsupported Plugins' started by DigitalTyrant, Mar 20, 2011.

  1. Offline


    PermissionsPlus - Adds ability to modify Permissions in-game

    Updated: 10/6/2011
    Version: 3.2.5p [jar]
    CraftBukkit: [b1337jnks]
    PermissionsPlus adds commands to allow administrators the ability to modify their Permissions config from within Minecraft client. The most complete Permissions editing plugin for Bukkit. Supports Multi-World. Updated for MultiPlay!​
    REQUIRES: Permissions 3.x - Permissions Thread

    Includes: P2Aliases updated 10/6/2011


    Get updates on TWITTER!

    Installation and Usage information and Permissions nodes
    are available at


    It appears that I am not the only server admin that stuck to Permissions v2.7.4 so, I have released PermissionsPlusLegacy v2.4. It is a RB1000+ compatible version of PermissionsPlus v2.3. You can download this in the change log below.
    • You can specify multiple worlds separated using a comma. Do not use any spaces after the comma.
    • You can specify all worlds using an asterisk.
    • You can specify multiple groups using commas for the /user -addgroup command.
      /user -addgroup u:Username s:Group1,Group2,Group3
    • All Usernames and Groups can be shortened. You will be notified if more than one possible match is found.
      digital = DigitalTyrant, adm = Administrator
    • With 2.x+ you must add the info variable 'rank' to your groups in order to enable promote, demote and some group functions. You can set this variable from within the game using the command:
      /group -setinfo g:GroupName i:rank s:1-100+
                         /rankset GroupName 1-100+ world 
      The higher the number the higher the rank. Make sure you use i:rank and not i:Rank it is case-sensitive.
    • You can now set Promote and Demote limits. The Promote limit is the highest rank they can promote to. Demote limit is the highest limit that they can demote from. You can set these using the commands:
      /group -setinfo g:GroupName i:dlimit s:50
                         /group -setinfo g:GroupName i:plimit s:75 
    If you use want to Permissions + PermissionsPlus while using Essentials plugins, make sure you do not have FakePermissions or EssentialsGroupBridge enabled.

    Not sure how long this will be useful with Bukkit's upcoming Permissions system, but it allows the Moderators of my server to give new members access without having to modify the .yml file directly. I will continue development until the new Bukkit Permissions system has widely replaced Permissions plugin.
    Thanks to Nijikokun, original author of Permissions.

    Thanks and Enjoy!
  2. Offline


    Thank you :)
  3. Offline


    No problem
  4. Offline


    I get this error when starting up my server. I am on RB 935 and I'm using Permissions 3.1.6. Please help?

    21:35:55 [SEVERE] Error occurred while enabling PermissionsPlus v3.2 (Is it up t
    o date?): tried to access field
    from class net.codej.permissionsplus.PermissionsPlus
    java.lang.IllegalAccessError: tried to access field net.minecraft.server.Propert from class net.codej.permissionsplus.PermissionsPlus
            at net.codej.permissionsplus.PermissionsPlus.onEnable(PermissionsPlus.ja
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.init(
  5. Offline


    is there a permission node that goes along with /rankset ?
  6. Offline


    not for the command, all it does it take a set of arguments and translates it to
    /group -setinfo i:rank g:Group s:#
    so.. indirectly, is the permission that would allow the rankset command.

    I haven't had a chance to do any testing with Perms 3.1.6 nor RB935. I will look into this issue.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  7. Offline


    My server is running stable atm. It has permissions and permissionsplus.
    I can use the commands to add a player in a group.

    But under the user, the word Permissions [] is never added by the commands.
    So basically the user is added correctly but he still can't do anything.

    When I do it manually in the config file, and I use the /permissions -reload all command,
    it works. But that means i have to keep messing about in the config file :(

    please don't shoot me it it's an obvious mistake on my part :eek:
  8. Offline


    Can it use global groups?
    Because i store all of my groups and users in the global files,not in the worlds,and when i try to add a user to a group it's says the group doesn't exist.
    Any advice?
  9. Offline


    I will take a look into the global groups and users. All of those functions are using the Permissions API so not sure why it wouldn't work but I will do some testing

    The Permissions: [] can be blank and your users will still have permissions through their group. The only time that will get populated is if you run the command
    /user -setperm u:Username s:Permissions.reload
    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  10. Offline


    Getting internal server errors when I /promote <name>.. running the first 1.7 cb build and restarted the server several times.
  11. Offline


    I'm sure that it won't work until I write an update. I will start on one this weekend possibly but won't release it until a build has been promoted to RB and I've had a chance to test it.
  12. Offline


    thanks so much, because i didn't want my moderators promoting themselve to admin n banning me :p
  13. Offline


    Can you add the ability to specify what groups users can add to?
    For example, I want a user to only be able to add other users to the Town1 group.
    I would give him the node 'p2.user.addgroup.Town1' and 'p2.user.remgroup.Town1' and then '-p2.*'
    Would this be possible?
  14. Offline


    You could accomplish this using ranks and plimit. By default, users can set anybody's group higher than their current, but if you raise the plimit of the group they could "promote" themselves without being able to obtain administrator status.
  15. Offline


    I want to use multiple-groups and 6 "dummy" groups that could be added to users to give then access to a town. The town is restricted, with residence, to only users of a certain group. By adding the group (6 groups for 6 towns) the user would get access to the town. I don't want nobles of one town to e able to add another towns group to players.

    I don't want nobles of each town to be able to give citizenship to players in other town, so I can't setup a numerical hierarchy because if the groups were 2-7 (6 towns), then the 7th town could control access to the others.
    Get what I'm saying?

    I need a permission that can specify what groups a user can add to, and only those groups.

    Would it be possible to have multiple strings of inheritance, and multiple rank hierarchies that don't overlap?
    That way someone in Town1 could promote a default into their town, and they could be /promoted through a rank hierarchy specific to that town/ inheritance group?
  16. Offline


    Hmm, is this something you can accomplish with tracks? I can see how this could be useful to admins, I'll think about a way that I could implement this.
  17. Offline


    I edited my last post for clarity. It's a bit late and I'm on my phone, so that doesn't help.
    But tracks is exactly what I need. If you could simplify the commands that "Permissions" uses into simple /promote commands, that'd be great!
  18. Offline


    lol, I'll see what I can do.
  19. Offline


    I'm just going to hurl my ideas at you before I fall asleep, hopefully it'll make some sense and I apologize if I seem like I'm insulting you with obvious or trite ideas. I'm just tired and slightly careless.

    Maybe something like "/promote NAME TRACK [WORLD]"
    Where we set the track just like rank, under info in the groups.yml or with the command. And world would default to the current one if left blank, like how it currently works, I think.

    The problem would be that people with no tracks would be forced to make one, along with rank, to promote normally. That's not bad at all though. An alternatve command could work though, too.

    Well thanks for listening to me ramble, I think I'm out of my mind now at 3AM in the morning. Hopefully it'll work out with tracks.

    I've got a ladder system working, using permissions' built in ladders and commands. The commands are a bit confusing, but work.

    My other idea/request is this:
    I also think it'd be useful if we could specify what groups can be added with

    This way I could give 'p2.user.addgroup.Donators' to Moderators so they can add donator permissions to someone who donates, without messing up their "town rank/permission group," and without me having to do it myself.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  20. Offline


    I am Not sure if this is a known Bug or even a bug, could be something I am doing wrong. Have 3 worlds Default world only one Group, other two worlds 16 groups. If I try to promote a user in a world they have not visited yet for Example: Survival World, It does not allow them to get promoted to the specify Group (Command Using: /groupset username Groupname Survival) But if they have visited that world and Establish Guest Group by Default, that command allows me to promote them up to a different group. I have tried multiple commands and attempts to see if it was something wrong with what I am doing, and came up with no solution. NOTE: this is still referring to 1.6.6, have not updated to 1.7.2 yet

    Plugins in Use:

    Permissions 3.X
  21. Offline


    Yes, this is an issue I meant to address in the last update but did not accidentally. I will start working on an update soon to work with the latest RB and Permissions releases, as well as fix this bug.
  22. Offline


    2011-07-02 15:05:42 [INFO] x0rtrunks used command "/promote joe_exp freebuildworld"
    2011-07-02 15:05:42 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'promote' in plugin PermissionsPlus v3.2
    	at org.bukkit.command.PluginCommand.execute(
    	at org.bukkit.command.SimpleCommandMap.dispatch(
    	at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    	at net.minecraft.server.NetServerHandler.handleCommand(
    	at net.minecraft.server.NetServerHandler.a(
    	at net.minecraft.server.Packet3Chat.a(
    	at net.minecraft.server.NetworkManager.b(
    	at net.minecraft.server.NetServerHandler.a(
    	at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    	at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.NullPointerException
    	at net.codej.permissionsplus.PermissionsPlus.highestRankGroup(
    	at net.codej.permissionsplus.PermissionsPlus.onCommand(
    	at org.bukkit.command.PluginCommand.execute(
    	... 12 more
    I'm not sure if this is related, but when I tried to promote a user in a world they haven't yet visited I got this error.
  23. Offline


    Ok i know im probally just missing it but is there a way to promote a person easy like /set piggypigman Admins or is there a different command. Please help
  24. Offline


    I do not permission to /groupset <MemberName> <GroupName> [WorldName]
    - p2.user.setgroup :( (no)
  25. Offline


    Group Donor does not have a rank defined for world World
    Group Regular does not have a rank defined for world World
    Group DemiAdmin does not have a rank defined for world World
    Group Moderator does not have a rank defined for world world
    group guest does not have a rank defined for world world
    group admins does not have a rank defined for world world

    My config:
    default: true
    prefix: '&7[Guest]: &7'
    suffix: ''
    build: true
    rank: 3
    - 'commandbook.spawn'
    - 'commandbook.msg'
    default: false
    prefix: '&2[Regular]: &2'
    suffix: ''
    build: true
    rank: 4
    - Guest
    - 'warpplugin.warp'
    - 'econplugin.basic.*'
    - 'mywarp.warp.soc.*'
    - 'mywarp.warp.basic.*'
    - 'myhome.home.basic.set'
    - 'myhome.home.basic.home'
    - 'myhome.home.basic.delete'
    - 'myhome.home.soc.*'
    - ''
    default: false
    prefix: '&6[Donor]: &6'
    suffix: ''
    build: true
    rank: 5
    - Regular
    - 'worldedit.navigation.thru'
    - 'worldedit.navigation.descend'
    - 'worldedit.navigation.ascend'
    - 'worldedit.navigation.unstuck'
    - 'worldedit.navigation.jumpto'
    - 'worldedit.navigation.up'
    - 'commandbook.give'
    - ''
    - 'commandbook.whereami'
    - 'commandbook.clear'

    default: false
    prefix: '&1[Moderator]: &1'
    suffix: ''
    build: true
    rank: 6
    - Donor
    - 'commandbook.bans.unban'
    - 'commandbook.bans.ban'
    - 'commandbook.kick'
    - 'commandbook.bans.isbanned'
    - 'commandbook.clear.other'
    - 'commandbook.mute'
    - 'commandbook.teleport'
    - 'commandbook.teleport.other'

    default: false
    prefix: '&c[DemiAdmin]: &c'
    suffix: ''
    build: true
    rank: 7
    - '*'
    default: false
    prefix: '&4[Admin]: &4'
    suffix: ''
    build: true
    rank: 8
    - DemiAdmin
    - '*'

    Help please, My admin is going to be mad if i dont get this fixed :\
  26. Offline


    You have a second world? Can you post the YML to pastebin?

    Yea, I will have that fixed in the update. Busy weekend here haven't had much time to code.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  27. Offline


    The link is broken D=
  28. Offline


    PermissionPlus freezes my server.

    14:04:36 [INFO] [Permissions] version [3.1.6] (Yeti) loaded
    14:04:36 [INFO] [P2] version 3.2 has been enabled.

    ---> stuck, nothing happens, read timed out etc.
  29. Offline


    yes i have the same problem since tuesday....i changed nothing.
    The only thing i changed was mcmmo from 1.0.25 to 1.0.29
  30. Offline


    Sorry about the downtime, It appears that one of the hosting servers has ran out of memory. It will be sorted soon
  31. Offline


    Any hints for the freezing problem?

Share This Page