Inactive [SEC] PermissionsPlus v3.2.5p - Alternative commands to modify Permissions in-game now w/MWS [1337]

Discussion in 'Inactive/Unsupported Plugins' started by DigitalTyrant, Mar 20, 2011.

  1. Offline


    PermissionsPlus - Adds ability to modify Permissions in-game

    Updated: 10/6/2011
    Version: 3.2.5p [jar]
    CraftBukkit: [b1337jnks]
    PermissionsPlus adds commands to allow administrators the ability to modify their Permissions config from within Minecraft client. The most complete Permissions editing plugin for Bukkit. Supports Multi-World. Updated for MultiPlay!​
    REQUIRES: Permissions 3.x - Permissions Thread

    Includes: P2Aliases updated 10/6/2011


    Get updates on TWITTER!

    Installation and Usage information and Permissions nodes
    are available at


    It appears that I am not the only server admin that stuck to Permissions v2.7.4 so, I have released PermissionsPlusLegacy v2.4. It is a RB1000+ compatible version of PermissionsPlus v2.3. You can download this in the change log below.
    • You can specify multiple worlds separated using a comma. Do not use any spaces after the comma.
    • You can specify all worlds using an asterisk.
    • You can specify multiple groups using commas for the /user -addgroup command.
      /user -addgroup u:Username s:Group1,Group2,Group3
    • All Usernames and Groups can be shortened. You will be notified if more than one possible match is found.
      digital = DigitalTyrant, adm = Administrator
    • With 2.x+ you must add the info variable 'rank' to your groups in order to enable promote, demote and some group functions. You can set this variable from within the game using the command:
      /group -setinfo g:GroupName i:rank s:1-100+
                         /rankset GroupName 1-100+ world 
      The higher the number the higher the rank. Make sure you use i:rank and not i:Rank it is case-sensitive.
    • You can now set Promote and Demote limits. The Promote limit is the highest rank they can promote to. Demote limit is the highest limit that they can demote from. You can set these using the commands:
      /group -setinfo g:GroupName i:dlimit s:50
                         /group -setinfo g:GroupName i:plimit s:75 
    If you use want to Permissions + PermissionsPlus while using Essentials plugins, make sure you do not have FakePermissions or EssentialsGroupBridge enabled.

    Not sure how long this will be useful with Bukkit's upcoming Permissions system, but it allows the Moderators of my server to give new members access without having to modify the .yml file directly. I will continue development until the new Bukkit Permissions system has widely replaced Permissions plugin.
    Thanks to Nijikokun, original author of Permissions.

    Thanks and Enjoy!
  2. Offline


    Hey is it possible using permissions or P2 to disable flymod for certain groups? And enable for other
  3. Offline


    I've never personally used flymod, but if it is a plugin that supports the permissions system, then yes. If it's an client mod, then not that I know of.
  4. Offline


    why can all my members promote themselves? any reason. i probably screwed soemthin up and i just dont know it
  5. Offline


    are they Ops? can you post your yml?
  6. Offline


    ahh i fixed it. idk what was wrong. i just redid them all and it worked. must have done something wrong the first time. :p
  7. Offline


    Can someone send the config file ? i dont get it how to make groups
  8. Offline



    ok i want it so default cant spawn items so how do i do it PLZ i need to know THANKS!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 12, 2016
  9. Offline


    many thx for p2.1. it'S great.

    is there a way to avoid changes of the info tag from other users, so just the user itself can set and modify the information and an admin? i guess a permission node like: and p2.user.admin.setinfo or p2.user.others.setinfo would be fine.
  10. Offline


    Can some one put a example config here. Pastiebin
    I dont no what to do with the permissions. I all the permissions to the Moderator group.
    Here is my config file.
    Can some one fix it and send it to me. :)

    EDIT: IT always says. 'Some groups do not have a rank defined, some commands are disabled.'
  11. Offline


    Go to your permissions plugin file, and add a rank attribute under the info list.

            default: true
                prefix: ''
                suffix: ''
                build: true
                rank: 1
            inheritance: null
  12. Offline


    No I will do this.

    EDIT: I still don't no what to do. I will show you what I did:

    I get the same errors, 'Some groups do not have a rank defined,some commands are disabled.' In red.

    EDIT: NVM I got it to work.
  13. Offline


    Soldier doesn't have a rank.
  14. Offline


    Why i cant add comments like

    # Admins!!!

    I am using Permissions 2.7 by Phoenix and withous Perm plus it works but now doesn't work

    Please make an update that i can edit it more on FTP...
    and please remove null
  15. Offline


    What happens when you add that comment? As for the nulls, that is most likely the YAML parser that is adding it.
  16. Offline


    When i add comment and reload server, permissions crash.... and i must restart my server
  17. Offline


    I've seen a lot of extra use of the /reload command recently. It can really cause problems with plugins and most plugins offer you something like "/pr -reload all" (reloads your permissions) that doesn't cause problems and just reloads the config files for that plugin. Try changing the file and either completely shut down the server and restart or use "/pr -reload all".

    When you say crash, is it throwing errors or you find yourself back at the desktop?
  18. Offline


    @DigitalTyrant @Reil


    default=<<command-console>>:oncommand|/lemondrop|override:user -setgroup u:<<triggerer>> s:validating $@permissions -reload all $@say <<triggerer>> has completed the tutorial!
    default=<<command-triggerer>>:oncommand|/lemondrop|override:tppos -2251 16 2909
    Works now, for anyone's reference Reil separated it into

    default=<<command-console>>:oncommand|/lemondrop|override:user -setgroup u:<<triggerer>> s:validating $@permissions -reload all $@say <<triggerer>> has completed the tutorial!
    default=<<command-triggerer>>:oncommand|/lemondrop|override:tppos -2251 16 2909
  19. Offline


    This's been settled; was a small syntax error. :3
  20. Offline


    @Jeyge - Thanks again buddy.

    @Wahrheit - How are things working on multiplay?
  21. Offline


    Can i change the prefix from [PermissionsPlus] to [Minehattan] ? Please answer because its so important ! Sorry for my bad english! :p
  22. Offline


    changelog has to show two latest versions without a spoiler
  23. Offline


    Beautiful. Just fucking beautiful.

    Stop by the server on a new account and check out the tutorial, you'll see why I wanted this so badly.
  24. Offline


    Oh suweeeeeeeet
    *Licks DigitalTyrant*
  25. Offline


    lol, all welcome, enjoy :)

    small update incoming soon.
  26. It may be stupid question but this plugin will modificate the world file in /plugins/Permissions folder?
  27. Offline


  28. Offline


    Hey, I got the /promote working.
    I wanted to make a quick suggestion; I have 20 ranks and some of the ranks have sub ranks but I can only make the rank goes like rank:1, rank:2 but if I didn't want to promote to rank 2 but rank 3 instead? couldn't there be a way to put /promote rank3 or /promote (group) that way I wouldn't have to promote several times to get from group knight to group magician since knight is rank 2 and magician rank 10.
    Idk.. just a thought.
  29. Now I got problem.
    After I use PermissionsPlus my permissions file(in Permissions folder)was complety unable to read(everything was writen in the same line).I'm sure that the fault of PP because I haven't got those problems before.
  30. Offline


    I have a feeling that is the editor you are using. I don't have a file handy right now that PermissionPlus wrote but I would bet it is only using linefeeds which will cause problems with standard text editors like notepad. Switch to notepad++ and it should work as expected.
  31. Offline


    Sounds interesting, I have no other reports of this nor have experienced anything of the sort. Could you throw it up on pastebin so I can take a look?

    Also, I didn't think of it, but @Jeyge is accurate. Notepad will not read the line breaks so you must use an alternative editor, I prefer Notepad++ as well.

Share This Page