Inactive [SEC] NoCheat v3.5.0 [CB 1.2.4 R1.0][ABANDONED]

Discussion in 'Inactive/Unsupported Plugins' started by Evenprime, Feb 15, 2011.

  1. Offline


    Xp10d3, Dereku, MyPictures and 35 others like this.
  2. Offline


    I had an older version working with yeti's permissions plugin. Can i use an older one?
  3. Offline


    All version starting with 2.0 of NoCheat no longer work with Permissions 3 (it gets ignored and OP status used instead). If you get an older version of NoCheat to work with current Bukkit versions, feel free to. I won't give support for outdated versions, and I'm very sure they no longer work with current CraftBukkit versions at all.
  4. Offline


    can you tell me how to disable certain logging messages to be displayed ingame? I get flooded with peoples lagg messages which I dont really care about.

    Thanks in advance.
  5. Offline


    Open config.txt, remove "xxxLog" from all checks that you don't want to see.
  6. Offline


    I apologize for posting this since you probably already answered it in this 68 pages..But..

    <playersname>failed timed.godmode: lagging or using godmode. VL 100

    We get SPAMMED with this error. Does this have something to do with no cheat? How do I get rid of it? Do you need anymore information?

    Once again sorry if you already answered it :(
  7. Offline


    It seems there are conflicts between Spout and NoCheat. If you use spout, please just deactivate that check by setting "timed.godmode.check = false" in the config.txt of NoCheat.
  8. Offline


    Does NoCheat not work with Spout no matter what version? Would updating Spout also help? Thanks for the help! I think I have one more error I just need to log on to find out what it is/why its popping up. For some reason it doesn't show in the logs only on screen in game
  9. Offline


    I've tried it for a bit now and couldn't really find a problem with Spout (I just thought there would be one because people that complained all used Spout). I tried the recommended version of Spout on RB 1337, with and without the Spoutcraft client. So back to square one.

    I'm currently modifying that check and other things to be less sensitive and hopefully get rid of the problem that way (whatever the problem is/was). I won't be able to finish today, but tomorrow this time I should have it ready and uploaded.

    You could try then again
    Jessicadawn likes this.
  10. Offline


    I built an obstacle course which requires players to run jump. However, nocheat seems to be pulling them back. Is there anyway to make it less sensitive. I'm using the newest verison on nocheat
  11. Offline


    By any chance you are using PermissionsEx? If so, look at the documentation of modifyworld, especially at the permissions nodes that come with it. You'll find that it includes permission nodes for "sprinting". Players need those nodes, or else sprinting on servers gets broken.
  12. Offline


    prime i know the reason becouse of the sprinting now!!! it is commandbin blocking it, owners of servers needs to go into commandbins yml config and change allowsprinting: false too true! you may add it in you'r thread so people would know.
  13. Offline


    Thanks for that! Man, why do people keep adding that s**t to their plugins, if they do not enforce it. Setting sprinting to false in CommandBin doesn't prevent people from sprinting in any way, unless NoCheat is installed on the server too. And in that case, I always get people complaining about my plugin making mistakes. :/

    I've left a message in the authors thread explaining the problem. But as more and more plugins start to creep up doing that really stupid thing, I can just as well counteract them directly by reverting everything they do to "PlayerToggleSprintEvent".
  14. Offline


    well im glad i could help since im the one who blamed you for the problem before. sorry.
  15. Offline


    No problem. :)

    It's always great when people come back and tell me what the problem was (sadly the exception rather than the rule). Next version of NoCheat will simply override such imho stupid ideas of other plugins (there is another common thing that always bugged me with other plugins, coincidentially CommandBin does that too).

    You'll get the option to not do that, but I'll activate it by default just to reduce the number of complaints.

    NoCheat v 2.16 (took quite some time):
    • far less sensitive Godmode check
    • removed "blockplace.onliquid" check (because it seemed to be buggy in certain situations)
    • make sure to only check direct attacks in "" checks, not e.g. arrows
    • new option "debug.compatibility" defaulting to "true": Fix some bad behaviour of other plugins on the fly ...
    • ... that should fix the "I can't sprint despite having permission"-type problems people have
    • massive rewrite of NoCheats internal handling of events, started to collect everything that's not Bukkit-API calls into one class to make porting of the plugin to other projects that are based on Bukkit (e.g. glowstone) far less painful, better encapsulation of each test type, class hierarchies, less code repetition, ...
    • I hope I didn't bork anything in the process. I've tested a bit and didn't find anything serious, but if you do, please tell.

    More detailed explaination:

    People who complained, I hear ya! Godmode check is much more permissible now, while still catching onto those that use the actual hack pretty fast (takes about 3-5 seconds for NoCheat to notice it).

    Blockplace.liquid is gone. I still don't know why some people got problems with it (probably a conflict with some other plugin), but I rather not have it in NoCheat and people happy without complaints than keeping causing people troubles like that.

    Thanks to somebody who reported that, ARROWS now no longer get checked by the "" checks. I thought I had excluded them already, but I was wrong.

    People who have problem with not being able to sprint despite having setup NoCheat correctly, rejoice! I've added a new option "debug.compatibility" that controls if NoCheat should take matters in its own hands and just prevent other plugins from doing those things that lead to you not being able to sprint correctly. It's active by default (because only a felt 10 % of my users bother to even open their config.txt once in their live).

    The rewrite stuff is mainly to make coding stuff faster and be able to (in future) add compatibility stuff for other plugins (I'm thinking about spout related things here). They were the main part of my work over the last two weeks, and I think it was worth it.

    Hopefully no new bugs crept in.

    As usual, get it early here

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  16. Offline


    Permissions ex yet :d already complained to the dev and thanks for the update
  17. Offline


    PermissionsEX v1.15
    NoCheat v2.16

    When using the latest nocheat v2.16, randomly people wouldnt be able to build in areas that are allowed to build in those areas. Its very random it seems even People of same PEX permissions seem have the randomly get the no build problem. Reverting back to v2.15 remedies this problem.
  18. Offline


    with 2.16 a few users are complaining that sprinting is bouncing them back after a while.
    Im using default configuration as always - regenerated with 2.16 (sprint at 40)
    2.15 however was fine with no issues.
  19. Offline


    What does the NoCheat log say to that? It should contain some reason for why building was blocked for those people.

    I'll look into that. I didn't run into such a problem while testing.
  20. Offline


    There is a very extremely serious issue with 2.16!
    I have been ripping my hair out all day over it, untill finally I tried something and traced it down to no cheat.
    Please keep in mind this is with a default newly generated configuration on 2.16
    (I have pmed you my plugin list for refrence - I like to keep it private)
    The issue I was having was that RANDOM and i stress RANDOM users were not able to build in areas they should be able to build. - Thus no way I would think it was nocheat. It was random so hard to trace down, (say 2 users out of 40 online had it) and seeing as it was a building problem i wouldnt think of looking at no cheat. Removing no cheat and restarting the server wouldnt help me trace it, as I usually had to wait quite a few minutes untill it somehow started for someone again.
    I ended up using a jsonapi mobile application I have connected to the server and started disabling plugins with a few of the users that had this issue. The entire building/breaking issue which occured randomly dissappeared upon disabling NOCHEAT. As soon as I disabled it while the server ran, the users with the issues were able to build/break immediately.
    There was no errors, no messages ingame, in console, etc during this problem.
    I have rolledback to 2.15 and the entire issue is gone.
    The above sprinting issue doesnt exist in 2.15 - but its nothing compared to the major issue with building/breaking that exists in 2.16
    Unfortunately I have no idea how to reproduce it, it was ..... the most random thing I have seen, and was alwasy linked to a different user after every restart.
  21. Offline


    same issue
  22. Offline


    @andrewkm : Thanks for the plugin list, although I don't see anything suspicious in it yet.
    @Darcion : Can you PM me your plugin list too?

    I've uploaded a version 2.16a now:

    It changes the only thing that imho could be a possible reason for players getting blocked from building stuff without messages from NoCheat getting logged. Plus it changes how NoCheat determines if a player is sprinting. If your sprint-related problems go away because of that, please tell me.

    The only thing that puzzles me is that the logic of those checks is really identical to 2.15. All I changed was the surrounding stuff, how the events are handled etc., the core is pretty much C+P from 2.15.

    Nocheat v 2.16a:
    • sprinting no longer food dependent (for testing purposes - if your 2.16 sprint problem is gone now, please tell)
    • some saveguards and warnings for unexpected systemtime changes (may fix the random "can't build" problems)
    • Hopefully that helps track down the issues
    PS: Also, if the problem reappears, can you try and deactivate the "blockplace.direction" and "blockbreak.direction" checks instead of the whole plugin? That would narrow it down for me, if that (not) fixes the problem.
  23. Offline


    @Evenprime i has send you something about my plugins
  24. Offline


    I will try it sometime tonight once traffic dies down, we are picking up for the day so I cant mess around too much at the moment. ( Just about to hop in bed too :p )
    - As well forgot to mention i have my logs disabled and all three settings to off usually... so thats why i may not have been seeing logs from the problem. I will try again when I get a chance and will leave logging on. (However I am 100% certain no cheat was causing the issues) - No one has complained whatsoever since reverting back to 2.15
  25. Offline


    Craftbukkit 1337
    NoCheat 2.16a

    I've noticed with nocheat 2.16a that when players are riding in carts managed by minecart mania (although this might not be involved) they trigger a mass warning of moving.running.walking. I didnt notice this with 2.15 though.

    Unsure why it is suddenly triggering.

    Edit: did more testing, seems minecart mania isnt involved. It happens whenever you get into a cart.

    Edit 2: More testing, this does NOT happen with NoCheat 2.15
  26. Offline


    I've identified where the problems with minecarts and failed reach checks in creative mode come from. Currently uploading new version to fix both. Thanks for all your error reports and patience. I appreaciate the time you all take to help me find and track down those things.

    Found it and fixed it. Thanks again.

    NoCheat 2.16b
    • fixed failed reach checks in creative mode
    • fixed minecarts and other vehicles making problems in relation to the playermove check
    • I believe there may still be a bug somewhere in there, so if you notice something that wasn't a problem in 2.15 but is now, please tell. I can't fix what I don't know.

    I think I finally tracked down the issue. If it really is the problem that I think it is, this should fix it. If it does fix it, I'll just have to find out why the problem happens in the first place.

    NoCheat 2.16c:

    • Likely fixed the random "player can't build, destroy blocks or fight" bug that happened since 2.16.

    Thanks for testing:

    Yes, seems I hit the squished that bug finally. 2.16c fixes pretty much all "it worked in 2.15, now it don't" problems you may have encountered.

    Most obscure bug ever.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  27. Offline


  28. Offline


    PEx should work now again. Just avoid version 1.15.1 of PEx, that one is broken. 1.15 and 1.16 should be fine.
  29. Offline


    so all the sub permissions should work ?
  30. Offline


    Yes, they should work as expected with PEx 1.16 again. E.g. the permission "nocheat" will also give a player "nocheat.admin", "nocheat.admin.chatlog", "nocheat.admin.permlist", ... and "nocheat.checks", "nocheat.checks.moving", etc. etc. automatically.
    RugRats likes this.
  31. Offline


    so do individual checks work as well?

Share This Page