[SEC/FUN/INFO] Towny v0.68 Fuzze Edition [818]

Discussion in 'Inactive/Unsupported Plugins' started by FuzzeWuzze, Apr 10, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Version: v0.68

    Moderator Edit: Please direct your attention here for an updated version. This thread is now closed due to people spamming random things about how its not working.

    So this has been asked for many times so i decided to finally make this thread.
    This is related to Shade's brilliant Plugin Towny

    Since Shade has been MIA for a while now, and we dont know if hes coming back i've been trying to keep Towny afloat as best i can in hopes he does come back as i dont really have the RL schedule to much of anything other than maintain it to be usable.

    I hope in June once i have more free time if Shade still isnt back :'( to actually do a formal Github Fork and continue the project. So until then, dont bother asking for new features, as time allows the only thing i'll try to do is fix large glaring bugs that effect the mod. This is a very large plugin and Shade has spent a lot of time on it, so even when/if i do fork it will take some time to get fully up to speed on everything. For now i just have a basic understanding of how everything is interacting and enough debug skills to track down most bugs ;)

    How it works/Features
    -See Original Towny Page for Instructions on how to setup and Permissions.

    Read this page to learn what everything in the config does!

    When reporting bugs, please use /townyadmin set debugmode on. Then perform the action and post or send me the log from your server. This will assist me in being able to fix the issue 10 faster, just simply saying "People can do X in my town when they shouldnt be able too" doesnt really help me at all and is impossible to replicate.
    • Permission cache errors
      • You didnt install Permissions properly, it creates a RENAMEME.yml file or something of the like when first started. This must be renamed to match your world name(for most people world.yml). Also you CANNOT have spaces in your world name. Test World is not an acceptable folder name, TestWorld is. Both towny and permissions dont like the Permissions YML file to have spaces.
    • /town top money causes exception
      • Your iConomy database is likely setup to still use sqlite. Ensure that your iConomy config file is setup to use database Type: H2SQL. A lot of people had issues with the sqlite to H2 conversion, if you still experience this error with it set properly your db may be corrupt. Back up your iConomy db and configs, then delete them all and allow iConomy to recreate them and see if it still happens. If it doesnt, your going to have to manually regrant people cash somehow as your iConomy database was corrupt.
    • towny.admin: User is able to use /townyadmin, as well as the ability to build/destroy anywhere. User can also able to make towns or nations when set to admin only.
    • towny.town.new :User is able to create a town (only is use when TOWN_CREATION_ADMIN_ONLY is on)
    • towny.town.claim : User is able to expand his town with /town claim
    • towny.nation.new :User is able to create a nation (only is use when NATION_CREATION_ADMIN_ONLY is on)
    • towny.wild.*: User is able to build/destroy in wild regardless if the config says no.
    • towny.wild.build
    • towny.wild.destroy
    • towny.wild.switch
    • towny.wild.item_use
    • towny.wild.block.[block id] : User is able to edit [block id] in the wild.
    • towny.spawntp :Use /town spawn when allow_town_spawn=false
    • towny.publicspawntp : Use "/town spawn [town]" (teleport to other towns) when allow_town_spawn_travel=false.

    All versions .64 and after will require iConomy 5.0 and higher. When making this initial transition it is HEAVILY advised that you back up your h2 and MySQL database's. I tested as well as i could with various functionality within Towny and it seemed to be working as expected. Also note that a ton of plugins that use iConomy are still broken, so unless they ALL work i wouldnt suggest updating. You've been warned. Dont cry if something bad happens and you dont have a backup of your iConomy database ...
      • Essentials 2.2
      • Permissions 2.7.4(DO NOT USE 3.X!)
      • iConomy 5.01
    • (JAR ONLY) Latest Build(.68) HERE
    • V.61

    • Fix /towny top money from crashing towny
    • Investigate potential issues with build/destroy permissions.

    • /town spawn will not charge players
    • DO NOT GIVE PLAYERS TOWNY.WILD.* permissions. Give players permissions by editing your config file by editing these. If players have wild permissions they can do funny business to get permission to build in other peoples towns.
    • Some people are reporting a lot of [SEVERE] warnings related to Player_Item and Player_Move, i believe these are being triggered by other mods. If you are having this issue please list your other plugins.

    Version .68
    • Compiled for CB818 (Minecraft 1.6.6)
    • Disabled town renaming (finally)
    • Do not use Permissions 3.0.x with Towny yet, there are still some MAJOR issues with the rework they are doing and a ton of people are nerd raging on their thread. I couldnt even get it to create my config or default files they were always blank, and i guess a ton of other people are having the same issues. Still didnt work when following instructions on how to make the file yourself. Because 2.7.4 works perfectly fine with CB818 im not in a rush to upgrade until they figure out their issues. Sorry if this causes plugin conflicts if some require Permissions 3.x but i doubt it will as not many mods are moving to it in its badly broken state. Because Towny is so heavily dependent on a lot of Permissions nodes being read properly i decided to stick with 2.7.4 for now. Ill work on a 3.x permissions build as soon as i feel its functioning properly.
    Version .66
    • Compiled for CB766
    • Players no longer need to /town set spawn, when a player does /town spawn they automatically go back to their town. Need to figure out how to re-implement the essentials teleport timer cooldown they changed their API
    Version .64
    Version .63
    • Really fixed /town spawn!
    Version .62
    • First Official Release by Fuzze!
    • Fixed /town spawn INVESTIGATING
    • Fixed /towny map
    • Verified all permissions are working properly. I ran it on my test server and tested resident build/destroy/switch and outsider build/destroy/switch by using /town set perm and turning them on and off and trying them out. ALL the permissions acted as they should. This should put to rest a lot of bugs people are having with people building. This doesnt mean Towny is using the default_town_build=false config lines properly for new towns, thats next. It does mean if your mayor sets the options manually it works.
    Version .061R6
    • Disabled /towny top money for towns/nations until able to fix bug related to null iConomy accounts, I have a feeling its related to iConomy databases that were SQLite and transitioned to H2 like my own. It *should* work fine for Residents, so far i havent seen null resident returns.
    Version 0.61R5

    • Updated to work with CB670
  2. Offline


    essentials economy :(
  3. Offline


    i donated a small chunk of money. maybe shade will come back?
  4. Offline


    Wait, what do we do if we can't give users 'towny.wild.*'...?
    More details please.

    EDIT: Nvm, I just misunderstood it. I got it. Thanks.
  5. Offline


    Alright alright you guys are killin me lol, i think i got it in the proper format.
    Ill recompile to the latest RB tonight since it just changed...
  6. Offline


    My Apologies if I'm not the first to mention this - it's a bit tricky to follow the thread of Towny development right now :)

    starting or reloading my server with Towny installed results in my permissions.yml file for my world (Dexteria.yml) having all the contents changed to "{}". This is using CB670 and and FuzzeTowny 0.61 on Ubuntu 8.04 server.
  7. Offline


    Also /town leave doesn't work. Keeps saying[Towny] Not registered
  8. Offline


  9. Umm, i have a problem when i delete a town, the area displays "TOWNAME Ruin" Please help how to remove
  10. Offline


    I don't know if you have time to fix this but when I add towny to my server and start it up I get the message repeatedly [Towny] Could not create permissions cache for this worl (Rawhide's Place.

    Please help me
  11. Offline


    Is there any way to allow all mobs in a town except for Creepers? We want guards to have something to do at night, and protecting the town from baddies is a big part of that.

    I know in the past you could do that, but for some reason, under the config it now just says "Monsters".
  12. Offline


    Not sure if this was stated somewhere else, or if it's blatantly obvious, but if Towny works by giving chunks of land to people, how do you make roads without getting them grieved to death? There's no space in between chunks for roads, and 16 blocks is a little wide to designate an entire chunk for a road.. Meh.
  13. Offline


    I changed my chunk size to 8x8 in the config, this allows mayors to set 8x8 roads off which is a good size.

    Those with permissions issues, specifically the cannot create cache, are you sure that your permissions file is renamed properly to match that of your world name? Thats most peoples problems.
    I have zero idea why Towny would be clearing permissions, it doesnt have access to do anything of the sort...

    And yes you can individually set what can spawn this is my line from my config
  14. Offline


    Fuzze, you're the shit. ( That's good by the way. )
  15. Offline


    I thought it was strange that having Towny.jar in my plugins folder would cause my permissions.yml to get wiped, but it's like clockwork - insert towny.jar, away goes permissions - no error messages or anything when it loads everything, either...

    Is there any way i could get you more data that could be helpful? Is this actually an issue with permissions? Is my server stuck in a towny-less doomhole? :)

  16. Offline


    I must say, you have saved my butt once again. I wish no ill will upon Shade what so ever, but great job, and please keep up the good work! =D
  17. Offline


    What version of Permissions are you using? I compiled against...uhm 2.6 which is what my servers using.
  18. Offline


    Permissions 2.6 (Phoenix)

    Ok so I think I figured out why. In my permissions folder I had both a "Dexteria.yml" and a Dexteria.yml.1" file, the second being from a copy command that I had never deleted. After having gotten rid of that file, Dexteria.yml seems to stay the same. I don't think the problem was just Towny anymore because even while removing towny got rid of the "{}" problem, my yml file was still randomly dropping changes, etc.

    If anyone else has problems with their permissions config file acting up, make sure it's the only file in that folder, i guess...

    Thanks FuzzeWuzze for looking into it, I appreciate that, and the work you're doing on this plugin!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  19. Offline


    a.. i find the reason. iZone is buggy. this plugin mass my server about pvp setting(MultiVerse,Towny..etc).
    anyway, thk Fuzze
  20. Offline


    so i have a question. is there any way to add boseconomy support? other then that, thank you so much friend. ill let everyone know.
  21. Offline


    great job works perfect
  22. Offline


    isnt shade working on the new mod called canary?
  23. Offline


    First, thanks so much for this great plugin! I've read enough plugin threads to know that people don't say "Thank you!" nearly enough to plugin developers! Fuzze, you are awesome for keeping this up and running!

    Second, I'm not much of a programmer but I want to do what I can do to help. I'm decent as a documenter so I offer my services as such :) With this in mind, two things 1) Would you like any tutorial videos made for your plugin? I have FRAPS and a decent computer so I wouldn't mind making some sort of tutorial video for this plugin if you want :) Just quote part of this message or send me a PM or something if you do! 2) I'd like to share the configuration of my working server to help answer others' questions.

    I have several plug ins, including this one, up and running and (so far as I can tell) they are all getting along and working. I know when I go looking for new plugins I'm always curious if somehow the new plugin will 'break' my current plugins so I'm posting this info for each of the plugins that I use. People always post in a plugin's thread when things don't work so I want to post something that does work for comparisson :)

    Basically, I just want people to know that yes, you can run this plugin and all these other ones without breaking the world.

    Pastebin of config file for Towny: http://pastebin.com/PEjusxJj

    Current Bukkit Version: 670

    Plug Ins

    CommandBook 1.2.1
    HeroChat 4.10.1
    iConomy 4.6.5
    LocalShops 2.2.1
    mcMMO 0.9.27
    Permissions 2.6
    PreciousStones 3.2
    Runecraft 2.5.1
    Towny v61Fuzzev5_CB670 (semi-officially forked version) (Note the semi-official fork now has a semi-official bukkit thread here.)
    VirtualChest aka GiftPost 3.3.1
    WorldEdit 4.3

    Pastebin of server.log on restarting the server: http://pastebin.com/n4yqxWSG

    Pastebin of my Permissions file (since I currently only have one world and that world is called PhoenixRealms, the file is called PhoenixRealms.yml): http://pastebin.com/4ySk7qD9
  24. Offline


    You are a brave soul Fuzze. Towny has so many bugs that it'd be a nightmare to manage. Someone just needs to fork this asap and make it their own plugin. There are entire sections that just need a re-write.
  25. Offline


    I might try this out because its such a great plugin and id love to see it being redeveloped. If you do this, you my good sir are a legend. =)
  26. Offline


    can you add something like /t join if you are invited?
    And please tell me how to change Mayor color.. well it is blue, but i want other :D
  27. Offline


    I am trying to create a town and it seems i cant. I am using an admin account, but when i type /t add [townname] it says: [Towny] Resident doesn't belong to any town.
  28. Offline


    thats the wrong command its /town new [townname]
  29. Offline


    Yes, i have great aspirations to attempt this feat come June once im on school break, because it does not appear Shade is coming back. It will probably be rewritten to use H2 database's as most other plugins are transitioning to that.

    Also thanks for all the kind words from everyone, ill do my best to keep it running and i still need to squash a few bugs just been really heads down with work and school.

    I have some awesome(i think) idea's for sub-plugins for Towny that would add a lot of really nice functionality ...all in due time.

    This, /town add is for adding residents to a town.

    As i understood it Canary is/was an attempt at an alternative to Bukkit, or are you talking about something else?

    At this point i dont see anything really taking the crown from Bukkit, the API is so developed nobody really cares about hMod support anymore.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  30. Offline


    Fuzze, Thanks for taking this on.
  31. Offline


    For some reason I get this weird 'You Do Not Have Permission To Do This' line when I place a block in wilderness, sometimes even my own town. We have been testing with the Permission nodes, but as of right now, I don't have any nodes and when I'm not OP/Admin, I get that line. The block is still placed, but that permission line keeps on coming back. Anyway, I don't know if I am being descriptive enough, but does anyone have any similar problem?

    edit: I know that you are trying to look into this problem, but I was curious as if anyone had fixed it.
Thread Status:
Not open for further replies.

Share This Page