Inactive [SEC] BigBrother 1.11.0 - Catch griffers red-handed [1060]

Discussion in 'Inactive/Unsupported Plugins' started by N3X15, Apr 13, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    N3X15

    [​IMG]
    Important Crap

    I'm done, but BB isn't.
    I've got 10 developers on the contributors' list who supposedly want to help, but I haven't heard a word from them since the day I added them. BigBrother's so full of bugs now that I don't know where to start, and I simply don't have the time or patience to work on it anymore. If you want something that works, pick up LogBlock. I'm fucking done. I updated it to "run" on 1060, but that's as far as I'm taking this. If you still want to help, email me at nexis@7chan.org and give me a rundown of your experience in coding plugins so I know you'll do something.​
    UPDATE: 3 developers have been added to the repo, but I'm waiting for them to get familiarized and start committing before I declare this crisis over. I appreciate the support and help that has been thrown this way. If you'd still like to help, but don't know how to code, there are many other ways to contribute. See the Contributors section for more info.​


    Version: 1.11.0
    Original Author: tkelly910

    Contributors
    • Development Team
      • N3X15
      • Mafio
      • FalconGaming
    • Quality Assurance (QA) Team (Testing, ONLY ON LATEST RB*!)
      • N3X15
      • Mineral
      • All of the poor bastards on the 7chan.org minecraft server + other dev servers
      • *NOTE: Unless EvilSeph or other bukkit devs indicate an RB is imminent, e.g. within the next week.
    • Bug Triage (Sorting through bugs, marking duplicates, closing, prioritizing)
      • N3X15
    • Documentation (Wiki, FAQ, other stuff people will read)
      • N3X15
    • MORE NEEDED. PLEASE PM ME IF YOU ARE INTERESTED IN TESTING OR DEVELOPING.
    Introduction

    BigBrother is a powerful plugin that enables you to investigate roll back griefing via a large and all-knowing database. You have a choice between using immensely powerful commands to search an area for changes, or you can whack a block with a stick or place a log to see changes within a single block.

    • /bb log - Gives you the BigBrother Multipurpose Tool, or a simple log. Hit something with it to see changes in that spot, and place it if the block you're check is non-solid, like water, lava or air.
    • /bb done - Removes the log from your inventory, and gives you back any items it replaced.
    • Want to check an entire area? Use /bb here to list who changed what!
    • Need to roll back EvilGuy and DoucheBug's edits? Use /bb rollback EvilGuy DoucheBug!
      • Have to roll back edits up to 5 minutes ago? Simple! /bb rollback t:5m
      • Need to only roll back within a certain radius? /bb rollback r:<radius-in-blocks>
      • Roll back specific actions with /bb rollback a:10,BLOCK_PLACE
    • If you screw up, /bb undo
    • (NEW) /bb history "Suspicious Guy" to see that player's recent history! (add pg:# to go to page #)
    • Mow your lawn with /bb mowlawn!
    See the full list of commands and Permissions nodes here.

    Screenshots

    [​IMG]
    [​IMG]
    [​IMG](Yes, stationary_* and regular blocks got reversed, this is fixed.)​
    [​IMG]

    Need Help?

    • What version of CraftBukkit and BigBrother? If you don't know, type /version and /bb version.
    • What database engine are you using? Look at the value for database.type in BigBrother.yml. I use MySQL on my server and test on H2.
    • Do you get any errors? If so, please link to a pastebin with your server.log
    • What steps do I have to take to reproduce this behavior?
    • What other plugins are you using?
    Known Issues
    • Everything listed here
    • ItemCraft is not supported due to it sending unexpected NULLs via Block.getType(). Can be fixed by adding a new enum value for unknown blocks.
    • Bugs everywhere, stopped counting.
    Coming Soon
    • /bb history - Gets the history of a player
    • Fixed /bb update
    • Updated API
    • Externally accessible API
    • Custom Action IDs (for WorldEdit support, etc.)
    More Information

    IRC: Support/Chatter/Developer Jive @ irc.7chan.org #bigbrother (Moved so my build notification bot has an easier time notifying multiple channels)

    Changelog
    BigBrother 1.11.0 Changelog
    • Centralize and update bystander checks.
    • Fix parsing errors in DeltaChest
    • Clarify /bb log
    • Fix sign lines being too far down
    • Add command censoring (for people worried about xAuth and the like)
    • Fix pagination capping
    • Fix an error in DeltaChest reading
    • Add ?autoReconnect=true to the MySQL DSN
    • Remove all H2 support
    • Removed /bb stick from /bb help since it is now obsolete
    • Fixed it so commands that work won't say commands not recognized after they already work
    • Fixed the issue of when you had the /bb log if you broke something it would not record the break even if you were watched
    • Now if the user tries to find the history of an invalid user it won't throw null errors.
    • Yell at the users if they don't follow the setup procedure
    • Should fix most of the errors dealing with the log and watch/unwatch problems
    • Update README
    1.10.0+ (open)

    BigBrother 1.10.1 Changelog
    • Fix a rollback SQL syntax error
    • Fix explosion logging
    • Clarify database trimming message in log
    • Fix /bb history
    • Continue rolling back incorrectly-logged BlockBurns, if the data field is unparsable, default to 0.
    • Fix Heartbeat logging
    • Fix SuperPerms support.
    BigBrother 1.10.0 Changelog

    New Features:
    • Brand new plugin API! (Wiki)
    • Database change. There is now a converter, but you might still lose data!
    • Compact chest changes: (+Added)(=Replaced)(-Removed)
    • Heartbeat Action: Logs users online and the current time, both to keep your database connection open, and for monitoring of your server's uptime!
    • Piston Actions!
    • Bukkit Superperms support!
    • RB 1000 support!
    • /bb history!
    • Formatting fix for rollbacks
    • A buttload of NPE fixes
    Bugfixes:


    • [BB-81] Rollback doesn't work because of empty data-values
    • [BB-78/BB-69] onPickupItem/onDropItem NPEs
    • Memory leak fix (Thanks to Wootalyzer!)
    BigBrother 1.9.1:

    • Use BlockSpreadEvent for tracking fires (later told by EvilSeph that there's no current way to track fire in Bukkit)
    • Display a "Permission Denied" to users trying to use commands with insufficient priviliges instead of silently failing.
    • Add /bb mowlawn.
    • Fix stupid mixup between String.format usage on C# and Java in DeltaChest
    • Automatically update plugin.yml via Maven (internal crap)
    BigBrother 1.9


    • Support for 928+
    • NEW: Lava/Water/Fire flow logging (AND ACTUALLY TESTED, FOR ONCE!)
    • NEW: a: directive for rollbacks, for specifying comma-delimited action IDs to track
    • Lots and lots of bugfixes.
    • Marginally better H2 support
    • More automated tests
    • Standardized QA tests (ongoing)
     
  2. Offline

    Ablac

  3. Offline

    SpawnSC

    thanks for the help on the logs guys :)

    now next issue. When I try to do a rollback it works and doesn't work.

    Example.

    If I break a block and do /bb rollback spawnsc t:10s I get "Nothing to Rollback"

    If I place a block and do the same command it works fine.

    Anyone else have this issue? i'm not using MySQL but h2
     
  4. Offline

    strontkever

    Bump for getting pistons tracked :)
    it does say "placed piston..."
    but not removed piston
     
  5. Offline

    Jobsti

    Huhu @N3X15

    What's about to log the Player which triggered the creeper, for the next update?
    I saw something in LogBlock to log this?! Would be nice to have this in BB.
     
  6. Offline

    Reiver

    I've got an odd issue

    My BB on my server is logging sporadic clusters of environment triggered piston move events on a world that doesn't exist on our server (listed as BB_Global in the bbworlds table)

    We only have two worlds, but it's got a 3rd world listed in the world table, and I get events where the Environment causes the piston to move a block of stone in the nonexistent 3rd world. How often it happens appears pretty random, with gaps ranging from a few seconds to about 20 minutes, but it always happens in groups of 4 block move events logged in the span of a single second.

    Any idea what could be causing this?
     
  7. Offline

    obscurehero

    um...

    I CAN"T figure out how to connect to my MySQL server. I think its drawing from the bukkit.yml for the server location. Is this something new in RB1000. I have it running on the same machine as the server, and our server is too small to make running mysql worth it for anything but bigbrother which does generate large logs... If I change the database type and location in bukkit.yml it breaks the other plugins that like H2SQL.

    I need help!
     
  8. Offline

    Traybair

    The download website is blocked through OpenDns on my network?.. I can unblock it but what is on the site that would cause it be blocked?


    Edit: After looking in OpenDns it says the site is categorized in "Hate/Discrimination, Tasteless, Nudity, Pornography, Forums/Message boards" lol Why???
     
  9. Offline

    but2002

    Because Forums/Message boards apparantly are blocked on your network. (No idea why bukkit.org is allowed)
     
  10. Offline

    Traybair

    Pornography, Nudity and Tasteless are blocked. Forums/message boards is just another one of the categories the site falls under. It shows every category a site is under regardless of whether or not it is blocked on a network. I just want to know if this site is rightfully categorized with Hate/Discrimination, Tasteless, Nudity, and Pornography.
     
  11. Offline

    briankdk

    Anyone knows why i get all these errors when i STOP the server ?

    (i think they startet appearing AFTER i installed BB 30 minuttes ago)

    Code:
    151 recipes
    16 achievements
    04:24:12 [INFO] Starting minecraft server version Beta 1.7.3
    04:24:12 [INFO] Loading properties
    04:24:12 [INFO] Starting Minecraft server on *:25565
    04:24:12 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-945-
    g73697a4-b1000jnks (MC: 1.7.3)
    04:24:13 [INFO] [PermissionsEx] sql backend registered!
    04:24:13 [INFO] [PermissionsEx] file backend registered!
    04:24:13 [INFO] [PermissionsEx] PermissionEx plugin initialized.
    04:24:13 [INFO] [PermissionsEx] p2compat backend registered!
    04:24:13 [INFO] [PermissionsCompat] Compatibility Layer Initalized!
    04:24:13 [INFO] [PermissionsEx] Initializing file backend
    04:24:13 [INFO] Preparing level "world_test"
    04:24:13 [INFO] Preparing start region for level 0 (Seed: -5689889447613562859)
    04:24:14 [INFO] Preparing start region for level 1 (Seed: -5689889447613562859)
    04:24:14 [INFO] Preparing spawn area: 20%
    04:24:14 [INFO] CommandBook 1.5.2-customized enabled.
    04:24:14 [INFO] CommandBook: Maximum wrapper compatibility is enabled. Some feat
    ures have been disabled to be compatible with poorly written server wrappers.
    04:24:15 [INFO] CommandBook: 1 banned name(s) loaded.
    04:24:15 [INFO] CommandBook: 1 kit(s) loaded.
    04:24:15 [INFO] CommandBook: Permissions plugin detected! Using Permissions plug
    in for permissions.
    04:24:15 [INFO] [PermissionsEx] Modifyworld is enabled.
    04:24:15 [INFO] [PermissionsEx] v1.12 enabled
    04:24:15 [INFO] [Residence] - Setting Permissions 2.X compatability mode...
    04:24:15 [INFO] [Residence] Found Permissions Plugin!
    04:24:15 [INFO] [Residence] iConomy NOT found!
    04:24:15 [INFO] [Residence] Loaded Residences...
    04:24:15 [INFO] [Residence] Enabled! Version 2.3.5 by bekvon
    04:24:15 [INFO] WorldEdit 4.6 enabled.
    04:24:15 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin
    for permissions.
    04:24:15 [INFO] [PermissionsCompat] Compatibility layer enabled.
    04:24:15 [INFO] CommandBook: Permissions plugin detected! Using Permissions plug
    in for permissions.
    04:24:15 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin
    for permissions.
    04:24:15 [INFO] [iChat] Found Permissions (v2.7.7)
    04:24:15 [INFO] iChat (v2.3.3) enabled
    04:24:15 [INFO] Server permissions file permissions.yml is empty, ignoring it
    04:24:15 [INFO] Done (0,209s)! For help, type "help" or "?"
    04:24:16 [INFO] naxiis [/94.145.61.113:26613] logged in with entity id 77 at ([w
    orld_test] -24.843081204056286, 64.0, -14.884282333137715)
    >stop
    04:24:19 [INFO] Stopping the server..
    04:24:19 [INFO] Stopping server
    04:24:19 [INFO] [PermissionsEx] v1.12 disabled successfully.
    04:24:19 [INFO] [Residence] - Saved Residences...
    04:24:19 [INFO] [Residence] Disabled!
    04:24:19 [SEVERE] java.lang.NoClassDefFoundError: ru/tehkode/permissions/Permiss
    ionManager
    04:24:19 [SEVERE]      at ru.tehkode.permissions.compat.PermissionHandler.permi
    ssion(PermissionHandler.java:81)
    04:24:19 [SEVERE]      at ru.tehkode.permissions.compat.PermissionHandler.permi
    ssion(PermissionHandler.java:72)
    04:24:19 [SEVERE]      at com.sk89q.bukkit.migration.NijiPermissionsResolver.ha
    sPermission(NijiPermissionsResolver.java:61)
    04:24:19 [SEVERE]      at com.sk89q.bukkit.migration.PermissionsResolverManager
    .hasPermission(PermissionsResolverManager.java:102)
    04:24:19 [SEVERE]      at com.sk89q.worldedit.bukkit.BukkitPlayer.hasPermission
    (BukkitPlayer.java:111)
    04:24:19 [SEVERE]      at com.sk89q.worldedit.WorldEdit.getSession(WorldEdit.ja
    va:144)
    04:24:19 [SEVERE]      at com.sk89q.worldedit.bukkit.WorldEditPlugin.onDisable(
    WorldEditPlugin.java:115)
    04:24:19 [SEVERE]      at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlug
    in.java:128)
    04:24:19 [SEVERE]      at org.bukkit.plugin.java.JavaPluginLoader.disablePlugin
    (JavaPluginLoader.java:899)
    04:24:19 [SEVERE]      at org.bukkit.plugin.SimplePluginManager.disablePlugin(S
    implePluginManager.java:288)
    04:24:19 [SEVERE]      at org.bukkit.plugin.SimplePluginManager.disablePlugins(
    SimplePluginManager.java:281)
    04:24:19 [SEVERE]      at org.bukkit.craftbukkit.CraftServer.disablePlugins(Cra
    ftServer.java:157)
    04:24:19 [SEVERE]      at net.minecraft.server.MinecraftServer.stop(MinecraftSe
    rver.java:312)
    04:24:19 [SEVERE]      at net.minecraft.server.MinecraftServer.run(MinecraftSer
    ver.java:391)
    04:24:19 [SEVERE]      at net.minecraft.server.ThreadServerApplication.run(Sour
    ceFile:422)
    04:24:19 [SEVERE] Error occurred while disabling WorldEdit v4.6 (Is it up to dat
    e?): loader constraint violation: loader (instance of org/bukkit/plugin/java/Plu
    ginClassLoader) previously initiated loading for a different type with name "com
    /sk89q/worldedit/LocalConfiguration"
    java.lang.LinkageError: loader constraint violation: loader (instance of org/buk
    kit/plugin/java/PluginClassLoader) previously initiated loading for a different
    type with name "com/sk89q/worldedit/LocalConfiguration"
            at java.lang.ClassLoader.defineClass1(Native Method)
            at java.lang.ClassLoader.defineClass(Unknown Source)
            at java.security.SecureClassLoader.defineClass(Unknown Source)
            at java.net.URLClassLoader.defineClass(Unknown Source)
            at java.net.URLClassLoader.access$100(Unknown Source)
            at java.net.URLClassLoader$1.run(Unknown Source)
            at java.net.URLClassLoader$1.run(Unknown Source)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(Unknown Source)
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.
    java:36)
            at org.bukkit.plugin.java.JavaPluginLoader.getClassByName(JavaPluginLoad
    er.java:219)
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.
    java:32)
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.
    java:24)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at com.sk89q.worldedit.WorldEdit.getSession(WorldEdit.java:144)
            at com.sk89q.worldedit.bukkit.WorldEditPlugin.onDisable(WorldEditPlugin.
    java:115)
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:128)
            at org.bukkit.plugin.java.JavaPluginLoader.disablePlugin(JavaPluginLoade
    r.java:899)
            at org.bukkit.plugin.SimplePluginManager.disablePlugin(SimplePluginManag
    er.java:288)
            at org.bukkit.plugin.SimplePluginManager.disablePlugins(SimplePluginMana
    ger.java:281)
            at org.bukkit.craftbukkit.CraftServer.disablePlugins(CraftServer.java:15
    7)
            at net.minecraft.server.MinecraftServer.stop(MinecraftServer.java:312)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:391)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    04:24:19 [INFO] CommandBook: Permissions plugin detected! Using Permissions plug
    in for permissions.
    04:24:19 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin
    for permissions.
    04:24:19 [INFO] [iChat] iChat Disabled
    04:24:19 [INFO] Saving chunks
    >Tryk på en vilkårlig tast for at fortsætte . . .
     
  12. Offline

    Arton

    i dont know if it is a bug or if it is from brother but i think it is

    [BBROTHER] Removed 0 records older than 168h00m00s in 0h00m00s.
    2011-07-29 04:21:29 [INFO] [BBROTHER] Building `ownership` table...
    2011-07-29 04:31:07 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'bb' in plugin BigBrother v1.10.1-SNAPSHOT
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:320)
    at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:713)
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:677)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:670)
    at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.IndexOutOfBoundsException: toIndex = 11
    at java.util.SubList.<init>(Unknown Source)
    at java.util.RandomAccessSubList.<init>(Unknown Source)
    at java.util.AbstractList.subList(Unknown Source)
    at me.taylorkelly.bigbrother.commands.HistoryCommand.onCommand(HistoryCommand.java:70)
    at me.taylorkelly.bigbrother.BBCommand.onCommand(BBCommand.java:57)
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    ... 12 more
     
  13. Offline

    Gizmokid2005

    I get this error randomly in console with 1.10.1 and Bukkit 1000

    Code:
    22:22:10 [SEVERE] java.lang.NumberFormatException: Value out of range. Value:"210" Radix:10
    22:22:10 [SEVERE]       at java.lang.Byte.parseByte(Byte.java:147)
    22:22:10 [SEVERE]       at java.lang.Byte.valueOf(Byte.java:199)
    22:22:10 [SEVERE]       at java.lang.Byte.valueOf(Byte.java:225)
    22:22:10 [SEVERE]       at me.taylorkelly.bigbrother.datablock.DeltaChest$DeltaEntry.<init>(DeltaChest.java:132)
    22:22:10 [SEVERE]       at me.taylorkelly.bigbrother.datablock.DeltaChest.processDeltaStream(DeltaChest.java:82)
    22:22:10 [SEVERE]       at me.taylorkelly.bigbrother.datablock.DeltaChest.getChanges(DeltaChest.java:451)
    22:22:10 [SEVERE]       at me.taylorkelly.bigbrother.datablock.DeltaChest.toString(DeltaChest.java:461)
    22:22:10 [SEVERE]       at me.taylorkelly.bigbrother.datasource.ActionSender.sendBlocksFlatFile(ActionSender.java:121)
    22:22:10 [SEVERE]       at me.taylorkelly.bigbrother.datasource.ActionSender.access$100(ActionSender.java:31)
    22:22:10 [SEVERE]       at me.taylorkelly.bigbrother.datasource.ActionSender$SendingTask.run(ActionSender.java:183)
    22:22:10 [SEVERE]       at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    22:22:10 [SEVERE]       at java.lang.Thread.run(Thread.java:636)
    
     
  14. Offline

    Legendpla

    Please someone tell me how to add permissions for my mods+ to use this?!
     
  15. Offline

    pontuzz

    Heya, one of my admins did a rollback but he made a mistake:

    /bb rollback TR1GG4H4PPY 10m 2011-07-28 23:14:16

    Is there any way for me to undo this? all the edits made by this player was undone,, this means roughly 200blocks of rail, 500pistons and some statues,,

    Can i roll somehow undo the rollback he made?

    Thx guys, apretiate any help i can get

    EDIT:

    I cant just undo either, because our server is restarted every 6 hours automaticly so theres no logged rollback in bb :/
     
  16. Offline

    Lookatmego

    hey i got a problem some of the blocks placed arnt being logged-.- i dont have them disabled and i checked by making some 1 place something and checked that and it worked but sometimes when they do it doesnt log it wat so ever...any ideas?
     
  17. Offline

    shadydeath999

    memory issue still not solved?
     
  18. Offline

    y1985

    How to open bigbrother.h2.db?
     
  19. Offline

    TapAforApple

    @N3X15
    I'm so confused, when i start up my server, BigBrother loads up perfectly but at the end it says 'no /help support'
    I have no idea on how to fix this, please reply back
    Apple,
     
  20. Offline

    tkausl

    "Help" is an Plugin to use the Command /help.
    If you hasnt this Plugin, You cant use Help -> "no /help support"
     
  21. Offline

    TheAswomeBoy123

    So i have just gotten Big Brother and it is not working in the server log it says it cant find the big brother help command and all the commands dont work does big brother NEED permissions to run or can i use group manager.
     
  22. Offline

    shadydeath999

    groupmanager for bigbrother works here
     
  23. Offline

    TheAswomeBoy123

    Could it be a plugin im useing?
     
  24. Offline

    shadydeath999

    did you set the permissions correct?
     
  25. Offline

    TheAswomeBoy123

    i never set permissions my admins just have the '*'
     
  26. Offline

    danielisacrab

    I've got no idea about this. I updated to 1000 and the newest build. This is the error I got:
    Code:
     Error occurred while enabling BigBrother v1.10.1-SNAPSHOT (Is it up to date?): me.taylorkelly.bigbrother.BBPermissions.initialize(Lorg/
    bukkit/Server;)V
    java.lang.NoSuchMethodError: me.taylorkelly.bigbrother.BBPermissions.initialize(Lorg/bukkit/Server;)V
            at me.taylorkelly.bigbrother.BigBrother.onEnable(BigBrother.java:142)
            at org.bukkit.plugin..java.JavaPlugin.setEnabled(JavaPlugin.java:126)
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:878)
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:272)
            at com.bekvon.bukkit.plugman.PlugMan.enablePlugin(PlugMan.java:338)
            at com.bekvon.bukkit.plugman.PlugMan.doCommand(PlugMan.java:139)
            at com.bekvon.bukkit.plugman.PlugMan.onCommand(PlugMan.java:65)
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:312)
            at net.minecraft.server.MinecraftServer.b(MinecraftServer.java:480)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:465)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    
     
  27. Offline

    shadydeath999

    seems like a plugin or sumthing cuases that or maybe corrupt jar
     
  28. Offline

    N3X15

    Hey guys, gonna be without Internet most of today.
     
  29. Offline

    TheAswomeBoy123

    Can someone go on team veiwer wit me and help me with big brother
     
  30. Offline

    Tadas159

    Can BigBrother still watch what items people took from a chest? I really need that. If It doesn't watch please make an option for that.
     
  31. Offline

    [Kor]Deer

    2011-07-31 20:15:06 [SEVERE] Could not pass event BLOCK_PLACE to BigBrother
    java.lang.NumberFormatException: For input string: "sh ??"
    at java.lang.NumberFormatException.forInputString(Unknown Source)
    at java.lang.Integer.parseInt(Unknown Source)
    at java.lang.Integer.valueOf(Unknown Source)
    at me.taylorkelly.bigbrother.datablock.DeltaChest$DeltaEntry.<init>(DeltaChest.java:111)
    at me.taylorkelly.bigbrother.datablock.DeltaChest.processDeltaStream(DeltaChest.java:82)
    at me.taylorkelly.bigbrother.datablock.DeltaChest.getChanges(DeltaChest.java:451)
    at me.taylorkelly.bigbrother.datablock.DeltaChest.toString(DeltaChest.java:461)
    at me.taylorkelly.bigbrother.finder.HistoryLog.getInfoOnBlock(HistoryLog.java:57)
    at me.taylorkelly.bigbrother.finder.Sticker.blockInfo(Sticker.java:104)
    at me.taylorkelly.bigbrother.finder.Sticker.stick(Sticker.java:117)
    at me.taylorkelly.bigbrother.BigBrother.stick(BigBrother.java:258)
    at me.taylorkelly.bigbrother.StickListener.onBlockPlace(StickListener.java:35)
    at org.bukkit.plugin.java.JavaPluginLoader$28.execute(JavaPluginLoader.java:434)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:332)
    at org.bukkit.craftbukkit.event.CraftEventFactory.callBlockPlaceEvent(CraftEventFactory.java:90)
    at org.bukkit.craftbukkit.event.CraftEventFactory.callBlockPlaceEvent(CraftEventFactory.java:74)
    at net.minecraft.server.ItemBlock.a(ItemBlock.java:81)
    at net.minecraft.server.ItemStack.placeItem(ItemStack.java:56)
    at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.java:223)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:553)
    at net.minecraft.server.Packet15Place.a(SourceFile:57)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
     
Thread Status:
Not open for further replies.

Share This Page