[SEC/ADMN] CoreProtect v2.0 - Fast Block Logging / Rollbacks / Now With Chest Rollbacks [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Intelli, Mar 9, 2012.

  1. Offline


    is there a beta build that doesn't get this error?? if so, can you provide a link? been looking for a link and cant find anything... thank you very much
  2. Offline


  3. Offline

    Carlos Fuentes

    Hey guys, bit of an issue here.

    On my Minecraft server, a strange bug has come up: my HDD has 256gb, with 230gb of that being free. As the server runs, over the course of a few hours, all 256gb become fully occupied. As soon as I restart the computer, the memory is once again freed up.
    This didn't happen prior to me installing CoreProtect, so I'm wondering if that could be causing this problem.
    I'm running a machine with Ubuntu. Any help is appreciated!
  4. Offline


    Intelli You should add a way to change where block data is stored, for those who don't use MySql. I'm trying to get block data to save on a thumb drive. If you like the idea I'd love it added! Keep up the great work! CP is great
  5. Offline


    How do you get that Font in the video, please reply ASAP:D
  6. Offline


    I use a plugin called WaterProof which I use to allow more blocks to "melt" under lava. When I say melt, I mean it in that when lava spreads, it will burn blocks like tall grass in the process. In this case, I've allowed blocks like dirt and sand to melt in the same fashion. I have also allowed more blocks like sugar cane to be breakable via flowing water.

    However, I am having an issue with the block logging concerning fluids (both lava and water). When I tried inspecting damage done to vines and tall grass by both fluids, it appears to log the damage fine. But when CoreProtect attempts to log blocks that don't normally break under lava/water, but do break with the WaterProof, it appears to have problems. I have tested this with sugar cane and dirt, but not with any other block like sand and such.

    When a fluid block flows into a block and breaks it, the breaking of that block is never logged. For example, if I placed dirt in this one spot, and then dumped lava on it, the lava would then burn the dirt block. When I inspect it, it will give back something like this:

    [CoreProtect] Block ID: #3 (Dirt)
    [CoreProtect] Placed by: SomePlayer
    [CoreProtect] When: 0.2 hour(s) ago

    It really should be this:

    [CoreProtect] Block ID: #10 (Lava)
    [CoreProtect] Placed by: SomePlayer
    [CoreProtect] When: 0.1 hour(s) ago

    Because the lava burned the dirt and flowed into it. But instead, it never tracked the fact that lava flowed into it. It also never tracked the fact that there is one less dirt block in that spot. From the report I get from inspection and /co l, it still thinks there's a dirt block there and there isn't any lava or damage done in that one spot.

    When inspecting blocks where lava/water has spread, but did not remove any blocks, it inspected just fine, and showed up who placed the source of the fluid. It also inspected just fine when either fluid removed a block like tall grass, which is a part of vanilla. But in the spots where blocks like dirt were removed (whether it was by lava or water), the water/lava flow simply doesn't show up.

    This effectively means that naturally generated terrain is sensitive to lava on my server, since lava burns dirt and grass. This also means that damage done by lava (or in rarer cases, water) is impossible to rollback.

    If my whole description up there was unnecessary or too confusing, here's a summary of my issue:
    - Not all types of blocks broken by fluids are logged. Only some types are, like tall grass.
    And here's what I'm basically asking for, if possible:
    - Please log all and any blocks broken by fluids, regardless of block ID.

    I don't know if this whole issue is known, or if I'm doing anything wrong on my side. Anyhow, I really like your plugin, and would like to know if you can do anything about it. If you can't, I'll just remove WaterProof and make dirt unrealistically resistant to lava again. Thank you for your time and patience.
  7. Offline


    CoreProtect v1.72 is now available! (Requires Craftbukkit #2513 or higher)

    • Recompiled to fix byecode incompatibility due to changes made to EntityChangeBlockEvent
    • Updated imports for item frame and painting logging.
    • Fixed order of blocks being rolled back (was reversed). Will fix torches that fell off blocks (etc) being rolled back properly.
    • Added support for properly rolling back skull types.
  8. Offline


    CoreProtect v1.73 is now available for Craftbukkit 1.4.6!

    • Fixed block type errors preventing a rollback from completing properly.
    • Fixed invalid or corrupted timestamp data from breaking rollbacks.
    • Added fix for WorldEdit logging occasionally causing Synchronized CHUNK_LOAD errors.
    • Added check to prevent CoreProtect from loading if not using a compatible Craftbukkit version.
    • Updated to support Craftbukkit 1.4.6. Craftbukkit #2545 or higher is required.
  9. Offline


    It logs the blocks just fine but it does not actually roll anything back for me. Whenever I type the command for rollback (I am only doing like a radius of 5 so I use /co rollback t:5m r:5) it simply puts
    [CoreProtect] Rollback started on "#global".
    [CoreProtect] Found 9 file(s) to scan.
    [CoreProtect] Scanned 1/9 file(s)
    [CoreProtect] Scanned 2/9 file(s)
    [CoreProtect] Scanned 3/9 file(s)
    [CoreProtect] Scanned 4/9 file(s)
    then it literally does nothing. Does not make it past 4/9. what am I doing wrong?

    Also I am on craftbukkit-1.4.4-R0.1.jar
  10. Offline


    What version of Craftbukkit are you using? What version of CoreProtect are you using? What error message is shown in the console?
  11. Offline


    I am on craftbukkit-1.4.4-R0.1.jar using version 1.7.2 of CoreProtect and you'll have to give me a moment to grab the console error.
  12. Offline


    CoreProtect v1.72 requires Craftbukkit #2513 or higher
    You should be using v1.71
  13. Offline


    Here is the console:
    21.12 13:05:50 [Server] SEVERE ... 3 more
    21.12 13:05:50 [Server] SEVERE at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
    21.12 13:05:50 [Server] SEVERE at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
    21.12 13:05:50 [Server] SEVERE at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:29)
    21.12 13:05:50 [Server] SEVERE at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:34)
    21.12 13:05:50 [Server] SEVERE Caused by: java.lang.ClassNotFoundException: net.minecraft.server.v1_4_5.World
    21.12 13:05:50 [Server] SEVERE at java.lang.Thread.run(Thread.java:722)
    21.12 13:05:50 [Server] SEVERE at net.coreprotect.CoreProtect$2BasicThread2.run(CoreProtect.java:625)
    21.12 13:05:50 [Server] SEVERE at net.coreprotect.Functions.dataProcessor(Functions.java:2626)
    21.12 13:05:50 [Server] SEVERE java.lang.NoClassDefFoundError: net/minecraft/server/v1_4_5/World
    21.12 13:05:50 [Server] SEVERE Exception in thread "Thread-964" 
    21.12 13:05:49 [Server] INFO list
    I did not see a link to that.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 24, 2016
  14. Offline


    MythicCynic likes this.
  15. Offline


  16. Offline


    Hey guys this is what i keep getting im hoping you guys can debug it im guessing its just 1.4.6 doing it i dont know how to fix it ^^ thanks for all your help!

    21:21:43 [SEVERE] Could not pass event EntityChangeBlockEvent to CoreProtect v1.
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.ja
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.j
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    at org.bukkit.craftbukkit.v1_4_6.event.CraftEventFactory.callEntityChang
    at org.bukkit.craftbukkit.v1_4_6.event.CraftEventFactory.callEntityChang
    at net.minecraft.server.v1_4_6.PathfinderGoalEatTile.e(PathfinderGoalEat
    at net.minecraft.server.v1_4_6.PathfinderGoalSelector.a(PathfinderGoalSe
    at net.minecraft.server.v1_4_6.EntityLiving.bl(EntityLiving.java:1457)
    at net.minecraft.server.v1_4_6.EntitySheep.bl(EntitySheep.java:44)
    at net.minecraft.server.v1_4_6.EntityLiving.c(EntityLiving.java:1254)
    at net.minecraft.server.v1_4_6.EntityAgeable.c(EntityAgeable.java:64)
    at net.minecraft.server.v1_4_6.EntityAnimal.c(SourceFile:33)
    at net.minecraft.server.v1_4_6.EntitySheep.c(EntitySheep.java:52)
    at net.minecraft.server.v1_4_6.EntityLiving.j_(EntityLiving.java:523)
    at net.minecraft.server.v1_4_6.World.entityJoinedWorld(World.java:1334)
    at net.minecraft.server.v1_4_6.WorldServer.entityJoinedWorld(WorldServer
    at net.minecraft.server.v1_4_6.World.playerJoinedWorld(World.java:1315)
    at net.minecraft.server.v1_4_6.World.tickEntities(World.java:1193)
    at net.minecraft.server.v1_4_6.WorldServer.tickEntities(WorldServer.java
    at net.minecraft.server.v1_4_6.MinecraftServer.r(MinecraftServer.java:58
    at net.minecraft.server.v1_4_6.DedicatedServer.r(DedicatedServer.java:22
    at net.minecraft.server.v1_4_6.MinecraftServer.q(MinecraftServer.java:49
    at net.minecraft.server.v1_4_6.MinecraftServer.run(MinecraftServer.java:
    at net.minecraft.server.v1_4_6.ThreadServerApplication.run(SourceFile:84
    Caused by: java.lang.NoSuchMethodError: org.bukkit.event.entity.EntityChangeBloc
    at net.coreprotect.EntityListener.onEntityChangeBlock(EntityListener.jav
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.ja
    ... 24 more
  17. Offline


    I am running a server on 1.4.6 and uses CoreProtect v1.73.
    The plugin seems to do its job just fine, but...
    When checking some griefing and stealing I used CoreProtect to check who took some items from a chest. To my surprise it said it was me! I know it wasn´t me but how come CoreProtect say so? I have checked the serverlog and I have not signed in from another IP than my own and nobody else have access to my computer so it must be CoreProtect that is wrong.
    If it had been anyone else I would have trusted CoreProtect and banned the person, now I feel I can´t ban anyone based only on the plugin without anything more. Is this an known issue?
  18. Offline



    How can you even run seriously a server without LWC?

    Well, i need to say i really like Coreprotect, its the best
    HawkEye replacement ever

    What it really need is an auto prune function,
    what delete datas what is older than x days/weeks/month whatever
    what prevents to have lots of gigs old not needed datas.
  19. Offline


    I don't really like LWC, I prefer simplechestlock. That is used on the server but until I am sure Bukkit is stable and all important plugin works the server is open for everyone with a temorary map. New users don't know how to lock chests.

    You are right about the auto prune function, but you have the option to delete older files with a command. Not so hard to do once a week or so, is it?
  20. Offline


    Has been very useful to me, has a lot of power and I don't need to set up a MySQL thingymajig.

    But, does it log when someone jumps on blocks and breaks crops? I just had half my farm ruined...and the only logs that existed were of me placing the blocks.

    I managed to check the radius however and found some people trying to break the fence/adding dirt to jump over the fence. I'm gonna assume it's them so just deleted their player saves...might remove their chests if they do it again and they can enjoy starting from the very beginning.
  21. Offline



    new users dont know how to use it?
    dude wake up, there is an autoprotect function in config.

    and prune by command? no way!
    that can be done automatically, like HawkEye have it

    its hard enough to run a server without that things
  22. Offline


    VoxelSniper Logging please :)
  23. Offline


    OMGAWSH I <3 it :D
  24. Offline


  25. Offline


    I've always tried to use Logblock over and over, and I can't I don't know what MySQL is. This is awesome, its like logblock but better. I love this! I've only had it for 3 days. I love it so much. Can you make it were right click or left will show who mined/placed the block and right/left click doors tell who placed it and who opened it last. I've been having problems were people are stealing stuff from things. Its easy for dispenser, but when someone opens my doors, I don't know who did it
  26. Offline


    Hey guys, I just downloaded CoreProtect and I'm wondering how to rollback everything done on the server during the past <n> seconds. Thanks for your help!
  27. Offline


    if i use the new coreprotect i cet if i start my server
    [Server] INFO Read timed out
    [Server] INFO Read timed out
    [Server] INFO [CoreProtect] Enabling CoreProtect v1.74

    it stays by coreprotect (sorry for the bat english)
  28. Offline


    What version of Craftbukkit are you using?
  29. Offline


    beta 1.4.6 r3
  30. Offline


    Wanting to convert my logs from flat-file to MySQL.

    Would the logs be larger or smaller in MySQL and how would you convert it all over?


Share This Page