Scaffolding

Discussion in 'Plugin Requests' started by madtomic, Aug 12, 2019.

  1. Offline

    madtomic

    Plugin category: Mechnical

    Minecraft version: 1.12.2

    Suggested name:
    Scaffolding

    What I want: I would like a plugin that would add the block Scaffolding in newer version of Minecraft for Minecraft 1.12.2

    As for block texture, it would be nice to be able to use custom texture for this as well.

    Reference:
    https://minecraft.gamepedia.com/Scaffolding

    Requirements:
    -replicate the scaffolding block

    config.yml
    -include the crafting recipe to make this item.
    -any configurable options for the item Scaffolding

    Commands/Permissions:
    give command to get this block
    permission to use the command

    Thank you for reading.
     
  2. Offline

    CraftCreeper6

    @madtomic
    In order to get a custom texture you'll need to reskin an existing block.

    What block would you like that to be? (This is not me taking the request.)
     
  3. Offline

    madtomic

    Skin is the easy part. The mechanic is hard part. I would assume one can simply take from the server code?
     
  4. Offline

    CraftCreeper6

    @madtomic
    Yes but if you're on a server that doesn't have the scaffolding block on it, then you can't just add a new block.

    You have to reskin an existing block, such as cyan terracotta to look like scaffolding and have the same behaviour.
     
  5. Offline

    Need_Not

    Yeah ^ plug-ins are not more all a plug-in does it take a vanilla mechanic and make it easier like how bed wars is 100% possible with commands and command blocks but it's just so hard it's better to let plug-ins do the job
     
  6. Offline

    Machine Maker

    What is wrong with updating to the newer version of minecraft?
     
  7. Offline

    madtomic

    @Machine Maker

    Custom plugins that isn’t 1.14 ready and years of development that had been put into this survival server. If I update again then I won’t be able to launch this survival server.

    I would need someone to update all the core plugins before I consider to update to 1.14
     

Share This Page