Inactive [RPG] The MineQuest v0.61 - RPG System with Customizable Quests, Classes, and NPCs [1000]

Discussion in 'Inactive/Unsupported Plugins' started by jmonk, Mar 15, 2011.

  1. Offline


    MineQuest - RPG System with Customizable Quests and Classes
    Version: 0.62-test
    MineQuest started out as a plugin to add some RPG-like progression to Minecraft. It had 8 (By default, now completely customizable) character classes (4 Combat, 4 Resource - also by default) and you gained experience by doing tasks related to the class (e.g. Warriors fight with a Sword, or WarMages cast WarMage Spells). All combat classes gained health when they went up in levels, and all classes gained related abilities at certain levels.

    An example of a custom class configuration is now available:

    Now MineQuest has grown to be a much bigger project than gaining abilities and extra health. It includes mobs that get harder over time based on a level adjustment (determined by active players in the server). It has built in economy(iConomy Supported)/town systems that are available if people so desire. Most likely the coolest thing so far is the quest system.

    Good Places to start in game are /minequest, /cubonomy (economy), and /quest (questing specific). Also poking around the help pages (Linked as more information below) gives some details about more advanced commands as well.

    MineQuest is equipped with a system that is being developed so that minecraft can have real instanced dungeons where a select party can teleport into a world that has traps, harder monsters, and special loot. When complete players are brought back to their original locations.

    These quests are completely customizable as they only load from a text file. MineQuest will search the bukkit directory for the appropriate .quest file when the quest is started. This means that anyone running a server could write a quest. Not just plugin developers!

    The spell system is nothing special, and I'm sure that others exist out there, but what really makes MineQuest unique is the complete package, dungeons and everything.

    MySQL or SQLite

    Suspected Conflicts:
    Towny, Essentials Spawn, World Guard, mcMMO,
    Other plugins that modify damage/health

    This is a video of the first real dungeon created, the first time through

    MineQuest 0.40 Trailer -


    Whats new in 0.60?


    Please read the following FAQ before posting your question. It will help you out by getting the answer faster and help us out by having a smaller volume of questions.
    There are some forums on the MineQuest site found below.
    If you cannot solve your issues in the MQ Forums and from the FAQ and the bug does not already exist please post it on the bug tracker.

    More Info:
    Information about MineQuest and its features

    Version 0.61:
    *NPC Fix Item Properties (Blacksmith Capabilities)
    *Fixed Ranged Ability Bindings
    *Other NPC Property changes
    *Bug Fixes
    Version 0.60:
    *Idle Quest System
    *Main World Scripting
    *Reputation System
    Version 0.53:
    *Fixed Instancing System
    *Fixed NPC Respawning Issue
    *Updated to b860
    *Fixed money naming
    *A couple hidden features

    Full Changelog:

    If you love MineQuest then help keep the project alive:
  2. Offline


    testing it atm.
  3. Offline


    Thanks, let me know of any problems. Hasn't been run on any servers besides mine so far.
  4. Offline


    been waiting for some sort of quest plugin, going to test it now :D
  5. Offline


    I forgot to mention the abilities.jar file. When trying to install this, make sure you download that as well otherwise you won't have any abilities, put it in the craftbukkit dir not plugins. I edited the post to reflect this.
  6. Offline


    I dont know how people activate these abilities but if you could bind them to golden tools that would be cool. As an example, you say a command like "/bind fireball sword" and this makes right-clicking with your sword cast the fireball spell, but damage the sword itself
  7. Offline


    Right now you can bind spells to any item id. You just pull out the item and use /bind Fireball. Then after that using the item will cast the spell.

    I also have something I call rebinders implemented. Where if you wanted two spells bound to your bow you can do something similar. You can have a rebinder on say cobblestone that binds Fireball to your bow, and then you can have a rebinder on dirt that will bind IceSphere to your bow. This allows you to quickly switch between spells in battle. They are set up like the following, if your are holding cobblestone and 263 is the item id for a bow (not quite sure on that), but in game /item_id tells you any item id, so you can find out for a rebinder quickly.
    /rebinder Fireball 263
  8. Offline


  9. Offline


    That. Looks awesome.
    Following the development of this one very closely! Nice job!
  10. Offline


    I'm not sure what exactly what you mean by rewards system. I currently have a bit of an economy system built in so its not my first priority to be adding another. I plan on adding support for giving monetary rewards as a part of quests, is that what your looking for?

    That being said, I would like to add some more integration with other plugins at some point, but first on my list is adding some more content like more Abilities and more types of QuestEvents and maybe a video on how to get started writing Quests.
  11. Offline


    There are some things I didn't get (I haven't tested it yet) :
    - Are the abilities unique? I mean, can a a guy be a warrior and an archer at the same time or not? I would love to see players thinking before choosing what class they're gonna play.
    - Isn't there a "classic" quest system? I mean, like, you go and kill 5 skeletons, you get money, boring typical quests. If I understood well, the whole Quest system is just an instance system, is it not?
  12. Offline


    Yes i was speaking in the sense that they could obtain currency from their local currency plugin ( be that BOSEcon or iConomy or whatever else you wish to support )
  13. Offline


    Players are not currently restricted to any single class. They start at level 0 in every class and gain experience in each class by doing activities related to their class (Warrior fighting with a sword, Miner mining cobblestone with a Pickaxe, etc.). This means you could be a high level in any number of classes. I would like to add a Prestige Class system at some point, where with the right combination of class levels you could select one per character.

    In regards to the quest system: Nothing requires it be an instance, I just feel the instance system is essential to having good dungeons. Currently I do have everything setup for people to do quests in their current world, the quest file would just have to be written such that it starts with the line World:world.

    I mentioned in a previous post that I really want to focus on adding more stuff right now, mainly abilities and quest events. All of my quest events currently are absolute positioning based on the world, I would also like to have relative positioning for a number of events so things can target specific questers (used mostly in normal world quests). Having some sort of quest event that requires just killing an enemy or an enemy of a specific type would probably be a good addition. I'll add it to the list of quest events I want to add.
  14. Offline


    Thanks for the answer.
    In regards to the 'one-class-per-user' thing, could you make it possible in a future version?

    Anyway, this is definitely on my Plugins list now! Excellent work.
  15. Offline


    Yeah, I'd be more than happy to make it an option in the properties file or something like that, I will try to get it into my next release. It should be only a change when creating a new character, after that only having one class shouldn't affect anything. I assume you would want them to still have all resource class so they can mine anything, just restrict to a specific combat class?
  16. Offline


    This is exactly what I meant :)
    That would be great.
  17. i have 2 different sql connectors and 3 different sqlite connectors, your plugin doesn't work with any of them, can you please upload your version of the sql connector you used when writing this.
    CB version 531
    minequest 2.0

    this crashes on load, i am also not getting a config file, which is probably relates to not starting.

    Code (Text):
    1. 2011-03-16 19:38:09 [INFO] You appear to be missing MySQL JDBC
    2. 2011-03-16 19:38:09 [SEVERE] java.lang.ClassNotFoundException: com.mysql.jdbc.Driver
    3. 2011-03-16 19:38:09 [SEVERE]     at$
    4. 2011-03-16 19:38:09 [SEVERE]     at Method)
    5. 2011-03-16 19:38:09 [SEVERE]     at
    6. 2011-03-16 19:38:09 [SEVERE]     at
    7. 2011-03-16 19:38:09 [SEVERE]     at java.lang.ClassLoader.loadClass(
    8. 2011-03-16 19:38:09 [SEVERE]     at java.lang.ClassLoader.loadClass(
    9. 2011-03-16 19:38:09 [SEVERE]     at java.lang.ClassLoader.loadClassInternal(
    10. 2011-03-16 19:38:09 [SEVERE]     at java.lang.Class.forName0(Native Method)
    11. 2011-03-16 19:38:09 [SEVERE]     at java.lang.Class.forName(
    12. 2011-03-16 19:38:09 [SEVERE]     at org.monk.MineQuest.MysqlInterface.<init>(
    13. 2011-03-16 19:38:09 [SEVERE]     at org.monk.MineQuest.MineQuest.onEnable(
    14. 2011-03-16 19:38:09 [SEVERE]     at
    15. 2011-03-16 19:38:09 [SEVERE]     at
    16. 2011-03-16 19:38:09 [SEVERE]     at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    17. 2011-03-16 19:38:09 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    18. 2011-03-16 19:38:09 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    19. 2011-03-16 19:38:09 [SEVERE]     at net.minecraft.server.MinecraftServer.e(
    20. 2011-03-16 19:38:09 [SEVERE]     at net.minecraft.server.MinecraftServer.a(
    21. 2011-03-16 19:38:09 [SEVERE]     at net.minecraft.server.MinecraftServer.d(
    22. 2011-03-16 19:38:09 [SEVERE]     at
    23. 2011-03-16 19:38:09 [SEVERE]     at
    24. 2011-03-16 19:38:09 [INFO] [MineQuest] (MySQL) CREATE TABLE IF NOT EXISTS questers (name VARCHAR(30), health INT, max_health INT, cubes DOUBLE, exp INT, last_town VARCHAR(30), level INT, enabled INT, selected_chest VARCHAR(33), classes VARCHAR(150))
    25. 2011-03-16 19:38:09 [SEVERE] null loading MineQuest v0.1 (Is it up to date?)
    26. java.lang.NullPointerException
    27.     at org.monk.MineQuest.MysqlInterface.update(
    28.     at org.monk.MineQuest.MineQuest.onEnable(
    29.     at
    30.     at
    31.     at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    32.     at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    33.     at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    34.     at net.minecraft.server.MinecraftServer.e(
    35.     at net.minecraft.server.MinecraftServer.a(
    36.     at net.minecraft.server.MinecraftServer.d(
    37.     at
    38.     at
  18. Offline


    Hmm... Give this one a try. I don't remember where I got it, but it has been hovering around my devel directories for a while. If that is the problem I would be happy to switch to using a different version of the mysql connector if it would work better for people.

    Attached Files:

  19. even using the one you sent me it is still giving the same error.
    also, what version of CB did you build this against?

    this works on your server, can you upload the sql connectors your server uses?
  20. Offline


    I think I found the problem, from my reading around the forums it appears the my manifest was setup improperly. I believe I have fixed this. If you download a new copy from my download page that I just posted I believe it will fix it. Sorry for the problems so far.

    In regards to bukkit version, up until now I have been running a copy that I compiled my self from the git repository, as sometimes I like to make changes. There is a copy of my own version on my download page, where I modified it so your hearts shake every time you are hit. This is important because as your health goes up your hearts show a percentage of your health and may not change when damaged.

    Long story short I am in the process of testing my plugin with some recommended builds and will try to post an officially supported one sometime soon.
  21. unfortunately i keep getting the same error, is the mysql connector you posted the one from your server?
  22. Offline


    yes, I have it in my bukkit directory on my server as well.

    what build are you running? version of java?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 12, 2016
  23. Offline


    If you use Windows copy your mysql-connector to C:\programms\Java\jre6\lib\ext\
    Than it works fine.
  24. still isn't working.
    too bad too, sounds like an awesome plugin.

    NoFear, i tried that on my windows test machine, still didn't work.
    the real server is debian


    ]0;[email protected]:~[[email protected] ~]# java -version
    java version "1.6.0_17"
    OpenJDK Runtime Environment (IcedTea6 1.7.5) (rhel-1.16.b17.el5-i386)
    OpenJDK Server VM (build 14.0-b16, mixed mode)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 12, 2016
  25. Offline


    I'm running Sun Java. I'll download that build and test with OpenJDK later tonight and report back. Hopefully I can reproduce the problem.

    Ok, just tested it and had no problems. I did my testing on a machine running Ubuntu 10.04 64-bit. Process I went through to test after switching to openjdk (please let me know if I did anything wrong):

    ~/testing_bukkit$ java -version
    java version "1.6.0_20"
    OpenJDK Runtime Environment (IcedTea6 1.9.7) (6b20-1.9.7-0ubuntu1~10.04.1)
    OpenJDK 64-Bit Server VM (build 19.0-b09, mixed mode)

    Downloaded craftbukkit 531 into a blank directory for testing

    Launched craftbukkit - normal first start stuff, restarted no issues.

    downloaded MineQuest - put in plugins directory, it complained about the class not found.

    unzipped mysql-connector that I uploaded in a previous post to craftbukkit directory - now complained about connection to database

    set up properties file with database info - stopped complaining about mysql, spit out lots of stuff about not finding abilities.

    downloaded abilities.jar to craftbukkit directory - everything started up fine.

    Could you try deleting all of the minequest-related and the mysql-related files and see if you can follow these steps?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 12, 2016
  26. Offline


    I get this Error, I tried doing what you said but nothing really changes.
    Do I need to download anything else besides what you gave?
    Code (Text):
    1. 23:44:25 [INFO] [MineQuest] [ERROR] Unable to Connect to MySQL Databse
    2. 23:44:25 [SEVERE] com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Commu
    3. nications link failure
    5. Last packet sent to the server was 0 ms ago.
    6. 23:44:25 [SEVERE]       at sun.reflect.NativeConstructorAccessorImpl.newInstance
    7. 0(Native Method)
    8. 23:44:25 [SEVERE]       at sun.reflect.NativeConstructorAccessorImpl.newInstance
    9. (Unknown Source)
    10. 23:44:25 [SEVERE]       at sun.reflect.DelegatingConstructorAccessorImpl.newInst
    11. ance(Unknown Source)
    12. 23:44:25 [SEVERE]       at java.lang.reflect.Constructor.newInstance(Unknown Sou
    13. rce)
    14. 23:44:25 [SEVERE]       at com.mysql.jdbc.Util.handleNewInstance(
    15. 23:44:25 [SEVERE]       at com.mysql.jdbc.SQLError.createCommunicationsException
    16. (
    17. 23:44:25 [SEVERE]       at com.mysql.jdbc.ConnectionImpl.createNewIO(ConnectionI
    19. 23:44:25 [SEVERE]       at com.mysql.jdbc.ConnectionImpl.<init>(ConnectionImpl.j
    20. ava:718)
    21. 23:44:25 [SEVERE]       at com.mysql.jdbc.JDBC4Connection.<init>(JDBC4Connection
    22. .java:46)
    23. 23:44:25 [SEVERE]       at sun.reflect.NativeConstructorAccessorImpl.newInstance
    24. 0(Native Method)
    25. 23:44:25 [SEVERE]       at sun.reflect.NativeConstructorAccessorImpl.newInstance
    26. (Unknown Source)
    27. 23:44:25 [SEVERE]       at sun.reflect.DelegatingConstructorAccessorImpl.newInst
    28. ance(Unknown Source)
    29. 23:44:25 [SEVERE]       at java.lang.reflect.Constructor.newInstance(Unknown Sou
    30. rce)
    31. 23:44:25 [SEVERE]       at com.mysql.jdbc.Util.handleNewInstance(
    32. 23:44:25 [SEVERE]       at com.mysql.jdbc.ConnectionImpl.getInstance(ConnectionI
    34. 23:44:25 [SEVERE]       at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegist
    36. 23:44:25 [SEVERE]       at java.sql.DriverManager.getConnection(Unknown Source)
    37. 23:44:25 [SEVERE]       at java.sql.DriverManager.getConnection(Unknown Source)
    38. 23:44:25 [SEVERE]       at org.monk.MineQuest.MysqlInterface.reconnect(MysqlInte
    40. 23:44:25 [SEVERE]       at org.monk.MineQuest.MysqlInterface.<init>(MysqlInterfa
    42. 23:44:25 [SEVERE]       at org.monk.MineQuest.MineQuest.onEnable(
    43. 507)
    44. 23:44:25 [SEVERE]       at
    46. 23:44:25 [SEVERE]       at
    48. 23:44:25 [SEVERE]       at org.bukkit.plugin.SimplePluginManager.enablePlugin(Si
    50. 23:44:25 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftSe
    52. 23:44:25 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftS
    54. 23:44:25 [SEVERE]       at net.minecraft.server.MinecraftServer.e(MinecraftServe
    56. 23:44:25 [SEVERE]       at net.minecraft.server.MinecraftServer.a(MinecraftServe
    58. 23:44:25 [SEVERE]       at net.minecraft.server.MinecraftServer.d(MinecraftServe
    60. 23:44:25 [SEVERE]       at
    62. 23:44:25 [SEVERE]       at
    63. ceFile:366)
    64. 23:44:25 [SEVERE] Caused by: Connection refused: conn
    65. ect
    66. 23:44:25 [SEVERE]       at Method)
    68. 23:44:25 [SEVERE]       at Source)
    69. 23:44:25 [SEVERE]       at Sou
    70. rce)
    71. 23:44:25 [SEVERE]       at Source)
    72. 23:44:25 [SEVERE]       at Source)
    73. 23:44:25 [SEVERE]       at Source)
    74. 23:44:25 [SEVERE]       at Source)
    75. 23:44:25 [SEVERE]       at<init>(Unknown Source)
    76. 23:44:25 [SEVERE]       at<init>(Unknown Source)
    77. 23:44:25 [SEVERE]       at com.mysql.jdbc.StandardSocketFactory.connect(Standard
    79. 23:44:25 [SEVERE]       at com.mysql.jdbc.MysqlIO.<init>(
    80. 23:44:25 [SEVERE]       at com.mysql.jdbc.ConnectionImpl.createNewIO(ConnectionI
    82. 23:44:25 [SEVERE]       ... 24 more
    83. 23:44:25 [SEVERE] null loading MineQuest v0.2 (Is it up to date?)
    84. java.lang.NullPointerException
    85.         at org.monk.MineQuest.MysqlInterface.update(
    86.         at org.monk.MineQuest.MineQuest.onEnable(
    87.         at
    88.         at
    89. .java:414)
    90.         at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
    92.         at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    93.         at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    94.         at net.minecraft.server.MinecraftServer.e(
    95.         at net.minecraft.server.MinecraftServer.a(
    96.         at net.minecraft.server.MinecraftServer.d(
    97.         at
    98.         at
  27. i don't understand it then, i can't get past the same "missing mySQL JDBC" error i was getting before

    followed the exact same steps you did on my debian machine.

    if you are willing, i'd like to try one last "experiment"

    rm -rf the world directory from the test folder you made above, scramble your SQL login details in the file
    then tar the entire test folder, i'll download that, untar it as is, put in my sql connect string info and try running it.
  28. Offline


    Here you go. I wish you much luck.
  29. ok, just for giggles i swapped out the b531 snapshot i downloaded from the bukkit repository with your special version.

    it worked.
    the b531 version that i downloaded will not work, but yours will.
    i will try your version on my public server and hopefully it plays nice with the other 27 plugins i am running.
    wow i just don't get this.... i just downloaded the tar above.
    oddly it doesn't work for me.
    but replacing the b531 with yours does.
    no idea, but wth. it seems to be playing nice with others so i'm just gonna run with it.
  30. Offline


    This is from you being unable to connect to the MySQL database. Future versions will catch this exception and inform you properly of the issue. This means you have 1 or 2 things wrong, you need to fill in login parameters to your mysql server and a database for minequest to use (these are set in in your bukkit directory). If you don't have a mysql database then that means you need to install one and then fill in the parameters.

Share This Page