Inactive [RPG] NPC-Quester v2.3.1 - Make NPCs give quests (links uQuest/EpicQuest and Citizens) [1000]

Discussion in 'Inactive/Unsupported Plugins' started by Randy Schouten, Jun 9, 2011.

  1. Offline

    Randy Schouten

    NPC-Quester - Make NPCs give quests!
    Version: 2.3.1

    If you ever wanted a plugin that would make your NPCs give out quests, this is the plugin for you.
    Lots of features to be added, so keep on the lookout!

    • uQuest:
      • NPCs give random quests
      • Specified NPCs give out a specific quest and restricted those quests if wanted
      • If wanted, make players have a specified item in their hand with a specified amount, and if you want it, take it from them too
      • Quest chains!
      • Make NPCs give out the quest only once
    • EpicQuest:
      • Give solo quests
      • Give group quests
    How to install: (read carefully!)

    First off, required plugins:
    uQuest or EpicQuest (quests)
    Citizens (NPCs)
    Permissions (commands, not neccesary but nice to have)

    Now, to give your NPCs quests, use the ingame commands to make your NPCs quests!​
    You can also copy paste one of the examples and type your own settings there if you find that easier too.​

    Use in-game commands to add NPCs or change the config​

    Names are case sensitive!

    When you are done adding your questers, /reload your server to load them.


    For uQuest (not iQuest!): RAR, ZIP
    For EpicQuest: RAR, ZIP

    How to use:
    To get a quest, right click a NPC who is in the config file.

    Commands with uQuest:
    /npcq help [page], shows commands.
    There's too much commands to type here, so just use the help command to see them all.
    Reload command removed for now, it doesn't work
    Permissions with uQuest:
    npcq.edit - Normal quest editing
    npcq.remove - Normal quest removing
    npcq.item - Quest giver item editing and removing
    npcq.chain - Chain quest adding, removing and editing - Shows all commands in-game
    Commands with EpicQuest:
    /npcq help - Shows commands.
    /npcq add solo/group/turnin [npc name] - Add a quester
    /npcq remove [npc name] - Remove a quester
    Permissions with EpicQuest:
    npcq.add - Add questers
    npcq.remove - Remove questers - Show all commands in-game
    • Option to restrict random quest givers to NOT give out specified quests (Planned for next version)
    • Quest chains
    • Get quests only once
    • Right click a NPC twice to get a quest, see q info on first click
    • Automatic quest amount counting (Planned for next version)
    • Need a certain quest level before able to get quests from certain NPCs
    • Command to add random quest givers (Planned for next version)
    • Show quest status instead of "You already have a quest" when you hit a quest giver (Planned for next version)
    • Complete quest on hitting the npc (Planned for next version)
    • Possible quest fees
    • Complete quests only once then disable them for that player
    • Suggestions always welcome!

    • v2.3.1
      • Fixed the remove command for EpicQuest
      • Added another NPC type: "turnin"
      • ^Right click that NPC to turn in quests
    • v2.3
      • Added EpicQuest support! (There's a second download now for that.)
    From here will only be EpicQuest updates, not uQuest
    • v2.2.5
      • Again, fixed to work with newest Citizens (stop changing hooks T_T)
    • v2.2.4
      • Bug fix:
        • Now works with newest Citizens version
    • v2.2.3
      • Bug fix:
        • The add command now adds the newest feature (this bug caused the plugin to read the config in a wrong way. Sorry!)
    • v2.2.2
      • Bug fix:
        • Chain quests now work properly with the new "onlyonce" feature
    • v2.2.1
      • Bug fix:
        • Quests should be given out properly now with the new features
    • v2.2
      • New additions:
        • Automatic quest counting
        • Option to have NPCs give out a quest only once
        • See the quest, then type a command to accept or decline it
      • Changes:
        • Added what item you need to have in your hand if you don't have the correct one
        • Permission nodes or items are merged
      • And some other stuff I can't remember, including changes and bugfixes (nothing major)
    • v2.1
      • New additions:
        • Commands to change quest chains
      • Changes:
        • Changed all commands to be compatible with v2.x.x and higher
        • Changed the help pages a little, /help shows categories with pages now
    • v2.0.4
      • Bug fix
        • Fixed quest chains not giving out properly if "iteminhand active = false" or "iteminhand consume = false"
    • v2.0.3
      • Bug fix:
        • Fixed the issue of "iteminhand active = true" and "iteminhand consume = false" resulting in not giving a quest
    • v2.0.2
      • Bug fix:
        • Fixed quests not giving out of the NPC had a colored name (This was the bug that bothered several users.)
    • v2.0.1
      • Bug fix:
        • Fixed quest progress saving possibly not saving correctly with multiple users
    • v2.0
      • New addition:
        • Chain quests!
        • Plugin remembers where you were in your chain quest, so you don't have to do it over ;)
      • Bug fixes:
        • Random stuff I can't remember
        • This includes NPCs not giving quests
    • v1.3.1b
      • Bug fixes:
        • Fixed some texts on [false/true] commands not displaying correctly
        • Fixed default config not working
        • Fixed a player not being able to turn in a quest if item consume and active are false
        • Fixed sending the player a message with all the configs for all NPCs
      • Changes:
        • Changed overall file handling, it's a lot more error resistant now
    • v1.3.1a
      • Bug fix:
        • Fixed config not read properly
        • Changes:
        • Improved check to see if a branch is empty
    • v1.3.1
      • Bug fixes:
        • Fixed commands not adding questers correctly with new format
        • Fixed random questers not working properly
    • v1.3
      • New additions:
        • Added the ability that you need a specific item in your hand to get a quest
        • Added the ability to consume that specific item
        • Added the ability to consume a certain amount of that item
        • If you right click the NPC you got the quest from and you completed the objectives, the quest is turned in
        • Shows the amount of objectives finished if you didn't complete a quest and hit the NPC you got the quest from
        • Added a check to see if a branch is empty, so there won't be errors if you have one empty
        • Added lots of commands
      • Bug fixes:
        • Fixed the commands from the previous version(s)
        • Fixed /help giving an error, now shows first page
        • Fixed NPCs saying "derp" when asking for a quest
        • Changes:
        • Help pages are now in categories
    • v1.2.1
      • New addition:
        • Compatible with 860
    • v1.2
      • Bug fixes:
        • Commands are now (hopefully) fully fixed
        • Fixed all NPCs giving quests
        • Stopped my plugin from ruining uQuest's quests.yml file (sorry!)
      • Changes:
        • Removed the /npcq reload command, it doesn't work as of now
    • v1.1
      • New additions:
        • Extra commands
        • Ability to have specific quests private or not
      • Bug fixes:
        • Fixed the /remove command
      • Changes:
        • /help now has 2 pages. So instead of "/help", type "/help 1" or "/help 2"
    • v1.0
      • Initial release
    Big thanks to the creators of:
    uQuest (
  2. Offline


    The plugin does read the configuration file. I'm not sure how you came to that conclusion.

    In your default yml file you missed a : in one of the examples causing the plugin not to load at all. Once fixed it works fine.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  3. Offline

    Randy Schouten

    Mmmm... I see.
    In any case, I improved file handling, so now they don't have to be in a specific order anymore, as long as they're in the same branch it's fine.

    That said, it is easier for me to program the rest as well.
    Now as far as progression goes, I've completely retested quest giving, and I'm done with the random questers.
    I'm about to thourougly start testing the specific questers.
    Please hold on a little bit longer to get a (hopefully) bug free release of 1.3.1!
  4. Offline


    Glad to see you are quickly fixing it. :)
  5. Offline

    Randy Schouten

    I'm doing my best to get my fixes out as fast as I can! :p
  6. Offline


    The problem I had with the items not removing from inventory until placed was with redstone. It doesnt seem to do it with anything else.
  7. Offline

    Randy Schouten

    Version 1.3.1b is live!

    A whole lot of the bugs should be fixed!
  8. Offline


    Great work man :) I'm very glad you're actively fixing the bugs :)
  9. Offline

    Randy Schouten

    Everything works fine then?

    I always want the best for my plugin users :)
  10. Offline


    Im still getting an internal server error whenever I try to run the /npcq help Command the code is:

    16:28:17 [WARNING] Unexpected exception while parsing console command
    org.bukkit.command.CommandException: Unhandled exception executing command 'n
    ' in plugin NPCQuester v1.3.1b
    at org.bukkit.command.PluginCommand.execute(
    at org.bukkit.command.SimpleCommandMap.dispatch(
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.jav
    at net.minecraft.server.MinecraftServer.b(
    at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.ClassCastException: org.bukkit.craftbukkit.command.Colou
    ConsoleSender cannot be cast to org.bukkit.entity.Player
    at randy.npcq.npcq.onCommand(
    at org.bukkit.command.PluginCommand.execute(
    ... 6 more
    Please help :)
  11. Offline


    Well, TBH I haven't even installed this plugin yet, just watching it's progress. I'm being a lazy admin and don't feel like setting up any NPC's at the moment, and I also need to fix alot of quests in uQuest anyways haha :p Just wanted to let you know that I appreciate you making this plugin, and I will be using it very soon.
  12. Offline

    Randy Schouten

    You are trying to do the command thru the console, correct?
    If so, that doesn't work. You must do it in-game.

    Ah, thank you!

    There's lots of features to be added, so don't worry on it stopping it's progress.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  13. Offline


    downloading the new version I'll test it and get back to you.

    The issue with the items not dissappearing from inventory right is still there.

    example: collect 10 cobblestone
    cobblestone is still showing in inventory until clicked or moved or placed.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  14. Offline


    No that comes up when I do it in game.
  15. Offline


    The help command works for me. What craftbukkit version are you using?
  16. Offline


    Im using Build 860 or whatever the newest one is
  17. Offline


    Okay well I clean installed the new version. Did you keep your old config or clean install?
  18. Offline

    Randy Schouten

    When exactly does this happen?
    If you have set "consume" to true, it should take the items specified when you take a quest instantly.
  19. Offline


    Everything is fresh except the world .
  20. Offline


    its taking the items on consume that's not the issue.

    The issue is on quest complete it takes the items but leaves them in the inventory. They are like ghost items...I guess.
    When you place the item they all go away.

    So if I had a quest to collect 10 cobblestone.
    I complete the quest using the npc but the cobblestone still SHOWS in the inventory slot.
    Once I try to place the cobblestone which is still SHOWING it disappears.

    The only time I've seen this happen is when a plugin is conflicting with essentials. What other plugins do you have installed?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  21. Offline

    Randy Schouten

    Ah like that.
    Do you remember if uquest should take the items or not?
    I'm typing this from my iPod so I can't test it..
  22. Offline


    uquest takes the items upon completion if I complete them with /q done

    Also this only seems to happen with specific not random..

    It just happened with coal on random.
  23. Offline


    I'm still getting no effect from right click :( Using bukkit 860, your 1.3.1b, citizens 1.0.8h... uquest seems to be functioning normally. I even tried setting the owner as someone else so it wouldn't select on right click >.< Could it be incompatibility with worldguard or mcmmo blocking the right click?
  24. Offline

    Randy Schouten

    It might be MCMMO.
    I think they use the same function to activate their abilities.

    I'll set my plugins priority to high and send that to you. See if you can still do everything.

    Update on progress.
    Just wrote down first version of chain quests.
    I'm going to start debugging now, but I can't guarantee I'll have an update out by today, as I have to go to work this evening.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  25. Offline


    Hello !!

    I have a problem :/ ... I'm BAD in english so i use a translator.
    When i tape : /npcq add NAME 1 true ... That marks : NAME has quest 3. Only this NPC: true.
    But i can't see my NPC ... What do I have to make ?

    Thanks You Very Much ! &' Again Sorry for my bad english :/ !
  26. Offline

    Randy Schouten

    Well first you have to create the NPC with the plugin called "Citizens".
    You can find a link on the first post at the bottom.
    You will also need the plugin called uQuest and create the quests from that plugin.
  27. Offline



    i've the same prob that Int0x. I'm french, and i don't speak english very very well. :s
    So, i create a NPC with Citizens (/npc create test) , and i do "/npcq add test 1 false".
    But when i right click on him, nothing happens.
    I'm sorry if this prob has been already said, but i don't understand all that you wrote. :)

    Thanks for your help.
  28. Offline

    Randy Schouten

    Damn, I'm already working on the chain quest update...

    I did fix the previous problems tho.
    I'll have it done as quick as I can.

    Also something I will keep in mind, is to back up my previous version before going on.

    Seeing how far I am at this moment, the update should arrive in tomorrow of the day after tomorrow.
    For those really intrested:
    • Done:
      • Config reading, including progress in quest chain
      • Adding in all the new properties in the quest files
    • Todo:
      • Give the correct quest from the quest chain
      • Continue the quest chain if the server restarted
  29. Offline


    Sorry, but I don't quite understand how to use this. Do I make an npc (names Quest for example) with citizens then type /npcq add Quest random? I tried that and the 'Quest' npc does nothing...
  30. Offline


    Confirmed. mcMMO is blocking the right click interaction with the NPC. I'll be happy to let you know if setting your priority higher causes mcMMO to stop functioning, or if it makes them work in harmony. :]
  31. Offline


    That's why it isn't working for me... Hope it gets fixed :)

Share This Page