Inactive [RPG] NPC-Quester v2.3.1 - Make NPCs give quests (links uQuest/EpicQuest and Citizens) [1000]

Discussion in 'Inactive/Unsupported Plugins' started by Randy Schouten, Jun 9, 2011.

  1. Offline

    Randy Schouten

    NPC-Quester - Make NPCs give quests!
    Version: 2.3.1

    If you ever wanted a plugin that would make your NPCs give out quests, this is the plugin for you.
    Lots of features to be added, so keep on the lookout!

    • uQuest:
      • NPCs give random quests
      • Specified NPCs give out a specific quest and restricted those quests if wanted
      • If wanted, make players have a specified item in their hand with a specified amount, and if you want it, take it from them too
      • Quest chains!
      • Make NPCs give out the quest only once
    • EpicQuest:
      • Give solo quests
      • Give group quests
    How to install: (read carefully!)

    First off, required plugins:
    uQuest or EpicQuest (quests)
    Citizens (NPCs)
    Permissions (commands, not neccesary but nice to have)

    Now, to give your NPCs quests, use the ingame commands to make your NPCs quests!​
    You can also copy paste one of the examples and type your own settings there if you find that easier too.​

    Use in-game commands to add NPCs or change the config​

    Names are case sensitive!

    When you are done adding your questers, /reload your server to load them.


    For uQuest (not iQuest!): RAR, ZIP
    For EpicQuest: RAR, ZIP

    How to use:
    To get a quest, right click a NPC who is in the config file.

    Commands with uQuest:
    /npcq help [page], shows commands.
    There's too much commands to type here, so just use the help command to see them all.
    Reload command removed for now, it doesn't work
    Permissions with uQuest:
    npcq.edit - Normal quest editing
    npcq.remove - Normal quest removing
    npcq.item - Quest giver item editing and removing
    npcq.chain - Chain quest adding, removing and editing - Shows all commands in-game
    Commands with EpicQuest:
    /npcq help - Shows commands.
    /npcq add solo/group/turnin [npc name] - Add a quester
    /npcq remove [npc name] - Remove a quester
    Permissions with EpicQuest:
    npcq.add - Add questers
    npcq.remove - Remove questers - Show all commands in-game
    • Option to restrict random quest givers to NOT give out specified quests (Planned for next version)
    • Quest chains
    • Get quests only once
    • Right click a NPC twice to get a quest, see q info on first click
    • Automatic quest amount counting (Planned for next version)
    • Need a certain quest level before able to get quests from certain NPCs
    • Command to add random quest givers (Planned for next version)
    • Show quest status instead of "You already have a quest" when you hit a quest giver (Planned for next version)
    • Complete quest on hitting the npc (Planned for next version)
    • Possible quest fees
    • Complete quests only once then disable them for that player
    • Suggestions always welcome!

    • v2.3.1
      • Fixed the remove command for EpicQuest
      • Added another NPC type: "turnin"
      • ^Right click that NPC to turn in quests
    • v2.3
      • Added EpicQuest support! (There's a second download now for that.)
    From here will only be EpicQuest updates, not uQuest
    • v2.2.5
      • Again, fixed to work with newest Citizens (stop changing hooks T_T)
    • v2.2.4
      • Bug fix:
        • Now works with newest Citizens version
    • v2.2.3
      • Bug fix:
        • The add command now adds the newest feature (this bug caused the plugin to read the config in a wrong way. Sorry!)
    • v2.2.2
      • Bug fix:
        • Chain quests now work properly with the new "onlyonce" feature
    • v2.2.1
      • Bug fix:
        • Quests should be given out properly now with the new features
    • v2.2
      • New additions:
        • Automatic quest counting
        • Option to have NPCs give out a quest only once
        • See the quest, then type a command to accept or decline it
      • Changes:
        • Added what item you need to have in your hand if you don't have the correct one
        • Permission nodes or items are merged
      • And some other stuff I can't remember, including changes and bugfixes (nothing major)
    • v2.1
      • New additions:
        • Commands to change quest chains
      • Changes:
        • Changed all commands to be compatible with v2.x.x and higher
        • Changed the help pages a little, /help shows categories with pages now
    • v2.0.4
      • Bug fix
        • Fixed quest chains not giving out properly if "iteminhand active = false" or "iteminhand consume = false"
    • v2.0.3
      • Bug fix:
        • Fixed the issue of "iteminhand active = true" and "iteminhand consume = false" resulting in not giving a quest
    • v2.0.2
      • Bug fix:
        • Fixed quests not giving out of the NPC had a colored name (This was the bug that bothered several users.)
    • v2.0.1
      • Bug fix:
        • Fixed quest progress saving possibly not saving correctly with multiple users
    • v2.0
      • New addition:
        • Chain quests!
        • Plugin remembers where you were in your chain quest, so you don't have to do it over ;)
      • Bug fixes:
        • Random stuff I can't remember
        • This includes NPCs not giving quests
    • v1.3.1b
      • Bug fixes:
        • Fixed some texts on [false/true] commands not displaying correctly
        • Fixed default config not working
        • Fixed a player not being able to turn in a quest if item consume and active are false
        • Fixed sending the player a message with all the configs for all NPCs
      • Changes:
        • Changed overall file handling, it's a lot more error resistant now
    • v1.3.1a
      • Bug fix:
        • Fixed config not read properly
        • Changes:
        • Improved check to see if a branch is empty
    • v1.3.1
      • Bug fixes:
        • Fixed commands not adding questers correctly with new format
        • Fixed random questers not working properly
    • v1.3
      • New additions:
        • Added the ability that you need a specific item in your hand to get a quest
        • Added the ability to consume that specific item
        • Added the ability to consume a certain amount of that item
        • If you right click the NPC you got the quest from and you completed the objectives, the quest is turned in
        • Shows the amount of objectives finished if you didn't complete a quest and hit the NPC you got the quest from
        • Added a check to see if a branch is empty, so there won't be errors if you have one empty
        • Added lots of commands
      • Bug fixes:
        • Fixed the commands from the previous version(s)
        • Fixed /help giving an error, now shows first page
        • Fixed NPCs saying "derp" when asking for a quest
        • Changes:
        • Help pages are now in categories
    • v1.2.1
      • New addition:
        • Compatible with 860
    • v1.2
      • Bug fixes:
        • Commands are now (hopefully) fully fixed
        • Fixed all NPCs giving quests
        • Stopped my plugin from ruining uQuest's quests.yml file (sorry!)
      • Changes:
        • Removed the /npcq reload command, it doesn't work as of now
    • v1.1
      • New additions:
        • Extra commands
        • Ability to have specific quests private or not
      • Bug fixes:
        • Fixed the /remove command
      • Changes:
        • /help now has 2 pages. So instead of "/help", type "/help 1" or "/help 2"
    • v1.0
      • Initial release
    Big thanks to the creators of:
    uQuest (
  2. Offline


    I suggest adding repeatable quests (haven't used the plugin yet, they may already exist)! Also, are you a native English speaker?
  3. Offline

    Randy Schouten

    Yes it requires Permissions.
    So that was the problem all along :p

    If you insist on not adding Permissions, I can add a check if someone is OP instead of having the permission.

    You can repeat all quests all the time at this moment.
    I'm not a native English speaker, I'm from the Netherlands. Does it look like I'm a native English speaker? xD

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  4. Offline


    Oh, well then you should add one-time quests! XD

    Actually, your English is really good- I only questioned your native speaking-ness when I saw this; it's a little awkward:
    It should be:
    I've never really thought about the rule for much vs. many, but it seems that "many" should be used when you can count what you're talking about and "much" should be used when it's uncountable (e.g., "too much sugar," "too much homework," etc.).
  5. Offline

    Randy Schouten

    Update v1.3.1
    Fixed a few bugs :)

    Check the config again, the arrangement of the branches has changed.
    They won't work if they are not in that order!!
  6. Offline


    I have both yours and uQuest reinstalled with vanilla settings, and now I'm not getting an error--but right clicking the npc I assigned a quest does nothing. I set the quest amount to 53 as there is in vanilla settings... and I think my branches are all correct.

    amount: 1
    item: 1
    active: false
    consume: false
    thisNPConly: 'true'
    quest: 1

    Again... no errors but no effect. Did I overlook something? :S Everything seems to load correctly on serverboot.
  7. Offline


    Ah shit, I'm an idiot lol. Thanks, I didn't even think about that! :)
  8. Offline

    Randy Schouten

    Damn it, I can't get it to work now either...
    I will improve the file handling now.
  9. cool good work will update and test when I get home

    Many thanks
  10. Offline

    Randy Schouten

    Update v1.3.1a
    You should be able to get quests now.
  11. Offline


    Hello there,

    tried to set up your plugin but had some problems with it:

    First (on help page 2) :
    /npcq item id [npc name] [id]

    gives me the result:
    /[id] uses item [npc name] to accept a quest.

    so i guess this should be:
    /npcq item id [id] [npc name]

    Next thing (on help page 2):
    /npcq item active [npc name] [true/false]

    gives me the result:
    /[true/false] now needs an item to give a quest.

    Same as (on help page 2):
    /npcq item consume [npc name] [true/false]

    gives me the result:
    /[true/false] now consumes the item specified.

    Next thing I found (on help page 2) :
    /npcq item amount [npc name] [number]

    gives me the result:
    /[number] needs [number] items to give a quest.

    Haven't tried to set up one quest npc without the use of an item! Would be great if you could check this plz
    Thanks for the plugin, have fun & enjoy ur day :)
  12. Offline


    Can u add older versions ?
    I use 818 and it wont work :(
  13. Offline

    Randy Schouten

    Can you give me the full error(s) you get?
  14. Offline


    4 things

    1. This does not work at all unless active is set to true. (in the config) it is not by default

    2. When I complete a quest in which it should take items it takes them but they stay in my inventory slot until I try to place them then they disappear.

    3. When consume is set to false I cannot complete a quest using the npc.

    4. When I right click the npc to get a quest or complete a quest it gives me all info about him. This should be command based and not when you right click.
  15. Offline


  16. Offline

    Randy Schouten

    I think you haven't put an amount in your config file, is that correct?
    It should also say that right before that error if it's true.

    These are the comments I need, thank you.
    I will work on it now.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  17. Offline


    I forgot to mention in my previous post, you forgot a : on one of the lines in the config file. This is what is giving Fuji that error.

    active: true to be specific.
  18. Offline


    I use the german quests from uqest

    and the error still happend :(

  19. Offline


    it should be active: true just add that : in
  20. Offline


  21. Offline

    Randy Schouten

    After observation, I see that part of the code is not working...
    I'm trying so squash that bug at this moment.

    Sorry for bringing out such buggy release, but I'm not SUPER experienced with coding yet, and this is my biggest and most complicated plugin up to now :p

    The new file reader should be alot better tho, you don't have to get the branch arrangement in a certain order anymore.
    moonjokes likes this.
  22. Offline


    remove everything from the config file except amount: # the # being the number of quests in the quest config.

    Also you are using an outdated version of uquest.
  23. Offline


    Ill fixx the problem :D
    But new one :
  24. Offline


    Get uquest 1.5 and make sure you are using the correct syntax in the config file. As far as I know color codes do not work with it if that's what you were going for? #FFFD is in the config for uquest somewhere and it should not be.
  25. Offline


    Where i can download 1.5 ?
  26. Offline


    also make sure to use the latest craftbukkit build 860 recommended using 1.6.6 beta
  27. Offline


    Ill get v 1.5 but :

  28. Offline


    conversation started so as to not spam this thread anymore. please respond to me there and I will help you get this figured out.
  29. Offline

    Randy Schouten

    The problem seems to be that my plugin doesn't read the configuration at all, causing all these errors.
    I have no idea how this happened, but I'll look into it.
  30. Offline


    if i type "/npcq help" i get a error. The error is "An internal error occurred while attempting to perform this command.
    Please help
  31. Offline

    Randy Schouten

    That was with one of the previous versions, but you should wait with updating for a little bit, trying to sort out some bugs atm.

Share This Page