[RPG/MECH] mcMMO v1.2.07 - RPG Addiction Redefined! Multi-Lingual! [1337][1549]

Discussion in 'Inactive/Unsupported Plugins' started by nossr50, Feb 5, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    I'm using CB #443, permissions 2.1 and MCMMO 0.7.11 and the mod seems not to work at all even though it says it's enabled.
    Permissions are set... what could I be doing wrong?
  3. Offline


    @Acren Perhaps you didn't name your permissions file 'world' or whatever your world is named as
  4. Offline


    Getting Debug code 0 when i repair stuff.. using latest mmo :)
  5. Offline


    @Wall Derp, I thought I removed them all. It will be gone in the next version.
  6. Offline


            default: true
                build: false
                - 'general.spawn'
                - 'myhome.home.basic.home'
                - 'myhome.home.basic.set'
                - 'myhome.home.basic.delete'
                - 'myhome.home.soc.*'
                - 'flashlight.normal'
        - 'mcmmo.skills.repair'
        - 'mcmmo.skills.unarmed'
        - 'mcmmo.skills.archery'
        - 'mcmmo.skills.herbalism'
        - 'mcmmo.skills.swords'
        - 'mcmmo.skills.acrobatics'
        - 'mcmmo.skills.axes'
            default: false
                build: true
                - Default
                - 'general.time'
            default: false
                build: true
                - Default
            group: Admin
    That's my permissions whats wrong with it?

    i used four spaces as you recommended im still getting the long string of errors whenever i do anything and start the server and it only happens with mcmmo

    oh and i tried putting the same spaces as the other permissions and still the same problem
  7. Offline


    It looks like your mcMMO skills are indented incorrectly. Look at the skills above it, see how they are indented?
    Also for Permissions support, please just go to the Permissions thread. I'm not a wizard at it.
  8. Offline


    How do i set exp for the skills?
  9. Offline


    Thanks for an Awesome plugin! really enjoying it! I having the same message like MCMaG.jp had. But im Just getting "Debug code 0" when im repairing. Im running bukkit build 441 and mcmmo v0.7.11.
  10. Offline


    she works fine with all the skills enabled strangely enough its only when i select custom skills does it malfunction imma retry adding seperate skills (rpg server i dont want blocks to drop items lol i want you to buy base materials off shops) XD so imma have to see if selecting some but not all skills works after trying again

    yup permissions were off! works GREAT now XD
  11. Offline


    Woot, my issues was with permissions.. Thanks!
  12. Offline


    Glad to hear you have resolved your issues.
  13. Offline

    Aaron Manners

    Hey, I am loving your problem. Slight issue though (and I'm new to bukkit, so this might just be me being an idiot). I can't get this to work with any chat plugin - is there any compatibility with simplecolours, ichat, or anything of such a nature?

    Thanks in advance. Great work on this!
  14. Offline


    Besides this being the best plugin on our server. I was wondering if it were possible to make it compatible with the Stats and Achievements plugins. Thanks.
  15. Offline


    Now, i've got bukkit 450 (i think: git-Bukkit-0.0.0-450-gd3c1ba4-b432jnks (MC: 1.3)), and GroupManager instead of Permission.
    Everything works fine, except that I have the "Debug code 0" message when I repair, but repair works.
  16. Offline


    [SEVERE] Could not pass event ENTITY_DAMAGED to mcMMO
    at com.gmail.nossr50.mcm.archeryCheck(mcm.java:161)
    at com.gmail.nossr50.mcEntityListener.onEntityDamage(mcEntityListener.java:60)
    at org.bukkit.plugin.java.JavaPluginLoader$39.execute(JavaPluginLoader.java:329)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:225)
    at net.minecraft.server.EntityArrow.f_(EntityArrow.java:169)
    at net.minecraft.server.World.a(World.java:1011)
    at net.minecraft.server.WorldServer.a(WorldServer.java:53)
    at net.minecraft.server.World.f(World.java:993)
    at net.minecraft.server.World.d(World.java:970)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:335)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:253)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)

    when shooting cow with bow, please help
    i get no exp

    i also get DEBUG CODE 0 when repairing..

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 8, 2016
  17. Offline


    stats dont work for me anymore, and debug code at repairing too.

    stats work now, just had to restart, still debug on repair though

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 8, 2016
  18. Offline



    Here is a little txt file that explains the settings file for MCMMO

    Attached Files:

  19. Offline


    Ok so... I got the bukkit build #441 and replaced my old craftbukkit. Then I get the new update of your plugin, replace the old one in the plugins folder, then move all the old mcMMO configs including the users out of my craftbukkit folder. Next I start my server log in and none of the skill gaining works. Before it was giving me errors, now its giving me nothing. Please help. My friends and I REALLY LOVE your plugin and we have been without it since the 1.3 update. Thanks for reading.

    P.S.- Everything works EXCEPT the skill gaining. I can type /stats and every other command its just that skill gaining has no effect what so ever.

    P.S.S- I think I have also set up Permissions right because the other plugins that require permissions work and I just did it the same way.
  20. Offline


    Are you using Permissions 2.1?
  21. Offline


    No Permissions 2.1 was giving me issues and wasnt working.
  22. Offline


    Did you remember to rename to permissions file to 'world' or the name of your world?
    Its something you have to do for Permissions 2.1
  23. Offline

    Soul Reaper

    any plans to make this modular? I just need the anvil, party system, and some of the skills :S
  24. Offline


    @SoulReaper Thats what the permissions are for.
  25. Offline


    No I dont have Permissions 2.1 i have Permissions 2.0 and it works with every other plugin including yours. The only problem is the skills arnt leveling up......
  26. Offline


    2.0 permissions was said to work fine, but it's not letting anyone do anything with this addon, so trying with 2.1.

    lol looks like someone else was having the same issue
  27. Offline


    Disclaimer: A small bug got past me, Bleed/HP Regeneration probably won't work for you. I'll fix it tomorrow hopefully. Please don't post to tell me its broken, I know its broken.
    This bug doesn't break anything except Bleed/HP Regeneration not working.

    Version 0.8
    • Archery skill now lets players recover arrows from downed foes
    • Health regenerates based on power level
    • Myspawn clearing inventory can now be toggled in the settings file
    • Swords now have a bleed effect
    • Rewrote Skill descriptions to be more informative/better
    • Misc bug fixes
    Alright guys, heres what you need to know about this update.

    HP Regeneration
    Starting at above 100 power level players will heal half a heart every 40 seconds. If you are hit by a monster or a player you have to wait a full 60 seconds before normal regeneration will kick back in.

    Archery Changes
    Starting at 50 Archery skill your arrows have a chance on hit to be added to the mobs loot. At higher skill levels more arrows will be retrievable. With a ridiculously high skill level you will always get all your arrows back.

    Sword Changes
    Swords now have a bleed effect. Applying the bleed effect to your target is based on your skill level. After 600 skill in swords you will cause targets to bleed for longer. If a mob/player bleeds to death they will drop their loot just as if you hit them to death. You can essentially whack a bunch of monsters and watch them bleed to death.

    I spent all day and some of yesterday coding this. I feel quite proud. I hope you guys enjoy this, I think these changes really improve mcMMO. I know this update doesn't have a new skill, this is mainly because I don't want to add any useless skills so I'm taking my time thinking of another great one.

    Like usual, I will watch this thread like a hawk and make sure everyone is able to run mcMMO like a well oiled machine. I hope 0.9 will be an even better update than 0.8!

    Thanks for downloading and using mcMMO, and double thanks to the donators.

    Version 0.8.1
    • Fixed nullpointer exception causing TimerTask to fail
    If you guys get any errors related to TimerTask, link to a screenshot.

    EDIT: Crap, just spotted yet another TimerTask bug. I'll put out a fix soon.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 8, 2016
  28. Offline


    hey, great update. i have a request. i want to use individual skills, my problem is, it shows all skill levels under /stats. is it possible to show only the skills that are set in the permission?
  29. Offline


    Can you please help. My friend and I really want to get your plugin working again...
  30. Offline


    @wafels45 I would say you probably need 2.1 of permissions

    I'm about to go to sleep guys so I'll fix HP REGENERATION/Bleed not working tomorrow. Please don't post any TimerTask bug reports, I already know what the problem is.
  31. Offline


Thread Status:
Not open for further replies.

Share This Page