[RPG/MECH] mcMMO v1.2.07 - RPG Addiction Redefined! Multi-Lingual! [1337][1549]

Discussion in 'Inactive/Unsupported Plugins' started by nossr50, Feb 5, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    Those errors I'm pretty sure are from formatting your permissions file incorrectly. They can help you with that over in the permissions thread.
  3. Offline


    Actually if you look back a few posts, you can see that I have already solved that problem. This plugin is not yet compatible with Permissions 2.1 That error went away after I downgraded to Permissions 2.0. I have a new problem now of not receiving xp from doing activities.
  4. Offline


    Thanks Galdrak!

    This works! But I installed GroupManager instead.
  5. Offline

    SweetCraft Girl

    Just to confirm something, if i change the loot item names in the config file, it does change the loot or not?

    I littered "dirt" through the list as loot. YAY! You dig in dirt and get even more! WooT! I want to change a couple items to specific quest key starters by putting items there i know they cannot acquire themselves.
  6. Offline


    @SweetCraft Girl
    It does not, its a planned feature though. I would like users to be able to customize loot they can find with excavation. The second part of your post confuses me as it does not do such a thing.
  7. Offline


    I spent about 10 minutes excavating, and I have received no xp from the excavation. Is there something further that I need to do to get the xp to work?
  8. Offline


    @Galdrak Theres only a few reasons why you would be getting no XP.

    1) You are using a build of CB that is not tested to work with mcMMO
    2) Your permissions are setup incorrectly (remember 4 spaces, no tabs)
    3) Your users are not in the group that has the permission to get skills
  9. Offline


    This mod looks really great, I just had one question, with higher skills do you mine/destroy blocks of that type faster? Or do you plan on implementing something like that? :eek:
  10. Offline


    Version 0.7.9
    • XP Curve now follows a new formula
    • Acrobatics XP gains changed
    • Compiled against permissions 2.1
    The new XP curve isn't much different, but should slow down level gains between 1-100, the modifier still works the same.

    This update may require using Permissions 2.1
    (Permissions is still optional for mcMMO but highly recommended)

    If this does require you to use permissions 2.1, then you NEED to read this or mcMMO will NOT WORK!

    Permissions 2.1 Installation instructions from http://permissions.nexua.org/
    If you install Permissions 2.1 and do not follow these instruction, NOTHING WILL WORK!
    I hope this is enough fair warning to stop people from posting mistakes that could've otherwise been avoided [pig]
  11. Offline



    This is what I get with mcmmo 0.7.8
    Permissions 2.0 (when I haven't even touched them to add anything from mcmmo yet, or with the permissions added in.)
    CBukkit build #432 like you recommended.
  12. Offline


    I was wondering if you had fixed the bug where on a protected area, you could mine the stuff there, and every fourth break and coming back, one of the actual item would come out for you to pick up.
  13. Offline


    Any chance of GroupManager support? Permissions developer stopped working on this. I can use permissions support eitherway with groupmanager so im not worried about it, but would be nice for native support. ;)
  14. Offline


    So, is 7.9 allowing for newer bukkit updates? I haven't switched from 432 but have alot of members saying ladders are broken. So I was rolling around the idea of bumping up the CB build to hopefully fix it. But I don't want to lose my mcMMO...
  15. Offline


    I was getting this when issuing reload in console to load the plugin/changes. Giving the server a restart solved it.
  16. Offline


    im running permissions 2.1 and mcmmo7.8 on cb432 with no problems
  17. Offline


    @Mukrakiish Updating is probably fine, you can try it out.
  18. Offline


    I am trying to work through permissions yml to get it working for now. It seems to be set up correctly, and I have the CB build that nossr recommended, but am still unable to get it to work correctly.
  19. Offline


    Ok, one more thing do you have an archive of older versions? Since Multi-Verse is not going to be shifting to 2.1 in any hurry since there seems to be some API issues, its going to bugger my current mcMMO version since its 7.3 and its still bugged. Maybe there is still 7.8 in an archive somewhere so we can have the 'full working' but pre-2.1 version?

    Thanks again for all your hardwork. Its much appreciated.
  20. Offline


    @Mukrakiish You might be able to use 2.0 Permissions with 0.7.9, its worth a shot. If not, I'll compile a build for 2.0.​
  21. Offline


    When I repair, I got a debug message:
  22. Offline


    @MCMaG.jp Whoops!

    Version 0.7.10
    • Debug messages on repair removed
  23. Offline


    2011-02-24 17:11:54 [INFO] This server is running Craftbukkit version git-Bukkit
    -0.0.0-450-gd3c1ba4-b432jnks (MC: 1.3)
    2011-02-24 17:11:54 [INFO] Preparing level "Skillcraft1"
    2011-02-24 17:11:54 [INFO] Preparing start region
    2011-02-24 17:11:55 [INFO] [mcMMO] Permissions enabled.
    2011-02-24 17:12:13 [WARNING] Failed to handle packet: java.lang.NullPointer
    at net.minecraft.server.ServerConfigurationManager.d(ServerConfigura
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:754
    at net.minecraft.server.Packet9Respawn.a(SourceFile:10)
    at net.minecraft.server.NetworkManager.a(SourceFile:230)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:70)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:338)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:253
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)2011-

    running mcmm07.9
    premissions 2.1
    and CB 432
    (no other plugins or mods)

    getting this error everytime i try to respawn after dying

    edit: tried to replicate w/o mcmmo, no errors
  24. Offline


    @diegokilla Try running only mcMMO and tell me what happens
  25. Offline


    done. exact same thing

    2011-02-24 17:23:30 [INFO] This server is running Craftbukkit version git-Bukkit
    -0.0.0-450-gd3c1ba4-b432jnks (MC: 1.3)
    2011-02-24 17:23:30 [INFO] Preparing level "Skillcraft1"
    2011-02-24 17:23:30 [INFO] Preparing start region
    2011-02-24 17:23:31 [SEVERE] [mcMMO] Permissions isn't loaded, there are no rest
    2011-02-24 17:23:31 [INFO] mcMMO version 0.7.9 is enabled!
    2011-02-24 17:23:31 [INFO] Done (593365456ns)! For help, type "help" or "?"
    2011-02-24 17:23:38 [INFO] 143 recipes
    2011-02-24 17:23:38 [INFO] diegokilla [/] logged in with enti
    ty id 86
    2011-02-24 17:23:40 [WARNING] Failed to handle packet: java.lang.NullPointerExce
    at net.minecraft.server.ServerConfigurationManager.d(ServerConfiguration
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:754)
    at net.minecraft.server.Packet9Respawn.a(SourceFile:10)
    at net.minecraft.server.NetworkManager.a(SourceFile:230)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:70)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:338)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:253)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
  26. Offline



    Thanks for making such a great plugin!

    More importantly thanks for updating it so frequently and helping with support issues.

    I would like to request the option (in mcmmo.properites) to be able to choose whether or not using /myspawn clears your inventory. I looked and don't believe this option exists right now.

  27. Offline


    @CaptainMo Sure I'll put it in the next version
    --- merged: Feb 24, 2011 10:37 PM ---
    @diegokilla That doesn't seem to be an mcMMO error... hmm try a newer build of CB perhaps?
  28. Offline


    @nossr: i am trying to replicate error on my wife's account and cant get it to replicate... possibly it has something to do with being op'd? wife is set to default user while my account is op'd... going to continue to try to reproduce it on wifes account to try and pinpoint the problem
  29. Offline


    ive figured out that mine works fine cuz im the admin. once i put myself in default mcmmo stops working. as far as not getting xp plus no motd
  30. Offline


    @KCMO_HITMAN that would be because your permissions are setup incorrectly
  31. Offline


    i spent almost an hour now messing with it and the only way i can get mcmmo 7.9 with permisions 2.1 and cb 432 to work is if i make myself an admin in permisions. im also an op maybe that has something to do with it
    --- merged: Feb 24, 2011 10:51 PM ---
    ive config many permission files now. im pretty sure i know i have them set right.
    --- merged: Feb 24, 2011 10:54 PM ---
    maybe you can post an example of a basic permissions config that works? if you already havent done so. im posting before research sorry
Thread Status:
Not open for further replies.

Share This Page