[RPG/MECH] mcMMO v1.2.07 - RPG Addiction Redefined! Multi-Lingual! [1337][1549]

Discussion in 'Inactive/Unsupported Plugins' started by nossr50, Feb 5, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    I came on here to ask the same exact thing. How does one go about disabling MCMMO's specific MOTD?
  3. Offline


    Everything is working great on 820 with permissions 3.1.4.. except one thing, the no durability loss during abilities.. For some reason the tool does lose durability but "not". So you end up with an empty slot that's not really empty.. It's kind of weird..
  4. Offline


    Can you add some kind of 'branching' thing?
    Like, in the beginning you choose from 3 directions.
    you choose for weapons.
    then you have to choose between Unarmed, Swords, Archery or Axes?
    or will i have to set this up on my own?
    i really feel like doing a guide how to make a good rp server.

    Just dont give the mcmmo.motd permissions.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  5. Offline


    Just posting to say that my server is running CB 820 and McMMO 1.0.09 perfectly.

    All skills are granting XP, durability is acting normal, no problems whatsoever.
  6. Offline


    Sometimes I'm confused as to how people with enough know-how to run a server and install plugins can't follow the most simple of instructions.

    Seriously. I've never messed with anything like permissions in my life and I could figure it out without complaining to the forums. How do people still come here daily to ask how to disable and enable specific stuff?

    My complaint aside, the current version is running perfectly on the stable recommended version of Bukkit for me. No errors at all. Gaining XP on everything just fine even with my complicated modifiers in place.
  7. Offline


    I don't gain exp on combat skills and others do. Could you plz tell me whether you installed mcmmo new with all files? ( jar and folder ) or did you download a previous version and just updated your .jar?
  8. Offline


    Minor bug -- Saplings gained with tree feller don't stack with other saplings of the same type. lol. *shrug*
  9. Offline


    Yeah, you're not coming off as a huge douchebag or anything. Your face when we're human beings and sometimes we make the most silliest of mistakes.

    Also, yeah. I'm not getting any XP errors either. Everything is working fine. The only thing I have that's odd is that I'm getting XP per hit, when I could've sworn it was XP per kill. I'm probably just mistaken, though.
  10. Offline


    Swords, axes, and acrobatics doesn't work on my server :O!
  11. Offline


    I'm sorry if I'm coming off like a douchebag and as often as possible I try to be helpful, but a lot of these are elementary problems that can be solved by doing something as simple as reading the first post and at the very most doing a search of the forums.

    There are plenty of people here with valid problems (i.e. unable to gain xp in certain skills), but those who are complaining about the intro message, xp modifiers, or permissions in general need to read the first post before posting. That's all I meant to say.

    Maybe that's the problem. I did NOT start new - I've been constantly replacing the jar file without messing around with the config files past modifying XP values somewhat recently.

    Permissions are set simply enough - mods have all permissions, other users have:

    That's pretty much all aside from the fact that I'm using Permissions 3.0. I have no idea why else it would be working fine for me. Probably just luck to be honest, haha.
  12. Offline


    Hi, I'm setting up a new server on CentOS and trying to use mcMMO. However, everytime I start the server I get a SEVERE error, please help.
    2011-06-06 00:21:58 [INFO] [mcMMO] Permissions enabled.
    2011-06-06 00:21:58 [SEVERE] Error occurred while enabling mcMMO v1.0.09 (Is it up to date?): URLDecoder: Incomplete trailing escape (%) pattern
    java.lang.IllegalArgumentException: URLDecoder: Incomplete trailing escape (%) pattern
        at java.net.URLDecoder.decode(URLDecoder.java:187)
        at com.mysql.jdbc.NonRegisteringDriver.parseURL(NonRegisteringDriver.java:633)
        at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:296)
        at java.sql.DriverManager.getConnection(DriverManager.java:620)
        at java.sql.DriverManager.getConnection(DriverManager.java:222)
        at com.gmail.nossr50.Database.<init>(Database.java:35)
        at com.gmail.nossr50.mcMMO.mcLoadMySQL(mcMMO.java:83)
        at com.gmail.nossr50.mcMMO.onEnable(mcMMO.java:69)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:125)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:750)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:253)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:134)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:112)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:232)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:219)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:146)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    When I try using it with my test server on Windows it works perfectly fine, but for someone reason it doesn't want to start up on Minecraft on a CentOS server.
  13. Offline


    MineOS doesn't come with mysql by default, it looks like your config might be set up for it instead of flatfile.
  14. Offline


    I'm using CentOS not MineOS :confused: Anyways I got it to work by changing the password to all alphanumeric and re-encoding the config file in UTF-8.
  15. Offline


    Whoa - totally misread that. Sorry!
  16. Offline


    By chance do players lose skillpoints over time or maybe its a new bug. Im running bukkit 819 and mcmmo 1.0.09 and users are saying they have been losing skill points the past few days.
  17. Offline


    Ya that was happening with me and some other poeple too. until one day it totally started crashing the server with error spamming.
    capsar likes this.
  18. Offline


    Hm. Sad. Because at the first time I just updated my .jar too. ( atm I redownloaded like 6 times and replaced reinstalled all and so on ) Maybe we just need to wait for the next version
  19. Offline


    Ok so wait, XP isn't broken it's only for some ppl?

    I use mysql and ever since Mc 1.6 Swords/Bows don't gain any XP for anyone on my server, shovel and pickaxe works fine tho. Does anyone have a possible fix then?
  20. ive heard mcMMO is corrupted plugin, it corrupts chunks and causes crashes.
  21. Offline


    I heard hearing random stuff with no proof is just trolling on forums.
  22. actually, when i remove mcmmo -> my server loads chunks a lot better :) but i dont mind , just saying ive heard that and it really does a lil. Is there gonna be update to bukkit 818?
  23. Offline


    The mcmmo code only executes when you interact with the world as in breaking blocks, cutting down trees, picking plants or killing mobs. Block loading has absolutely nothing to do with mcmmo whatsoever so it just makes no sense at all that it would affect that. Block loading sucks in 1.6 vanilla without any plugins or bukkit running so until the actual mc server code gets better block loading its not going to get any better much.
    Also if u read 1 page back u'll see the auth posted that its fully 818 compatible. The only issue sofar seems to be that certain skills dont level up and others lvl u to much (swords/archery/herbalism)
  24. Offline


    Localization support incoming...

    Alright guys the next update to mcMMO due out today (most likely) will have localization implemented, so you can translate mcMMO into another language and share language files. This was thanks to Pandarr programming localization in for mcMMO.

    I have tested XP gains with bukkit 818 and 1.0.09 and I'm able to gain xp in every skill with no problem, those with issue please answer the following

    1) Are you using MySQL or Flat File
    2) Are you using bukkit 818
    3) Are you using 1.0.09

    Anywho, I've got a list of some bug reports anyways that I'm going to take a look at. I'll be updating mcMMO when I've finished the final touches on localization.
  25. Offline


    1. MySQL
    2. Used 818 and now using 823 (no XP gain for archery/swords on either)
    3. Yes

    I opened the mysql table and I can see my other XP values change/update but nothing happens to the sword/archery numbers.
    Also no errors in the console/log.
  26. Offline


    1. MySQl
    2. Didn't work on 818, using 823 doesn't work.
    No errors.
    Only problems with MCMMO on my server include the following skills not working: Axes, Acrobatics, Swords, Unarmed, Taming and Archer
    Other plugins on my server:
    1. Permissions
    2. CommandBook
    3. Citizens
    4. BananaChunk
    5. iChat
    6. Craftbook
    7. BigBrother
    8. Jobs
    9. CustomDrops
    10. MotherNature
    11. MobBounty
    12. LWC
    13. WorldGuard
    14. AnyoneSleep
    15. InvClear
    16. iConomy
    17. Whitelist
    18. GravelToClay
    19. iConomyChestShops
    20. uQuest
    21. uQuest AutoComplete
    22. BlocksOnGlass
    23. WorldEdit
    24. Warpz0r
    25. Backup
    26. Dynmap
    27. StealthLogin
    Maybe one of these is causing some of the skills not to work?
    Just Repair, Excavation,Herbalism, Woodcutting, and Mining work on my server. Sad face.

    My Permissions
    default: true
    prefix: '&2'
    suffix: '&2'
    build: true
    - 'citizens.create.npctype'
    - 'citizens.use.trader'
    - 'citizens.use.healer'
    - 'citizens.use.wizards'
    - 'citizens.use.blacksmith'
    - 'bog.powered_rail'
    - 'bog.detector_rail'
    - 'bog.torch'
    - 'bog.ladder'
    - 'bog.rails'
    - 'bog.lever'
    - 'bog.stone_plate'
    - 'bog.wood_plate'
    - 'bog.redstone_torch_on'
    - 'bog.stone_button'
    - 'bog.sign'
    - 'bog.wood_door'
    - 'bog.iron_door'
    - 'bog.redstone'
    - 'bog.bed'
    - 'bog.diode'
    - 'bog.fence'
    - 'invclear.self'
    - 'MobBounty.mb'
    - 'jobs.join.Woodcutter'
    - 'jobs.join.Miner'
    - 'jobs.join.Builder'
    - 'jobs.join.Digger'
    - 'jobs.join.Farmer'
    - 'jobs.join.Hunter'
    - 'jobs.world.world'
    - 'mcmmo.motd'
    - 'mcmmo.regeneration'
    - 'mcmmo.chat.partychat'
    - 'mcmmo.commands.ability'
    - 'mcmmo.commands.ptp'
    - 'mcmmo.commands.party'
    - 'mcmmo.commands.whois'
    - 'mcmmo.ability.woodcutting'
    - 'mcmmo.ability.mining'
    - 'mcmmo.ability.axes'
    - 'mcmmo.ability.excavation'
    - 'mcmmo.ability.swords'
    - 'mcmmo.ability.unarmed'
    - 'mcmmo.ability.herbalism'
    - 'mcmmo.skills.*'
    - 'uQuest.CanQuest.done'
    - 'uQuest.CanQuest.amount'
    - 'uQuest.CanQuest.stats'
    - 'uQuest.CanQuest.info'
    - 'uQuest.CanQuest.give'
    - 'uQuest.CanDropQuest'
    - 'warpz0r.warp'
    - 'warpz0r.set'
    - 'warpz0r.remove'
    - 'warpz0r.list'
    - 'warpz0r.warpto'
    - 'warpz0r.home'
    - 'warpz0r.sethome'
    - 'warpz0r.worldwarp'
    - 'warpz0r.worldhome'
    - 'commandbook.rules'
    - 'commandbook.who'
    - 'commandbook.motd'
    - 'commandbook.intro'
    - 'commandbook.midi'
    - 'commandbook.spawn'
    - 'commandbook.msg'
    - 'commandbook.whereami'
    - 'commandbook.whois'
    - 'lwc.protect'
    - 'iConomy.access'
    - 'iConomy.payment'
    - 'iConomy.bank.access'
    - 'iConomy.bank.access'
    - 'iConomy.bank.deposit'
    - 'iConomy.bank.join'
    - 'iConomy.bank.join.multiple'
    - 'iConomy.bank.leave'
    - 'iConomy.bank.list'
    - 'iConomy.bank.main'
    - 'iConomy.bank.main.change'
    - 'iConomy.bank.main.set'
    - 'iConomy.bank.main.view'
    - 'iConomy.bank.transfer'
    - 'iConomy.bank.transfer.multiple'
    - 'iConomy.bank.withdraw'
    - 'iConomy.list'
    - 'iConomy.rank'
    - 'craftbook.mech.ammeter.use'
    - 'craftbook.mech.bridge'
    - 'craftbook.mech.bookshelf.use'
    - 'craftbook.mech.cauldron'
    - 'craftbook.mech.elevator'
    - 'craftbook.mech.elevator.use'
    - 'craftbook.mech.gate'
    - 'craftbook.mech.light-switch'
    - 'craftbook.ic.safe'
    - 'iConomyChestShop.shop.create'
    - 'iConomyChestShop.shop.create.<id>'
    - 'iConomyChestShop.shop.exclude.<id>'
    - 'iConomyChestShop.shop.buy'
    - 'iConomyChestShop.shop.sell'
    - 'iConomyChestShop.command.iteminfo'
    default: false
    prefix: '&1'
    suffix: '&1'
    build: true
    - Builder
    - 'commandbook.kick'
    - 'commandbook.bans.ban'
    - 'commandbook.bans.unban'
    - 'commandbook.bans.isbanned'
    - 'commandbook.bans.load'
    - 'commandbook.bans.save'
    - 'backup.canbackup'
    - 'lwc.mod'
    default: false
    prefix: '&8'
    suffix: '&8'
    build: true
    - '*'
  27. Offline


    Q #1. I'm having trouble with the acrobatics skill. I'm at lvl 86, and it seems that im not getting and xp for jumping off cliffs. The xp bar is stuck at 30/272. This has happened since I got permissions working. Every other skill is fine. Is there an error? :
    1. No idea, how can i check?
    2. 818
    3. No idea what it refers to. Please help.

    default: true
    prefix: '&7'
    suffix: ''
    build: true
    - 'mcmmo.skills.taming'
    - 'mcmmo.ability.woodcutting'
    - 'mcmmo.ability.herbalism'
    - 'mcmmo.ability.unarmed'
    - 'mcmmo.ability.swords'
    - 'mcmmo.ability.excavation'
    - 'mcmmo.ability.axes'
    - 'mcmmo.ability.mining'
    - 'mcmmo.skills.mining'
    - 'mcmmo.skills.woodcutting'
    - 'mcmmo.skills.repair'
    - 'mcmmo.skills.unarmed'
    - 'mcmmo.skills.archery'
    - 'mcmmo.skills.herbalism'
    - 'mcmmo.skills.excavation'
    - 'mcmmo.skills.swords'
    - 'mcmmo.skills.acrobatics'
    - 'mcmmo.skills.axes'
    - 'mcmmo.commands.whois'
    - 'mcmmo.chat.partychat'
    - 'lwc.protect'
    default: false
    prefix: '&9'
    suffix: ''
    build: true
    - Citizen
    - 'mcmmo.chat.adminchat'
    - 'mcmmo.commands.ptp'
    - 'mcmmo.commands.setmyspawn'
    - 'mcmmo.commands.myspawn'
    default: false
    prefix: '&4'
    suffix: ''
    build: true
    - Mayor
    - '*'
    Q #2. Im also having trouble with permissions and mcmmo. I want "Citizen" to be able to invite players to a party, accept party invites, and make a party. What is the permission for this? I've looked through the guide but no help.
  28. Offline


    POSSIBLE FIX FOR XP not gaining!!

    I converted to mysql a while ago from flatfiles but I never deleted the flatfiles and users file so today i went to plugins\mcmmo\ and deleted everything except the config file.
    Now my users are ganing xp on skills again :D

    I must have been smoking something, it did nothing. Mining, excavation, herbalism and repair works everything else doesn't get XP. (i think woodcutting gets xp too)
  29. Offline


    doing that looks like it will erase all data of stats...
  30. Offline


    Just converted over to mysql same skills don't work. Acrobatics,axes,Swords,Unarmed, taming and archer.Just repair,excavation,herbalism, woodcutting, and mining work on my server. Sad face.
  31. Offline


    oh. i haven't checked if axes swords unarmed taming or archer worked. I never use them.
Thread Status:
Not open for further replies.

Share This Page