Inactive [RPG] AncientRPG - Create your own RPG v0.95[1.3.2]

Discussion in 'Inactive/Unsupported Plugins' started by Pylamo, Mar 19, 2012.

  1. Offline


    [RPG] AncientRPG - Create your own RPG

    With AncientRPG you can create your own classes and spells and use the built in guild/party system.
    There is also a fully configurable HP and XP system.
    Use our new homepage if you need help.
    For a list of all commands and a more detailed documation visit our wiki.

    Plugin depends on Vault!

    • Guild system
      • guild chat
      • guild admin functions
      • guild stored in yaml files
      • motd
      • guild ranks
      • guild bank (economy system)
    • XP system
      • Define experience for each creature
      • Use level system with spells
    • HP system
      • Customizable damage of creatures
      • Customizable damage reduction of armor
      • Custom HP of players and creatures
    • Class system
      • Create your own classes by creating folders in the Class folder
    • Spellmaker for spells
      • Easy to use spellmaker to make spells
      • Can use all commands for spells
      • Easy use of parameters and subparameters
      • Hints what to do next
      • Easy variable creator
    Download the latest version here.
    Download latest (maybe) unstable builds here
    Download the spellmaker here

    Spellmaker tutorial:

    If you appreciate my work and want to support me you can

    We are adding more commands and parameters soon, but if you have one command you need for your spells or you have any question pm me or add me on
    steam([email protected])/icq(317116559)/skype(soul0ry).

    txbergy likes this.
  2. Wow sound complicated but very awsome at the same time :)
  3. Offline


    Changelog please
  4. Offline


    There is already a changelog, but I made the text bigger for you :)
  5. Offline


    Spout support or update to 1.2.5? I've been looking for something like this.
  6. Offline


    Spout is planned for version 1.0, it also works with 1.2.5
  7. Offline


    Fantastic. Thank you for reply.
  8. Offline


    Sorry didn't see that, approved.
  9. Offline


    Is there was a specific document name that is given to the class config file?

    NVM looks like after I attempt to join the class i got the config file

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 24, 2016
  10. Offline


    I already love your plugin 'cause of spellmaker, but can you add class based damage system? Ex. class A will deal 200 dmg with diamond sword, class B will deal 240 dmg with diamond sword.
    And please, add mana and hp per level system.
  11. Offline


    This is already possible with my dev version, so yes :)
  12. Offline


    Hope that you'll continue updating this plugin, sounds cool. I'll use it on my server :)
  13. Offline


    Of course,
    new version will be released ~sunday
  14. Offline


    havn't downloaded yet but curious to know if i can disable parts of this like guilds and xp and whatnot to prevent interference with factions and mcmmo?
  15. Offline


    Yes you can disable every part of the plugin (except classes, but just don't create a classes then).
  16. Offline


    when people disconnect from my server they lose their stats, why is this and how can i fix this
  17. Offline


    that should not happen.
    are you sure that your server has the rights to create the playerfiles?
    please check if there are files in the ancientrpg/players folder
  18. Offline


    Hi! I'm a newbie server admin (for my family since we all love minecraft) and I love your plugin! I created Mage as a class and added some spells, but when someone takes the class it says they don't have permission to cast spells....I see the permissions in the class file, but am kinda at a loss as to what to put there.
  19. Offline


    You probably defined a permission in the spell config, open the config wit an editor and remove the permission.
  20. Offline


    Hi! Thanks for the quick response, I appreciate it. I checked, but there are no permissions set. I did notice something I did not notice yesterday...when you type 'set class mage' I get 'your class is now mage' and then under that, in red I get 'An internal error occurred while attempting to perform this command'. I am guessing this may have something to do with it? As a side note, the spells work on my character, but I have op don't know. :confused: Thanks for any help!
  21. Offline


    Can you paste the error please?
    And some general information:
    Which permission plugin do you use, is the latest version of vault installed on your server?
  22. Offline


    I don't know how to cut/paste from minecraft...but the exact message was 'An internal error occurred while attempting to perform this command'

    I don't think i have a permissions plugin, these are what I have:
    And I am certain vault is the latest, as I just downloaded it yesterday and used the latest download.
  23. Offline


    Do you have access to your the logfile of your server or the console of the server?
    A more detailed error message should be logged there.
  24. Offline


    Im such a newbie...I am not sure what a logfile you mean the cmd promt that I use to run it and where I can type in commands like oping myself? I got this in the cmd thing when I tried to set my class to mage: not sure if this is what you wanted... 16:03:13 [SEVERE] null org.bukkit.command.CommandException: Unhandled exception executing command 'clas s' in plugin AncientRPG v0.5 at org.bukkit.command.PluginCommand.execute( at org.bukkit.command.SimpleCommandMap.dispatch( 6) at org.bukkit.craftbukkit.CraftServer.dispatchCommand( 73) at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler. java:821) at at net.minecraft.server.NetServerHandler.a( at net.minecraft.server.Packet3Chat.handle( at net.minecraft.server.NetworkManager.b( at net.minecraft.server.NetServerHandler.a( at net.minecraft.server.NetworkListenThread.a( 8) at net.minecraft.server.MinecraftServer.w( at at Caused by: java.lang.UnsupportedOperationException: SuperPerms no group permissi ons. at net.milkbowl.vault.permission.plugins.Permission_SuperPerms.playerRem oveGroup( at net.milkbowl.vault.permission.Permission.playerRemoveGroup(Permission .java:492) at com.ancientshores.AncientRPG.Classes.Commands.ClassSetCommand.setClas s( at com.ancientshores.AncientRPG.Classes.Commands.ClassSetCommand.setComm and( at com.ancientshores.AncientRPG.Classes.AncientRPGClass.processCommand(A at com.ancientshores.AncientRPG.AncientRPG.onCommand( ) at org.bukkit.command.PluginCommand.execute( ... 12 more
  25. Offline


    Exactly what I meant.

    As far as I can see superperms does not support groups, to get rid of this problem use PEX.
    (you don't need to configure it or something, just download and put it in your plugins folder) until I fix the problem with the next bugfix release.
  26. Offline


    Didn't realize you created a thread bro.

    This is a great plugin guy if you have an rpg server try this out!
  27. Offline


    Thanks! PEX eliminated the error message, but I still get 'you don't have permissions to cast a spell'
  28. Offline


    Could you please paste your spellconfig?
  29. Offline


    If it is the 'Mage':

    Permissionnode: ''
    armorTypes: leather,iron,chainmail,gold,diamond
    weaponTypes: wood,stone,iron,gold,diamond,bow
    maxhp: 600
    permissiongroup: ''
    enabled in world: ''
    minlevel: 0
    preclass: ''

    and here is a sample simple spell that summons a bread:

    additem, Player, 297, 1
  30. Offline


    Can you add me in skype/steam/icq so I can send you a hopefully fixed version?(addnames in plugin description)

Share This Page