Application RemoteToolkit - Restarts + crash detection + auto saves + remote console!

Discussion in 'Bukkit Tools' started by drdanick, Jan 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Minecraft RemoteToolkit
    -Less downtime, more fun for your players, more power to you!

    Are you a Minecraft server administrator? Do you value up-time and stability? Do you fancy the ability to remotely control your server, both in-game and out of game, in a myriad of useful ways from a plethora of different devices?
    If you answered yes to any of the above, then the Minecraft RemoteToolkit is for you!

    What the Minecraft RemoteToolkit Plugin and Wrapper do for you:
    • Provides almost perfect server uptime with no need for action from an owner/administrator!
    • Have your server save and restart at any time period with configurable restart warnings!
    • The Toolkit guarantees a restart within the set restart period, even if your server crashes, becomes unresponsive, or encounters a "SEVERE" exception!
    • Remotely control every function of the Toolkit, even from your smart phone!
    • Full remote console access via telnet with support for multiple terminal types!
    • Telnet daemon conforms to current Telnet related RFCs!
    • Customizable alert messages!
    • Fully extendable though 3rd party modules!
    • Full feature set works with most craftbukkit builds!
    • Most features work with any Minecraft server variation, even vanilla!
    • Telnet can be disabled!
    For server administrators
    Download - Release 10, Alpha 15.3 [CB 1.7.2-R0.2] (wget friendly)
    Instructions & Documentation

    For developers
    UDP API REV 8 | Documentation
    Module API | Coming soon!

    For everyone
    Official IRC channel
    #remotetoolkit @

    "Help! I've downloaded it, but I do not know how to get it working!"
    Stop! Before you give up or ask for help, make sure you have read the step-by-step installation instructions on the wiki page. If you are still having problems, please do not be hesitant to post a request for help on this thread or in the IRC channel - no matter how simple your problem seems.


    Any donation would be very much appreciated. I'm but a poor University student, and I sacrifice quite a lot of unpaid time to keep the Toolkit updates and support flowing.

    Thank you to the following who have chosen to support the Toolkit through a donation:
    Deren909, marshall007, Vittek, clanslots, meee, KyneSilverhide, szoller, hungoverfurball, Lama_0, Viet, acc1dent, joby890, Liger_XT5
    Last edited: May 6, 2017
  2. Offline


    Hello, I have a... little problem with Rkit and with the 1.7.2 version of bukkit. After update of bukkit to 1.7.2 version, every time I issue restart... the rkit forces save, and than sits for exactly 60 seconds, and than restarts... is it something in the config or is it something new in 1.7.2? thx for answering :)
  3. Offline


    I'm milesmcc and I support the idea.

    We need RTK for BungeeCord.
  4. Offline

  5. Offline


    With Current builds of spigot i get this error and cant fix it even by raising maxperm size up in rtoolkits start.command file.

    Warning, your max perm gen size is not set or less than 128mb. It is recommended you restart Java with the following argument: -XX:MaxPermSize=128M

    when i use a normal start up without rtoolkit i dont get the message at all. Can you fix or who can i write to help with this issue.
  6. Offline


    VodkaDK I'll look into adding support one way or another. I'm overseas for the next few months, so can't do anything right now.

    MrInfro Make sure you are running the latest version of the toolkit. Redownload it to be sure.

    Wizardgreatar either set enable-jline to true, or set filter-ansi-escape-codes to true.

    zachrywilsn pastebin both the contents of, and the script you are using to start the toolkit.
  7. Offline


    I understand, thank you for considering my request :)
  8. Offline


    i added (,-XX:MaxPermSize=256M) to the line underneath but ill still send pastebin for you to check.
    it seams to work after ptting that line in.


    i added it to wrapper properties

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 2, 2016
  9. Offline


    Is there a way I can disable the remote feature like the UDP
  10. Offline


    This would make me amazingly grateful. Item duplication is getting to be more of an issue for me, as i'm starting to control the dupes added by the modpack itself :p This fix would be awesome. Thank you VERY much in advance.
  11. Offline


    Great work on the software drdanick, Im trying to get the new version but your site seems to be down a google search for the file name came up with nothing... doesn anyone know of a mirror or want to email me the file.
  12. Offline


    Looks like the website is down...
  13. Offline


    Hi, why there is not option for force restart server ? I am having a issue that when my server crash it takes over 10 minutes until remote tool kit automatically restarts the server and when .restart is executed happens nothing.
  14. Offline


    Hey, is there a 1.7.2 version of this? i cant get it to work on the latest beta builds or dev builds of bukkit.
  15. Offline


  16. Offline


    Could you either fix the -o or could i get the source code for this project? ill even pay
  17. Offline


    Hey drdanick,
    awesome tool - aynyway, this won't forcestop my server if it crashes (not always but still remarkable) and leaves a zombie-process that will block the port our server is running on. Would be even MORE awesome if you could fix this. Unfortunately I got no log cause I delete it from time to time :/
    Our server-homepage
  18. Offline


    Windows Server2008

    Minecraft Remote Toolkit R10 Alpha 15.3
    Loading toolkit properties...Done.
    Loading toolkit modules...Done.
    Wrapper is running on: Windows Server 2008 R2 6.1 amd64
    Exception in thread "main" java.lang.NoClassDefFoundError: Could not initialize
    class org.fusesource.jansi.internal.Kernel32
    at org.fusesource.jansi.internal.WindowsSupport.getConsoleMode(WindowsSu
    at jline.WindowsTerminal.getConsoleMode(
    at jline.WindowsTerminal.init(
    at jline.TerminalFactory.create(
    at jline.TerminalFactory.get(
    at jline.console.ConsoleReader.<init>(
    at jline.console.ConsoleReader.<init>(
    at com.drdanick.McRKit.Wrapper.init(
    at com.drdanick.McRKit.Wrapper.<init>(
    at com.drdanick.McRKit.Wrapper.createWrapper(
    at com.drdanick.McRKit.McRKitLauncher.<init>(
    at com.drdanick.McRKit.McRKitLauncher.main(
  19. Offline


    Will it restart my server if i crash it with WorldEdit ?
  20. Offline


    It should restart the server if the server goes down at all. (I believe)
  21. Offline


    i have a few questions about this plugin first question is, can this plugin be put on a FTB unleashed server because my server uses craftbukkit.jar second question is does this plugin work on 1.5.2
  22. Offline


    Everything work nice but in my console I have wrong time 1 hour difference ;(
    someone help?
  23. Offline


    drdanick, please add feature (telnet command) to reload toolkit's configuration. Sometimes during setting up server owners should change allocating memory or java command line options. It is boring to stop server, wrapper and restart all this again.
  24. Offline


    EDIT: Problem solved. The keystone was spigot.yml which has an option to restart server on crash. The default script is the same as RToolkit start script, so it has been making more and more copies of one server running. Changing it to seperate script has solved the problem.

    Hello! After updating to 1.6.4, I've been experiencing FAILED TO BIND TO PORT error every now and then, when my server restarts. The wrapper acts like the server didn't launch, but it does work absolutely fine - people can log in and play like normal, only the console doesn't. On top of that, the server restarts itself just fine at the next scheduled time.

    I'm using RToolkit r10a15, and MCPC+ 1.6.4 R2.1 forge 965 on Linux Debian 6 squeeze.
    Here's my
    Startup script is standart for RToolkit
  25. Offline


    does this work with multiple servers on the same machine? ex. i have a 4 server setup connected using bungeecord, would i be able to use this to control the 4 servers? if, yes how would the setup be as compared to default?
  26. Offline


    After following the installation instructions in the Wiki I start the server and it tries 3 times to check for the presence of RemoteToolkit plugin but can't find it. Finally it says "RemoteToolkit plugin for Bukkit was not detected. Disabling heartbeat until next restart."

    If I run just the start script that points directly to the server .jar it loads the RemoteToolkit plugin perfectly but using the script that points to the Remote Toolkit .jar I'm getting the above issue. The server does start fine but the issue is that it's not loading any of my plugins (dynamic map and myhome).

    I fixed it - I had the pointing to the vanilla server jar instead of the spigot JAR.
  27. Offline


    Dear DrDanick,
    Fisrt of all thank you for your very usefull wrapper!

    I use it along with SpaceBukkit (1.2)
    Since 1.7.2, I have some problems.
    When I set server-restart-delay to 0, the server still automatically restarts itself after 6 hours.
    When I set a proper date or time it works perfectly.
    But the big problem is that after a restart SpaceBukkit cannot communicate anymore with the wrapper. When I log in spacebukkit I end up on the page :
    In order to make it work again I need to log in my server via SSH and manually use the command .stopwrapper then restart the wrapper.

    I tried a "fresh" install of your wrapper but still had the same problem.

    I use Release 10, Alpha 15.3 [CB 1.7.2-R0.2], craftbukkit 1.7.2 beta R0.3 and spacebukkit beta 1.2 on ubuntu server 13.10 with Oracle Java 7. I had the same problem with every dev or beta build since 1.7.2.

    Can you help me please?
  28. Hey,
    I'm running it with "BungeeSuiteBans", and it appears to be kicking for a reason "Breaking the server rules" instead of the kick message in the config. Is this an issue you could fix?
  29. Offline


    I am running
    ( Release 10, Alpha 15.3 [CB 1.7.2-R0.2] )
    at the moment on a 1.6.4 server, it simply just doesn't work i get this
  30. Offline


    Wait, what?
  31. Offline


    Well the uploader does not post any links nor tell us where we can find the old builds.
Thread Status:
Not open for further replies.

Share This Page