Application RemoteToolkit - Restarts + crash detection + auto saves + remote console!

Discussion in 'Bukkit Tools' started by drdanick, Jan 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Minecraft RemoteToolkit
    -Less downtime, more fun for your players, more power to you!

    Are you a Minecraft server administrator? Do you value up-time and stability? Do you fancy the ability to remotely control your server, both in-game and out of game, in a myriad of useful ways from a plethora of different devices?
    If you answered yes to any of the above, then the Minecraft RemoteToolkit is for you!

    What the Minecraft RemoteToolkit Plugin and Wrapper do for you:
    • Provides almost perfect server uptime with no need for action from an owner/administrator!
    • Have your server save and restart at any time period with configurable restart warnings!
    • The Toolkit guarantees a restart within the set restart period, even if your server crashes, becomes unresponsive, or encounters a "SEVERE" exception!
    • Remotely control every function of the Toolkit, even from your smart phone!
    • Full remote console access via telnet with support for multiple terminal types!
    • Telnet daemon conforms to current Telnet related RFCs!
    • Customizable alert messages!
    • Fully extendable though 3rd party modules!
    • Full feature set works with most craftbukkit builds!
    • Most features work with any Minecraft server variation, even vanilla!
    • Telnet can be disabled!
    For server administrators
    Download - Release 10, Alpha 15.3 [CB 1.7.2-R0.2] (wget friendly)
    Instructions & Documentation

    For developers
    UDP API REV 8 | Documentation
    Module API | Coming soon!

    For everyone
    Official IRC channel
    #remotetoolkit @

    "Help! I've downloaded it, but I do not know how to get it working!"
    Stop! Before you give up or ask for help, make sure you have read the step-by-step installation instructions on the wiki page. If you are still having problems, please do not be hesitant to post a request for help on this thread or in the IRC channel - no matter how simple your problem seems.


    Any donation would be very much appreciated. I'm but a poor University student, and I sacrifice quite a lot of unpaid time to keep the Toolkit updates and support flowing.

    Thank you to the following who have chosen to support the Toolkit through a donation:
    Deren909, marshall007, Vittek, clanslots, meee, KyneSilverhide, szoller, hungoverfurball, Lama_0, Viet, acc1dent, joby890, Liger_XT5
    Last edited: May 6, 2017
  2. Offline


    I've been having issues with automated server restarts. its having trouble binding to the port because it's already in use?... Not sure why this is happening.
  3. Offline


    Something that might amuse you, drdanick. I had to change the restart message to 'rebooting' instead of 'restart' because all the derp users on my server kept thinking it meant the map was resetting [​IMG]
  4. Offline


    Uh, that's odd. The . commands work from the local server console and from telnet. Wait, you said command window? Are you using Windows? >.> Windows never plays nice with my wrapper, i'm going to have to fix that.
    I admit, I haven't gotten around to doing my Windows testing. I was leaving it for the beta, but that's probably a bad idea.

    Just a technical note: the entire console that you see when you use the Toolkit is actually the wrapper. For the most part, the wrapper is in charge of forwarding input from the console to the server and output from the server to the console window. To get the . commands to work, I parse every line of text entered by the user before sending it to the minecraft server console. The same thing goes for the telnet remote console.

    Oh, the .stopwrapper sends a stop command to the servers console, which by design forces a save of the map and other data.

    Is the minecraft server having trouble binding to the port, or is the wrapper? Can you give me the error as reported in the console (including the stack trace).

    I've heard that one many times ;)
  5. Offline


    My console says

    Starting UDP listen server on port 25561
    UDP Socket exception: Address already in use: Cannot bind

    and it keeps repeating that over and over again, it works at first -- like from a cold boot, but after a random number of server restarts I get that.

    Upon looking at my log, it doesn't even seem like its happening during a server restart... it just, HAPPENED outta nowhere, when a player disconnected?
  6. Offline


    i didn't see this unless it was on page 3 or 4 (skipped those). is there any way to run with garbage collection like this?

    java -Xincgc -Xmx1024M -jar craftbukkit.jar nogui
    because in the the initial heap size is "initial-heap-size=1024M" so i'm guessing it executes -Xms(whatever you declare). So using the -Xincgc flag would not work here. Any suggestions? I'm operating on a wicked memory budget atm, so efficiency is the order of the day for me sadly.
  7. Offline


    I did answer this earlier ;)
    From what i've seen, running -Xincgc along with -Xms is fine, although -Xincgc does not honor the value set by -Xms. In a future update, I will add the option to ignore the initial-heap-size property, just to avoid this confusion. :)
    --- merged: Feb 7, 2011 5:58 PM ---
    That's to do with my wrapper trying to bind to UDP port 25561 for some of the remote functions, nothing to do with the minecraft server. The only reasons I can think of is that you are either running multiple instances of the wrapper inadvertently, or something else is trying to bind to that port.
    Try changing the value of remote-control-port in to some arbitrary number (like 24155).

    One more thing, if this continues to happen, make doubly sure that you aren't running the wrapper twice. Try using the web remote interface ( to issue a "version" command. If you get a response, you're probably running the wrapper twice.
  8. Offline


    Could you put the version in the topic so it's easier to keep track of updates?

    Thanks for the awesome plugin.
  9. Offline




    I'd be more then willing to test new functions in Windows 7 if you need someone to do it.
  10. Offline


    Well, you're clearly running the wrapper. Looks like a windows issue - I will have a look into it ASAP.
    I'll let you know if I need anything tested. Backups will probably need thorough testing on all supported platforms.
  11. Offline


    The response I get is
    1.0_b15_31 ALPHA
  12. Offline


    When I use the plugin Big Brother with this plugin, and do a rollback~ the server restarts.
    I'll do this:
    /bb rollback JERKNAME
    then it will say:
    Are you sure? type /bb confirm
    I'll type it~ and then BAM!
    My server restarts like I had asked it to or something...
  13. Offline


    Ok so this time around it didn't overwrite the and so it wasn't spamming the saves. I set it to save every 6 hours and 30 minutes, and to restart every 3 hours. Its saving fine, but it doesn't restart. The restart warnings aren't given, and the server doesn't restart. When I do /restartsrv however it does restart. Whats up with this? Is it possible that I set it up wrong? Oh and btw I have build #271.
  14. Offline


    Everything downloaded today works out of the box nearly with linux.

    Restarting server...
    2011-02-07 17:10:29 [INFO] [CONSOLE] [SERVER] SERVER IS RESTARTING
    2011-02-07 17:10:33 [INFO] CONSOLE: Stopping the server..
    2011-02-07 17:10:33 [INFO] Stopping server
    2011-02-07 17:10:33 [INFO] [Glonick] version [1.3] (Owl) un-loaded
    2011-02-07 17:10:33 [INFO] MeasuringTape Disabled
    2011-02-07 17:10:33 [INFO] [iChat] version [1.5] (Maria Holic) disabled
    2011-02-07 17:10:33 [INFO] [General] version [2.1] (Salvez) disabled
    2011-02-07 17:10:33 [INFO] Remote Toolkit Plugin V0.11b disabled!
    2011-02-07 17:10:33 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-02-07 17:10:33 [INFO] Saving chunks
    2011-02-07 17:10:39 [INFO] Starting minecraft server version Beta 1.2_01
    2011-02-07 17:10:39 [INFO] Loading properties
    2011-02-07 17:10:39 [INFO] Starting Minecraft server on *:25565
    2011-02-07 17:10:39 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-357-gc3ee971-b268 (MC: 1.2_01)
    2011-02-07 17:10:39 [INFO] Preparing level "world"
    2011-02-07 17:10:39 [INFO] Preparing start region
    2011-02-07 17:10:40 [INFO] Preparing spawn area: 44%
    2011-02-07 17:10:41 [INFO] WorldEdit 3.2.2 loaded.
    2011-02-07 17:10:41 [INFO] WorldEdit: No known permissions plugin detected. Using configuration file for permissions.
    2011-02-07 17:10:41 [INFO] [Glonick] version [1.3] (Owl) loaded
    2011-02-07 17:10:41 [INFO] [iChat] version [1.5] (Maria Holic) loaded
    2011-02-07 17:10:42 [INFO] [General] version [2.1] (Salvez) loaded
    2011-02-07 17:10:42 [INFO] [Permissions] version [1.9] (Handler) loaded
    2011-02-07 17:10:43 [INFO] [MYHOME]: 9 homes loaded
    2011-02-07 17:10:43 [INFO] [MYHOME] Permissions enabled.
    2011-02-07 17:10:43 [INFO] MyHome 1.8 enabled
    2011-02-07 17:10:43 [INFO] MeasuringTape v0.7 by DiddiZ enabled
    Memory max: 2624716800 bytes
    Memory total: 1029046272 bytes
  15. Offline


    Hm. If you get that when you are experiencing the problem, that means the wrapper listen server is being run twice. By design, my code should not allow this. Make sure you aren't running the wrapper elsewhere. Again, try changing the port my wrapper listens to remote requests on.

    Can you post the body of

    You haven't explained the problem you're having.
  16. Offline


    Sure thing. Here it is:
    #Minecraft Remote Toolkit Properties File
    #Tue Feb 08 12:47:42 UTC 2011
  17. Offline


    I'll have a look at it. But on another note, you're missing a space in the server-saveall-period value.
    It should be "6h 30m". Plus, the scheduled save-all will never occur because its frequency is lower then that of the restart frequency. The server-saveall-period value should be lower.
    --- merged: Feb 8, 2011 4:11 AM ---
    Sounds like bigbrother is crashing the server. Have you tried it without the wrapper?
  18. Offline


    I meant to get back to you about this.... It's bukkit 271.
    With all do respect, it's trash.

    I have random blocks all over my world. I have random shadows every 20 blocks or so. I even had a member randomly catch fire today. The build is broken.... very very....broken.
  19. Offline


    How would you run this with another wrapper, IE BioTerrainMod?
  20. Offline


    I suppose that's reason enough to believe that BigBrother is crashing the server.
    The restart means the wrapper is doing its job! :D

    There is a way, but it forces the server into offline mode. (read back a few pages)
    I'm going to introduce the ability to change the process execution line in the properties file in the next update, which will make it work properly.
    --- merged: Feb 8, 2011 6:14 AM ---
    @sadleric The problem should now be fixed.
  21. Offline


    My development server is on windows where I test everything thoroughly before putting on my production server which is on linux. I have your wrapper and plugin running via the .bat file.. however, to get the server to start I have to hit enter... then, after restart, it just hangs at "Restarting..." until I hit enter. Any suggestions?
  22. Offline


    What version of windows are you using?
  23. Offline


    Oh sorry, noobness.. its on winXP Pro.
  24. Offline


    Yeah... XP does some non standard things with cli based applications. There is no easy/clean workaround, and I am probably going to have to remove support for it. If you want, I can give you a custom build that will flush a newline character to the console to simulate the enter key being pressed, but this function will not be part of the official build. It's too messy.
  25. Offline


    No that's fine.. its only my test server anyway.. just where I run new things i'm adding for a day or two before putting them on the linux. If it will function fine when I run it from bash i'm cool
  26. Offline


    latest update will make the server always take 100% cpu for me
  27. Offline


    What version were you using prior to the current version?
  28. Offline


    Release 10, Alpha 5.341

    ahh, sorry for that, actually it has nothing to do with your plugin, that 100% cpu did start last night before i updated your plugin, sorry for that!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  29. Offline


    I have tested it with your settings twice and it worked fine both times. Try setting the restart period down to 1 minute, and see if it restarts. Also be sure to check if any errors occur.
  30. Offline


    my keeps getting overwritten - the values for

    are both getting reset to 1024M

    I know 1024 is a recommended minumum but, i'm running thin on memory atm... just wonder why it does that?
  31. Offline


    It shouldn't. I will have a look at it.

    UPDATE: Found the problem. I will have a fix out soon.
    --- merged: Feb 9, 2011 9:48 AM ---

    @tremor Fixed! Thank you for bringing my attention to that.
    tremor likes this.
Thread Status:
Not open for further replies.

Share This Page