Application RemoteToolkit - Restarts + crash detection + auto saves + remote console!

Discussion in 'Bukkit Tools' started by drdanick, Jan 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Minecraft RemoteToolkit
    -Less downtime, more fun for your players, more power to you!

    Are you a Minecraft server administrator? Do you value up-time and stability? Do you fancy the ability to remotely control your server, both in-game and out of game, in a myriad of useful ways from a plethora of different devices?
    If you answered yes to any of the above, then the Minecraft RemoteToolkit is for you!

    What the Minecraft RemoteToolkit Plugin and Wrapper do for you:
    • Provides almost perfect server uptime with no need for action from an owner/administrator!
    • Have your server save and restart at any time period with configurable restart warnings!
    • The Toolkit guarantees a restart within the set restart period, even if your server crashes, becomes unresponsive, or encounters a "SEVERE" exception!
    • Remotely control every function of the Toolkit, even from your smart phone!
    • Full remote console access via telnet with support for multiple terminal types!
    • Telnet daemon conforms to current Telnet related RFCs!
    • Customizable alert messages!
    • Fully extendable though 3rd party modules!
    • Full feature set works with most craftbukkit builds!
    • Most features work with any Minecraft server variation, even vanilla!
    • Telnet can be disabled!
    For server administrators
    Download - Release 10, Alpha 15.3 [CB 1.7.2-R0.2] (wget friendly)
    Instructions & Documentation

    For developers
    UDP API REV 8 | Documentation
    Module API | Coming soon!

    For everyone
    Official IRC channel
    #remotetoolkit @

    "Help! I've downloaded it, but I do not know how to get it working!"
    Stop! Before you give up or ask for help, make sure you have read the step-by-step installation instructions on the wiki page. If you are still having problems, please do not be hesitant to post a request for help on this thread or in the IRC channel - no matter how simple your problem seems.


    Any donation would be very much appreciated. I'm but a poor University student, and I sacrifice quite a lot of unpaid time to keep the Toolkit updates and support flowing.

    Thank you to the following who have chosen to support the Toolkit through a donation:
    Deren909, marshall007, Vittek, clanslots, meee, KyneSilverhide, szoller, hungoverfurball, Lama_0, Viet, acc1dent, joby890, Liger_XT5
    Last edited: May 6, 2017
  2. Offline


  3. Offline


    Yes, I know what it looks like. My point is that this exception is commonly encountered in Java. I would need to parse multiple lines to decide what the source of the error was, and that is a complete waste of resources.
    I'll see if I can figure out an efficient way of doing this, but it is likely to be detrimental to performance.
    --- merged: Jan 29, 2011 1:11 AM ---
    Yes, the other two lines are printed when the say command is used. Try entering "say **SERVER IS SAVING THE MAP**" and see what happens :p
  4. Offline


    Oh I see never had that in all my logs even one line so I guess I never been stuck with bad plugins before hehe. Even [SEVERE] Unexpected exception never happen besides this from what I can see it many many logs but I guess you know what your doing hehe.
  5. Offline


    wait, i dont understand this duping issue, is it caused by this plugin, or are we safe letting it do its thing? thanks
  6. Offline


    It has nothing to do with this plugin, that was a problem with his own script which has now been fixed. You are safe. :)
  7. Offline


    My "Script" only sended "save-all" waited 10 seconds (5 would be enough), then "stop"

    When I only use "stop" it works thought.
  8. Heyho,

    i got a problem with the remote toolkit. It won't bind the port correctly.
    This is, what i get, when i start the server with the Toolkit:

    2011-01-30 04:56:27 [INFO] Starting minecraft server version Beta 1.2_01
    2011-01-30 04:56:27 [INFO] Loading properties
    2011-01-30 04:56:27 [INFO] Starting Minecraft server on *:25569
    2011-01-30 04:56:27 [WARNING] **** FAILED TO BIND TO PORT!
    2011-01-30 04:56:27 [WARNING] The exception was: Address already in use
    2011-01-30 04:56:27 [WARNING] Perhaps a server is already running on that port?
    When i start bukkit without the toolkit, this is not happening.

    Bukkit b165, Wrapper Release 10, Alpha 4.61

    Oh: And i made sure, that the port is not in use.
  9. Offline


    Can you set telnet-enabled to false in so we can rule that out? That is the only TCP socket that is open in the wrapper. I'll have a look at this myself shortly.
  10. Offline


    I got that when I stopped the server and closed the console without using ctrl+c because the server continues to run. I fixed it by just restarting the comp.
  11. Indeed, after setting telnet to false it worked.
  12. Offline


    Can you re-enable telnet and print the first bunch of console lines up until the socket bind exception?
  13. The lines i quoted above is everything, that got printed out.
  14. Offline


    where is the server bin? i cannot find it =P
  15. Offline


    I need to see the lines pertaining to the wrapper. They occur before what you posted.

    If you mean the bin folder, it's whatever folder you choose to put the craftbukkit jar in. Or do you mean the craftbukkit jar itself?
  16. Offline


    Does this plugin support in game restarting?

    I miss /serverrestart =(
  17. Offline


    I'll be supporting that shortly.
  18. With craftbukkit b186 this is the full output
    Minecraft Remote Toolkit V1.0_b14_61 ALPHA
    Loading toolkit properties...Done.
    Starting wrapper...
    Starting UDP listen server on port 25569
    Jan 31, 2011 8:30:24 AM run
    INFO: Listening to Port 25,569 with a connectivity queue size of 5.
    2011-01-31 08:30:24 [INFO] Starting minecraft server version Beta 1.2_01
    2011-01-31 08:30:24 [INFO] Loading properties
    2011-01-31 08:30:24 [INFO] Starting Minecraft server on *:25569
    2011-01-31 08:30:24 [WARNING] **** FAILED TO BIND TO PORT!
    2011-01-31 08:30:24 [WARNING] The exception was: Address already in use
    2011-01-31 08:30:24 [WARNING] Perhaps a server is already running on that port?
  19. Offline


    Change the remote-control-port value in to be something other than 25569. You should not be setting that port to the save value as the port the server binds to.
  20. Offline


    If i wanted to use the -Xincgc flag instead of Xms, can i leave the Xms parameter blank in the properties file, and add the -Xincgc to the extra runtime arguments? Thanks
  21. Offline


    The incremental garbage collector does not honor the initial heap size, and as far as I know it is not adversely affected by it being there. Just leave the initial heap size setting as is and add -Xincgc to the extra runtime arguments field.
  22. Offline


    Will this work with the following bash script?
    screen -m -d -S minecraft java -Xmx2560M -Xms512M -jar craftbukkit.jar
  23. Head => Table
    I forgot that UDP Control thingie you built in, sorry. So i really did not iron that out, arrrrr!
  24. Offline


    Yes. Set initial-heap-size in to 512M and maximum-heap-size to 2560M. Then run the server with the following command:

    screen -m -d -S minecraft java -jar Minecraft_RKit.jar user:pass

    Remember to replace user and pass with something else!
  25. Offline


    its possible to put the messages to config file for localisation?
  26. Offline


    Yes, that is something I plan to do either today or tomorrow.
  27. Offline


    How would i accomplish something like this with the auto restarter?
    -cp BiomeBukkit.jar;craftbukkit.jar org.bukkit.craftbukkit.Main

    Because i don't see a way to run two jars as one classpath yet
    --- merged: Feb 1, 2011 1:54 PM ---
    Nevermind i used server arguments instead!
    --- merged: Feb 1, 2011 1:58 PM ---
    Yeah that didn't work.

    Yeah still didnt' work
  28. Offline

  29. Offline


  30. Offline


    What craftbukkit build are you using, and what exactly was the error?
    I just tested it again and it works fine for me.
  31. Offline


Thread Status:
Not open for further replies.

Share This Page