Application RemoteToolkit - Restarts + crash detection + auto saves + remote console!

Discussion in 'Bukkit Tools' started by drdanick, Jan 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Minecraft RemoteToolkit
    -Less downtime, more fun for your players, more power to you!

    Are you a Minecraft server administrator? Do you value up-time and stability? Do you fancy the ability to remotely control your server, both in-game and out of game, in a myriad of useful ways from a plethora of different devices?
    If you answered yes to any of the above, then the Minecraft RemoteToolkit is for you!

    What the Minecraft RemoteToolkit Plugin and Wrapper do for you:
    • Provides almost perfect server uptime with no need for action from an owner/administrator!
    • Have your server save and restart at any time period with configurable restart warnings!
    • The Toolkit guarantees a restart within the set restart period, even if your server crashes, becomes unresponsive, or encounters a "SEVERE" exception!
    • Remotely control every function of the Toolkit, even from your smart phone!
    • Full remote console access via telnet with support for multiple terminal types!
    • Telnet daemon conforms to current Telnet related RFCs!
    • Customizable alert messages!
    • Fully extendable though 3rd party modules!
    • Full feature set works with most craftbukkit builds!
    • Most features work with any Minecraft server variation, even vanilla!
    • Telnet can be disabled!
    For server administrators
    Download - Release 10, Alpha 15.3 [CB 1.7.2-R0.2] (wget friendly)
    Instructions & Documentation

    For developers
    UDP API REV 8 | Documentation
    Module API | Coming soon!

    For everyone
    Official IRC channel
    #remotetoolkit @

    "Help! I've downloaded it, but I do not know how to get it working!"
    Stop! Before you give up or ask for help, make sure you have read the step-by-step installation instructions on the wiki page. If you are still having problems, please do not be hesitant to post a request for help on this thread or in the IRC channel - no matter how simple your problem seems.


    Any donation would be very much appreciated. I'm but a poor University student, and I sacrifice quite a lot of unpaid time to keep the Toolkit updates and support flowing.

    Thank you to the following who have chosen to support the Toolkit through a donation:
    Deren909, marshall007, Vittek, clanslots, meee, KyneSilverhide, szoller, hungoverfurball, Lama_0, Viet, acc1dent, joby890, Liger_XT5
    Last edited: May 6, 2017
  2. Offline


    I mean, the rtoolkit, arent you supposed to double click it, instead of start? or how does it works? ( to start the cmd windom that starts the server ) ? any edits there or?
  3. you are supposed to run the rtoolkit.bag or .sh file. You need to edit the wrapper.propperties if your craftbukkit.jar does have another filename.
  4. Offline


    why don't you use that the people can subscribe to updates via e-mail?
  5. Offline


    It's named craftbukkit , but i'm supposed to type it's named craftbukkit.jar right?
  6. Offline


    I got a problem when i try to remotly connect to my server so i can start it and restart it , i've read the hole thread u gave on how to install and commands , i added all the files as in there ,edited everything to what i needed , running rtoolkit.bat runs the server ok, but using putty.exe to connect to my hosters ip is not working at all. I put the ip and port select the network as telnet as in the "tutorial", I selected that it never closes the window so i can see whats going on but nothing, i either get the putty command prompt like "serverip - PuTTy" or i get Server unexpectedly closed network connection, and in other cases something about remote hoster closed. I think it is because the server doesn't have an ip to connect to It's a DNS, could that be my problem? Can anyone tell me what im doing wrong or maybe a sugestion of what i should be doing.
  7. yes, as the wohle filename is craftbukkit.jar. BTW if you do not see extensions in your explorer (are you using Windows?) i would recommend that you change the settings, so you can see them!
  8. Offline


    But the problem is, if i do it all correct, and double click the rtoolit.bat, it says java is not a etc, sould i do something extra there?
  9. Java is not recognized as an internal or external command?
    That would indicate that your systemvariables are not correct. I'D suggest search google for it as there are some more reasons why this coud happen.
  10. Offline


    I'd say he's got a 64 bit OS but only 32 bit Java installed.
  11. Offline

    justin shulman

    It seems that when people try to join the server the first time the client crashes, however the second time they try they logging without an issue? Any fix?
  12. Offline


    Thank You SO Much You Are The BEST Plugin Developer Ever!!! All Other Plugins Suck Compared To This ;)
    no problems at all! A bit hard to install i must admit, especially on a Mac :p. Cool Though!!


    - Der

    I Donated Today!! <3 This Plugin :D

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 2, 2016
    drdanick likes this.
  13. Offline


    ye =/ how can i fix this :?

    Any fix for it? D=

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 2, 2016
  14. Offline


    @davvem How are you currently launching the server without the toolkit? If you're using a .bat/.sh, can you post its contents here?

    There's a copy of it on the first few pages of this thread. It is missing a few commands, but they are documented in the wiki. Tell me if you need any more help.

    I will need to see the errors. I can't help much otherwise

    I am looking in to it. I'm still not certain as to how I am going to categorize the toolkit there.

    Have you portforwarded the correct TCP port? (25561 by default)

    That sounds like something on bukkit's end. The toolkit does not interfere with the operation of the server directly. However, if you provide the information I asked for in the replay to your PM, I may be able to help.
  15. Offline


  16. Offline


    Nvm fixed it =p And, i meant for the server xd, i'm going to try redownload the plugin and see if it works now, i'll comment soon =)

    Thank you so much morrolan! =D helped me =)

    Ok, i got it to work! :D:D:D:D:D:D:D:D:D, and i whant to say thanks! to everyone who helped me! it was WERY kind of you, and i love this pluggin! =D and my server works perfect now! =D also, ip if anyone whanna check it out :p xD

    Nvm, it says read timed out, is there a fix for that??

    ok, just 2 questions 1, does .restart fixes it temporarly, or permanently? 2, do you mean it dosent like... save the information too well or what? ( noob at this )

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 30, 2018
  17. Offline


    That is a very well known server-side issue (ie. not the toolkit). The best you can do is to issue a restart when it occurs. Future toolkit releases should be able to accurately detect this and restart the server automatically.
  18. Offline


    Where are errors for Rtoolkit placed?
  19. Offline


    As of yet, the toolkit does not log anything (this is being implemented in the next release). Do you have access to the console? If the problem repeats itself, try to copy down whatever is printed to the console.
  20. Offline


    What do you mean whit that?? and it repeats itself
    it only says read timed out
    read timed out
    read timed out
  21. Offline


    Issue this console command:
  22. Offline


    The read time out error is a problem on bukkit's end - the restart is only a temporary solution. Map data should be saved when .restart is used.
  23. Offline


    Yes, I run it from home (2 server PC's dedicated to one server with RAID intercross cable... So yeah :D). Also, my server has frozen before, and Rtoolkit doesn't restart the server...
  24. Offline


    Nvm, i found that it works EXCELENT togheter whit Autosave =p Autosave+rtoolkit=EPIC xd
  25. Offline


    ehh so I must waiting... i try try try... and or error or server start(on) but option wrapper no loaded

    /again sry for English
  26. Offline


    Saved the server from total collapse, twice!
  27. Offline


    hey i know ur probably busy but after i install everything, whe i try to open the .bat file, it flashes open for half a sec and and then closes again and i dont know why. please help me if u can, i really need to get this working, thanks
  28. Offline


    Open the .bar file in a text editor and add this to a new line at the end of the file:
    Run the .bat again and tell me what the error was.
  29. Offline

    Epic Sandwich

    I've set everything up on the wiki as instructed, but when I try and connect to the server I get a 'connection refused' error. Any ideas?

    My server was working fine before installing the wrapper.
  30. Offline


    What operating system are you using, and how are you launching the toolkit?
  31. Offline

    Epic Sandwich

    I'm on my Ubuntu VPS, and I'm launching it with 'bash'
Thread Status:
Not open for further replies.

Share This Page