Application RemoteToolkit - Restarts + crash detection + auto saves + remote console!

Discussion in 'Bukkit Tools' started by drdanick, Jan 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Minecraft RemoteToolkit
    -Less downtime, more fun for your players, more power to you!

    Are you a Minecraft server administrator? Do you value up-time and stability? Do you fancy the ability to remotely control your server, both in-game and out of game, in a myriad of useful ways from a plethora of different devices?
    If you answered yes to any of the above, then the Minecraft RemoteToolkit is for you!

    What the Minecraft RemoteToolkit Plugin and Wrapper do for you:
    • Provides almost perfect server uptime with no need for action from an owner/administrator!
    • Have your server save and restart at any time period with configurable restart warnings!
    • The Toolkit guarantees a restart within the set restart period, even if your server crashes, becomes unresponsive, or encounters a "SEVERE" exception!
    • Remotely control every function of the Toolkit, even from your smart phone!
    • Full remote console access via telnet with support for multiple terminal types!
    • Telnet daemon conforms to current Telnet related RFCs!
    • Customizable alert messages!
    • Fully extendable though 3rd party modules!
    • Full feature set works with most craftbukkit builds!
    • Most features work with any Minecraft server variation, even vanilla!
    • Telnet can be disabled!
    For server administrators
    Download - Release 10, Alpha 15.3 [CB 1.7.2-R0.2] (wget friendly)
    Instructions & Documentation

    For developers
    UDP API REV 8 | Documentation
    Module API | Coming soon!

    For everyone
    Official IRC channel
    #remotetoolkit @

    "Help! I've downloaded it, but I do not know how to get it working!"
    Stop! Before you give up or ask for help, make sure you have read the step-by-step installation instructions on the wiki page. If you are still having problems, please do not be hesitant to post a request for help on this thread or in the IRC channel - no matter how simple your problem seems.


    Any donation would be very much appreciated. I'm but a poor University student, and I sacrifice quite a lot of unpaid time to keep the Toolkit updates and support flowing.

    Thank you to the following who have chosen to support the Toolkit through a donation:
    Deren909, marshall007, Vittek, clanslots, meee, KyneSilverhide, szoller, hungoverfurball, Lama_0, Viet, acc1dent, joby890, Liger_XT5
    Last edited: May 6, 2017
  2. Offline


    is there a way to disable the save messages? I set them to nothign yet I still see the defautls on my server. My world is on a ramdisk and id like it to save evey minute but im now spamming my userbase with these messages. How can I stop these?
  3. Offline


    I'll implement the ability to hide messages shortly.

    As a side note for everyone: There are a few formatting issues with the new bukkit console formatting system. I will get those straightened out ASAP, but it will most likely require me to implement a good chunk of bukkit's console format system in the wrapper. On the plus side, this may mean that running the wrapper with any server mod/vanilla server will result in having the nice new console system.

    For the mean time, the telnet shell should continue to work correctly.
  4. Offline


    Using build 450 of craftbukkit

    using r10 a8

    hmodtest/bin# sh
    Minecraft Remote Toolkit V1.0_b18 ALPHA
    Loading toolkit properties...Done.
    Loading toolkit modules...Done.
    Wrapper is running on: Linux amd64
    Starting wrapper...
    Starting UDP listen server on port 31337
    Feb 25, 2011 10:35:50 PM run
    INFO: Listening to Port 31,337 with a connectivity queue size of 5.
    22:35:50 [INFO] Starting minecraft server version Beta 1.3
    22:35:50 [INFO] Loading properties
    22:35:51 [INFO] Starting Minecraft server on *:25565
    22:35:51 [WARNING] The server will make no attempt to authenticate usernames. Beware.
    22:35:51 [WARNING] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    22:35:51 [WARNING] To change this, set "online-mode" to "true" in the server.settings file.
    22:35:51 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-468-ga3bf56c-b450jnks (MC: 1.3)
    22:35:51 [INFO] Preparing level "world"
    22:35:51 [INFO] Preparing start region
    22:35:52 [SEVERE] Could not load plugins/MinecraftRKitPlugin.jar in plugins: null
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.d(
    Caused by: java.lang.NoSuchMethodException: com.drdanick.McRKit.plugin.RTKPlugin.<init>()
            at java.lang.Class.getConstructor0(
            at java.lang.Class.getConstructor(
            ... 8 more
  5. Offline


    Is there any way to be able to run the kit without having to keep the Putty window open? I can't ever close and when I try to it stops the server. I've tried running it via the sh file and jar and still have the same issue. I've tried making it run automatically, but I'm unable to limit how many times it runs. All it does is run twice and I have two servers running on the same port. Is there a way to run it so I don't have to keep my ssh window open?

    I run my server by typing sh and ./ into the console, both cause the server to die once I close the window.
  6. Offline


    Came to post the same thing...

    You should look into a program for linux called screen.
    If you need help PM me.

    My understanding is that most plugins have removed the long constructor. Build 440 works fine for the plugins that left it in but when I tried 450 it caused those plugins with the long constructor to stop working (as stated by bukkit devs they WILL stop working and break other plugins)

    So if yours is already removed it's probably the other 2 plugiuns I have on that still have the long constructor.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 30, 2018
  7. Offline


    @gyoza @silentdojo

    I'm having the same problem with all of the plugins I use on my test server, with or without the wrapper being used. It appears to be a problem with that craftbukkit build.
  8. Offline


    @drdanick Perhaps its from not removing the stupidly long constructor (If you didn't do that yet).
  9. Offline


    ok. so i am running craftbukkit but cannot find the 'bin' folder to put files in?? what am i doing wrong here. could someone kindly explain?

    *ive just worked out that the main folder is the bin dir. but not im getting cant access craftbukkit-0.0.1-SNAPSHOT errors. even tho it is renamed exactly
  10. Offline


    I have set the restart delay to 0, but the server keeps restarting every 5h, as per default. Any suggestions?

    #Minecraft Remote Toolkit Properties File
    #Fri Feb 25 08:11:05 CST 2011
  11. Offline


    That was removed. And even so, it does not cause problems leaving it in. As far as I can see, that build will not load any plugin.

    Can I see the exact error you are getting?

    What is the exact command you are using to launch your server?
  12. Offline


    Ugh, I was using some of the object instances passed to that constructor. >.>
    I know how their classloader works. There is NO reason as to why they can't just stop calling that constructor.

    Update in 10 minutes.
  13. Offline


    Ya I just updated CB and the remote toolkit plugin is failing... you have an udpdate on the way?
  14. Offline


    Hey quick question.
    When I try to connect to my sever with PuTTY, the connection screen (black command box) closes the instant I connect. I have double checked that my port and IP are correct. I dont think the .jar file used to connect is working either. Does anyone know whats going on? Anyone else have this problem?
  15. Offline


    @silentdojo @tremor The plugin has been updated. I've also corrected some formatting issues over telnet.

    Can you try another telnet client?
  16. Offline


    The problem is I want the server to be able to run without me having to initially start it up, that's why I tried to use a cron job with my server, but it just ran two servers on the same port.
  17. Offline

    John wade

    I may be a noob, but whenever i try to use the rtoolkit.bat it just says java is not recognized as an internal or external command, operaable program, or batch file
  18. Offline


    Open up a command prompt and try this command:

    java -version
  19. Offline


    try this
    @echo off
    "%ProgramFiles(x86)%\Java\jre6\bin\java.exe" -Xmx30M -Xms30M -XX:MaxPermSize=40M -jar Minecraft_RKit.jar user:pass
  20. Offline

    Michael Murphy

    If you're using ubuntu you need to create a script in /etc/init.d to manage starting and stopping it (mine is a shell script). then use update-rc.d <script> defaults .see this link
    cron is used to run something at set intervals. I use it to back my world up every night at 12pm

    here's my script for starting my server from within /etc/init.d
    cd /Bukkit
    screen -h 1000 java -Xms1024M -Xmx2048M -jar ./craftbukkit.jar
    here's a neat backup script. cron: 00 00 * * * /Bukkit/ > /Bukkit/BKUP.LOG
    # What to backup.
    # Where to backup to.
    # Create archive filename.
    date=$(date +%m-%d-%y)
    hostname=$(hostname -s)
    # Print start status message.
    echo "Backing up $backup_files to $dest/$archive_file"
    # Backup the files using tar.
    tar czf $dest/$archive_file $backup_files
    # Print end status message.
    echo "Backup finished"
    # Long listing of files in $dest to check file sizes.
    ls -lh $dest
  21. Offline


    I am having a problem with not being able to type anything inside the wrapper window with CB 456.

    Minecraft Remote Toolkit V1.0_b18_2 ALPHA
    Loading toolkit properties...Done.
    Loading toolkit modules...Done.
    Wrapper is running on: Windows 7 6.1 x86
    Starting wrapper...
    Starting UDP listen server on port 25561
    Feb 26, 2011 11:03:12 PM run
    INFO: Listening to Port 25,561 with a connectivity queue size of 5.
    23:03:12 [INFO] Starting minecraft server version Beta 1.3
    23:03:12 [INFO] Loading properties
    23:03:12 [INFO] Starting Minecraft server on *:25565
    23:03:12 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-472-g53b258e-b456jnks (MC: 1.3)
    23:03:12 [INFO] Preparing level "world"
    23:03:12 [INFO] Preparing start region
    23:03:13 [INFO] Starting Minequery server on *:25566
    23:03:13 [INFO] WorldGuard loaded.
    23:03:13 [INFO] ÂșeLoaded Essentials build Dev546 maintained by Zenexer, ementalo, Aelux, and Brettflan
    23:03:13 [INFO] Loaded EssentialsBan build Dev546 by Zenexer, ementalo, Eris, and EggRoll
    23:03:13 [INFO] Loaded EssentialsChat build Dev546 by Zenexer, ementalo, Aelux, and Brettflan
    23:03:13 [INFO] Loaded EssentialsEco build Dev546 by Zenexer, ementalo, Aelux, and Brettflan
    23:03:13 [INFO] Loaded EssentialsGod build Dev546 by Zenexer, ementalo, Eris, and EggRoll
    23:03:13 [INFO] Loaded EssentialsHelp build Dev546 by Zenexer, ementalo, Eris, and EggRoll
    23:03:13 [INFO] Loaded EssentialsHome build Dev546 by Zenexer, ementalo, Aelux, and Brettflan
    23:03:13 [INFO] Loaded EssentialsProtect build Dev546 maintained by Zenexer, ementalo, Aelux, and Brettflan
    23:03:14 [INFO] EssentialsServerlist version Dev546 by Vimae Development enabled.
    23:03:14 [INFO] Loaded EssentialsSpawn build Dev546 maintained by Zenexer, ementalo, Aelux, and Brettflan
    23:03:14 [INFO] Loaded EssentialsTele build Dev546 by Zenexer, ementalo, Aelux, and Brettflan
    23:03:14 [INFO] Loaded EssentialsWarp build Dev546 by Zenexer, ementalo, Aelux, and Brettflan
    23:03:14 [INFO] GroupManager - Scheduled Data Saving is set for every 10 minutes!
    23:03:14 [INFO] GroupManager version 0.99c is enabled!
    23:03:14 [INFO] Fake Permissions version 2.0 is enabled!
    23:03:14 [INFO] [HeroicDeath] enabled.
    23:03:14 [INFO] Memory max: 1037959168 bytes
    23:03:14 [INFO] Memory total: 1037959168 bytes
    23:03:14 [INFO] Remote Toolkit Plugin V0.31b enabled!
    23:03:14 [INFO] [MultiVerse] - Version 1.4 (Permissions 2.0) Enabled
    23:03:14 [INFO] [MultiVerse] Loading World & Settings - 'world' - NORMAL
    23:03:14 [INFO] [MultiVerse] 1 - World(s) loaded.
    23:03:14 [INFO] [MultiVerse] Loading Portals
    23:03:14 [INFO] [MultiVerse] 0 - Portal(s) loaded.
    23:03:14 [INFO] [NoCheatPlugin] version [0.5.7] is enabled with the following checks: moving speedhack
    23:03:14 [INFO] WorldEdit 4.0-beta7 enabled.
    23:03:14 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    23:03:14 [INFO] WorldGuard: Permissions plugin detected! Using Permissions plugin for permissions.
    23:03:14 [INFO] WorldGuard: Single session is enforced.
    23:03:14 [INFO] WorldGuard: TNT ignition is PERMITTED.
    23:03:14 [INFO] WorldGuard: Lighters are PERMITTED.
    23:03:14 [INFO] WorldGuard: Lava fire is blocked.
    23:03:14 [INFO] WorldGuard: Fire spread is UNRESTRICTED.
    23:03:14 [INFO] WorldGuard 4.0-alpha1 enabled.
    23:03:14 [INFO] Done (0.173s)! For help, type "help" or "?"
  22. Offline


    It should still allow input, but you won't see it as you type. If all is failing try using the telnet console.

    This is going to take me some time to fix, and I wish the new console system was far better documented. My university semester starts tomorrow and I don't have an infinite amount of time to devote to this.
    --- merged: Feb 27, 2011 1:28 PM ---
    Update on my progress:

    Ok, I sort of have it working (sort of).

    Most of the new formatting works, but some lines do appear to arrive slightly out of order. The main problem that I am facing is that the input streams no longer block until a return carriage, but now until whenever a key is pressed. This is causing some de-synchronization between a few of the IO threads I have running on the wrapper, and so there is going to have to be a lot of code rewritten.

    Seeing as I have uni starting, it will take me at minimum a week to get this update out. I am terribly sorry for this delay, and hope that you can put up with not being able to see what you're typing (input still works). The good news is that telnet still works apart from the backspace key (which appears to be my own fault, and so I should have this fixed much faster).
  23. Offline


    Hi DrDanick,
    thanks you so much for your version. I have a question : i can connect with Putty and access Console command. It is possible to send "console commands" directly with the UDP method ?
  24. Offline


    I'm using Craftbukkit Build 440, and this is what I get when trying to start this in a virtual terminal (screenshot)

    This is my rtoolkit.bat file:
    @echo off
    java -Xmx654M -Xms654M -jar Minecraft_RKit.jar SirMustachio:(PASSWORD)
    Any suggestions?
  25. Offline


    try this
    java -Xmx20M -Xms20M -jar Minecraft_RKit.jar SirMustachio:pASSWORD
  26. Offline


    I tried that and got closer, but it's looking for craftbukkit.jar in /bin/ and not the root (screenshot). What do I need to change?

    EDIT: I think I found the problem....
    EDIT2: This error was just because I didn't put everything in the right place
  27. Offline


    You can acess the full console via telnet, whack PuTTY supports. I have not implemented support for console commands via UDP yet, but do plan to soon.
  28. Offline


    This is a new error I'm getting trying to start this (screenshot)
    I did put a password in the command, but removed it for the sake of internet posting.

    I'm lost for what to do. If it helps at all, I'm running this through a SSH connection to a remote server.
  29. Offline


    How much ram is installed in your server and how much are you allocating in
  30. Offline


    I have 1 GB dedicated RAM and currently 1024M is the maximum-heap-size and initial-heap-size

    EDIT: I think I fixed the problem by reducing these numbers
  31. Offline


    Every time I restart the server in-game it just says "Done!", but doesn't show the **SERVER IS RESTARTING** message and restart the server. I'm running craftbukkit build #457. Maybe I didn't set something right? It worked on earlier builds. Thanks. [​IMG]
Thread Status:
Not open for further replies.

Share This Page