Solved 'Regulars' Cant /warp using Signs in my region?!

Discussion in 'Bukkit Help' started by iKiwic, Apr 18, 2013.

Thread Status:
Not open for further replies.
  1. Offline

    iKiwic

    Hey!
    I opened my server today and basically it all went to sh..:( when no one could use the [Warp] Wild sign?

    The warp sign works for me but not any regulars? I THINK it's because I've protected the spawn (obviously) using region define?

    I did /region flag Spawn Allowed-cmds /warp but that didn't work either?! can anyone help asap?!

    Thank you!!
     
  2. Offline

    Lolmewn Retired Staff

    What permissions plugin are you using? Did you give them the right permission? Is there a message displayed anywhere when they try to do so? What is your server.properties?
     
  3. Offline

    Swaash

    did u give them the permission essentials.warp.sign.use
     
  4. Offline

    iKiwic

    Group manager and I think so? what permissions would they need?

    Server properties:

    #Minecraft server properties
    #Thu Apr 18 11:16:30 BST 2013
    generator-settings=
    allow-nether=true
    level-name=world
    enable-query=false
    allow-flight=true
    server-port=*****
    level-type=DEFAULT
    enable-rcon=false
    level-seed=
    server-ip=
    max-build-height=256
    spawn-npcs=true
    white-list=false
    spawn-animals=true
    snooper-enabled=true
    hardcore=false
    texture-pack=
    online-mode=true
    pvp=true
    difficulty=2
    server-name=Unknown Server
    enable-command-block=true
    gamemode=0
    max-players=50
    spawn-monsters=true
    generate-structures=true
    view-distance=10
    spawn-protection=16
    motd=Welcome to YourKraft!
     
  5. Offline

    Swaash

    they need the perm essentials.warp.sign.use
     
  6. Offline

    iKiwic

    Okay, hold on, testing now!

    still nothing, help D:

    bump- this is super important!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jun 1, 2016
  7. Offline

    jacklin213

    PlZ do not bump after 25 mins , if it's urgent go and ask people on the IRC : #bukkit
    If you dont have an IRC CLIENT , http://mibbit.com
     
  8. Offline

    martian3333

    1. Do users also have/need the essentials.warp node?

    2. Would spawn protection in the server.properties cause any problems?
     
  9. Offline

    iKiwic

    no ones on that though?


    I've given them the essentials.warp.signs.use and they have essentials_default?

    I've disabled spawn and added essentials.warp but its still not working.. Although! Just realised its not the spawn thats the problem, they cant use warp signs altogether?!

    Edit: Even though I've Definitely added the permissions they cant use /warp either!? I'm using group manager with essentials!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jun 1, 2016
  10. Offline

    martian3333

    Do any of the other commands that require a permission node work for that group? Maybe it's a problem with your permissions setup.
     
  11. Offline

    Iroh Retired Staff

    Post your perms file.
     
  12. Offline

    iKiwic

    okay, heres what the regular group looks like in the groups config:

    Regular:
    default: false
    permissions:
    - -bukkit.command.kill
    inheritance:
    - g:groupmanager_default
    - g:bukkit_default
    - g:essentials_default
    - g:towny_default
    - g:factions.kit.fullplayer
    - g:essentials.warp
    - g:essentials.spawn
    info:
    prefix: '&f[&aRegular&f] '
    build: True
    suffix: ''
    Iroh martian3333
     
  13. Offline

    fredghostkyle1

    add essentials.warp and essentials.warp.* and essentials.warp.list then essentials.sign.use.warp
     
  14. Offline

    iKiwic

    Okay, I've done it and it seems that warps are working but no ones online to test :/
    however, now when someone right-clicks the sign it displays 'you do not have permission for this area' (which must mean warps are working!) I've protected the spawn using essentials protect by doing /region define spawn I've also done /region flag spawn allowed-cmds /warp but it looks like the signs use a different technique?

    EDIT: No I can't tell if it works :/ any chance anyone can log onto my server and try?
     
  15. Offline

    fredghostkyle1

    WorldGuard interference, not Essentials. the Allowed-cmds flag needs to be removed to fix this. Also outside of a protected region, see if you can do it as a check.
     
  16. Offline

    iKiwic

    Any chance you could log onto my server to see? I can't really test it myself if I'm an admin :<
     
  17. Offline

    fredghostkyle1

    iKiwic i have time, ya IP? I would not mind at all
     
  18. Offline

    martian3333

    And remember to use essentials.signs.use.warp and not essentials.sign.use.warp
     
  19. Offline

    fredghostkyle1

    iKiwic likes this.
  20. Offline

    iKiwic

    HOW IT GOT FIXED (thanks to fredghostkyle1)

    Okay, So I gave them the command 'essentials.sign.use.warp' that command is WRONG the command you need is 'essentials.signs.use.warp' Don't notice anything different? neither did we.. its signs with an S ON THE END.

    anyway, thanks everyone!
     
    fredghostkyle1 likes this.
  21. Offline

    martian3333

    fredghostkyle1 Very nice

    iKiwic If everything is working properly now, please mark this thread solved.
     
    fredghostkyle1 likes this.
Thread Status:
Not open for further replies.

Share This Page