Read Timed Out

Discussion in 'Bukkit Help' started by MGNick, May 4, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    I'm still having this issue as well. And ran out of things to try.
  2. Offline


    Me too, got my first timed out in days.
    28.08 14:46:05 [Server] INFO Read timed out

    Bukkit devs should look into this.
  3. Offline


    ive got this problem, too
    lost many players
  4. Offline


    Worst bug today. Wish there was a way to not have to play trial and error but get better information. I guess this is a limitation of java :(

    Bukkit Version: 1060
    I = Installed, Meaning the plugin and installed and functioning.
    W = Warning, Meaning the plugin is installed but is causing some problems or no bukkit Dev Move.
    D = Disabled, Meaning the plugin is disabled due to errors, testing, or other reasons.
    S = Subscribed, Meaning Kane is subscribed to the Plugins new bukkit Dev system for instant emails.
    O = Obsolete, Meaning getting out of date, created jumped ship.

  5. Offline


    This error is EXTREMELY frustrating. It happens for no apparent reason, and I always have to restart the server manually. I keep having to look at my console window every 5 minutes to see if it's up. This REALLY needs to be looked into by bukkit devs.
  6. Offline


    Yep its been plaguing my server for days now. Sometimes the server lasts 4 hours, sometimes 5 min. Every time it's a read time out error with no warnings, no just stops.
  7. Offline


    i have it 2, but all the players from my server not :confused:
  8. Offline


    Guys when this happens post your Stack Trace, run the following command as root where 3935 is the process ID

    jstack -l 3935 > stackdump20.txt

    I have done this a few times and one thing is always true, Permissions is in the list.
  9. Offline


    Anyone find a solution to this??
  10. Offline


    Nope. Still happens. Even running the custom version of Perm 3.1 that was posted, didn't help much.
  11. Offline


    have u guys try running PermissionsEX? and remove permissions 3.1.6
  12. Offline


    I heard that using PermissionsBukkit might solve the problem. Although PermissionsBukkit is complicated and annoying to use, it's better than your server crashing every hour :/
  13. Offline


    PermissionsEX did not fix the problem. Still happens with the same frequency. Confirmed this is NOT a perms 3 issue.
  14. Offline


    Got the same problem as everyone else. So far every plugin has been updated and still no fix. It has been doing this since I got bukkit 1060
  15. Offline


    My server was fine until this cancer of a problem hit my server. Now it crashes every hour. FIX. THIS. PROBLEM.
  16. Offline


    Does anyone know why this is happening?
  17. Offline


    Try removing your auto Backup/Save plugin and install Remotetoolkit plugin this is my temporary solution.
  18. Offline


    We have also been hit hard by this issue and have tried everything possible to stop it from happening.

    Started happening on 1000, switched from Perms 3 to PermsEX, did not help, 1060, no and 1089 no. The issue is just a read time out with no indication of the actual error.

    Disabled plugins, updated plugins, blamed the hardware, ran disk checks, saw bad sectors and got the disk replaced, thought we were clear, it continued again. Checked the connection. Updated Mono. I can only echo all the other posts, our server has been up for 10 months and no issues like this have ever been seen. This is devastating our community and especially the downtime associated with 1.8 updates will further population declines for our servers. Multiple rollbacks are no fun, especially everyday.

    jstack dump

    Dual Quad Core X5675 Processors // 48GB DDR3 RAM // Solid State Drive // 1gbit dedicated uplink

    CentOS 5
    Running MCMA Newest Version
    Craftbukkit 1089 currently
    500 slots

    AutoTool 1.2
    BananaChunk 4.6
    BlockCantKeepUpSpam 0.1
    BorderGuard 4.11
    ChestShop 3.00 BETA 9
    Commands Logging 1.0
    CommandBook 1.4.2
    Command iConomy 7
    FalseBookBlock 0.86.2alpha
    FalseBookCore 0.86.2alpha
    FoundDiamonds 1.666
    HeroBounty 1.8.0
    HeroChat 4.10.3
    HeroSpawn 0.2
    HomeSweetHome 0.8
    HookShot 1.2.2
    LWC 3.21
    Lottery 0.4.3
    MagicCarpet 1.5.6
    MagicSpells 0.6.2
    Minequery 1.5
    Modifyworld 1.13
    MyWarp 2.0
    Permissions 2.7.7
    PermissionsEx 1.13
    RocketBoots 0.3.6
    SignColours 0.3
    SpamHammer 1.5a
    Stargate 0.5.5
    TaxFreeRegion 0.2
    Towny 0.74.0
    VanishNoPickup 1.9.12
    VirtualChest 4.4.4
    Votifier 1.4
    Vouchers 2.2.1
    Whitelist 2.7
    WorldEdit 4.6
    WorldGuard "5.2.2"
    WorldWarp 2.0
    BigBrother 1.8-SNAPSHOT
    dynmap "0.21.1"
    iAuction 3.2
    iConomy 5.01
    properTime 1.8.9

    Thank you for any help in this matter
  19. Offline



    We are in a similar boat, have tried everything, stack dumps don't give much away. Noone has any answers, and this truly sucks.
  20. Offline


    Our server is getting slammed by this problem. A fix would be very much appreciated; it's driving tons of users away.
  21. Offline

    Steve Member

    This will never cause the issue described as it uses UDP and not TCP so its impossible for it to cause problems with the server <-> client interaction
  22. Offline

    Robert Pendell

    I've found Permissions 2/3 caused the issue for me. I removed it and replaced it with Group Manager (the copy in Essentials) and the issue disappeared. I plan to move to either PermissionsBukkit or PermissionsEx eventually.
  23. Offline


    After removing WorldWarp we have seen promising results after 24 hours (no read time outs), not entirely sure it was Multiworlds though, will further test.
  24. Offline



    Still no dice for us.Considering we are having the EXACT same problem since around CB1000, I looked at what we had in common.

    Came up with this list:


    Food for thought, maybe. Have you tried vanilla yet? We are about to start testing one plugin at a time, painful as it will be. If everyone will start posting items from that list that they have, perhaps we can whittle it down to one plugin, but at this point - I think this is a CB issue.
  25. Offline



    Yeah after reading all of these replies I would imagine its some change in the CB builds after 1000. The plugins just make the issue more apparent, it is indeed not just one plugin causing the issue, so we can look past just targeting one plugin.

    The core issue of a read time out is a failure for files to be read efficiently. Without actual errors pointing to these read time outs we can simply think it's just a read/write bottleneck. For my server removing Multiworlds cleared the bottleneck it seems. What is your specific bottleneck would be the question now.

    A few other questions I would ask you Legionarius are, have you tried putting your configs and world on a RAM disk to increase performance? How about checking what your setting for open file descriptors are?

    For everyone following this, this doesn't seem to be a simple, this is the issue answer to this. It seems we need to reconfigure our server to handle whichever new file handling or saving that has been implemented with 1000+.

    Edit: Forgot this.. Our recent changes which led to more stable results were... upgrade from 1060 - 1089, upgrade Iconomy, Towny, and CommandBook, update to the latest Mono version for MCMyAdmin and disable WorldWarp.

    I hope for your success in tackling this issue!
  26. Offline



    There hasn't been new versions of towny/iconomy in quite some time, iconomy especially. As far as what is causing the I/O issue, I have no doubt it could be Heroes. Does more flatfile read-writes than anything i've ever seen, but it is an integral part of our experience now. We will see if it helps without it, just to know, and we will try CB1089.
  27. Offline



    Sorry for the confusion, it's possible our plugins were outdated to begin with after we updated to 1089. I just added that information, as supplemental information to everything else. Good luck with the update, let us know your results.
  28. Offline


    As an aside, anyone running a linux distro, you are welcome to the crontab entry we wrote which watches for read time outs, dumps the stack, prints the full list of open files, and restarts the server. Has made our life easier :)

    Disabling plugins has had no effect so far. Starting to smell more and more like a CB issue.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 15, 2016
  29. Offline


    Psst, if you just do what I have quoted (if you have SSH access) it will TELL you what caused the issue.
  30. Offline


    I know how to dump the stack :) In fact our autokill script does that for us. Doesn't seem to give much of a clue, though.
Thread Status:
Not open for further replies.

Share This Page