"Read Timed Out" / "Server Can't Keep Up!"

Discussion in 'Bukkit Help' started by Jamie Sage, Sep 16, 2011.

Thread Status:
Not open for further replies.
  1. Hi,

    For a few weeks now, players, and the console have being getting the "Read Timed Out" error, and the console gets "Server Can't Keep Up!" error.

    I also get this error:

    2011-09-16 14:53:30 [SEVERE] java.lang.OutOfMemoryError: Java heap space
    2011-09-16 14:54:37 [SEVERE] 	at net.minecraft.server.RegionFile.a(SourceFile:224)
    2011-09-16 14:57:18 [SEVERE] 	at net.minecraft.server.RegionFileCache.c(SourceFile:89)
    2011-09-16 14:57:24 [SEVERE] 	at net.minecraft.server.ChunkRegionLoader.a(SourceFile:25)
    2011-09-16 14:57:29 [SEVERE] 	at net.minecraft.server.ChunkProviderServer.loadChunk(ChunkProviderServer.java:120)
    2011-09-16 14:57:12 [INFO] Connection reset
    2011-09-16 14:57:36 [SEVERE] 	at net.minecraft.server.ChunkProviderServer.getChunkAt(ChunkProviderServer.java:63)
    2011-09-16 14:58:30 [SEVERE] 	at net.minecraft.server.PlayerInstance.<init>(PlayerInstance.java:31)
    2011-09-16 14:58:30 [SEVERE] 	at net.minecraft.server.PlayerManager.a(PlayerManager.java:45)
    2011-09-16 14:58:30 [SEVERE] 	at net.minecraft.server.PlayerManager.movePlayer(PlayerManager.java:141)
    2011-09-16 14:58:47 [SEVERE] 	at net.minecraft.server.ServerConfigurationManager.d(ServerConfigurationManager.java:146)
    2011-09-16 14:58:47 [SEVERE] 	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:373)
    2011-09-16 14:58:52 [SEVERE] 	at net.minecraft.server.Packet10Flying.a(SourceFile:126)
    2011-09-16 14:59:11 [SEVERE] 	at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    2011-09-16 14:59:18 [SEVERE] 	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:91)
    2011-09-16 14:59:18 [SEVERE] 	at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    2011-09-16 14:59:18 [SEVERE] 	at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:464)
    2011-09-16 14:59:18 [SEVERE] 	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    2011-09-16 14:59:31 [SEVERE] 	at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    2011-09-16 14:59:31 [SEVERE] Exception in thread "Listen thread"
    2011-09-16 14:59:31 [SEVERE] Unexpected exception
    java.lang.OutOfMemoryError: Java heap space
    	at net.minecraft.server.RegionFile.a(SourceFile:224)
    	at net.minecraft.server.RegionFileCache.c(SourceFile:89)
    	at net.minecraft.server.ChunkRegionLoader.a(SourceFile:25)
    	at net.minecraft.server.ChunkProviderServer.loadChunk(ChunkProviderServer.java:120)
    	at net.minecraft.server.ChunkProviderServer.getChunkAt(ChunkProviderServer.java:63)
    	at net.minecraft.server.PlayerInstance.<init>(PlayerInstance.java:31)
    	at net.minecraft.server.PlayerManager.a(PlayerManager.java:45)
    	at net.minecraft.server.PlayerManager.movePlayer(PlayerManager.java:141)
    	at net.minecraft.server.ServerConfigurationManager.d(ServerConfigurationManager.java:146)
    	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:373)
    	at net.minecraft.server.Packet10Flying.a(SourceFile:126)
    	at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:91)
    	at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    	at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:464)
    	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    	at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    2011-09-16 14:59:50 [SEVERE] java.lang.OutOfMemoryError: Java heap space
    2011-09-16 15:00:14 [SEVERE] 	at java.io.BufferedOutputStream.<init>(BufferedOutputStream.java:59)
    2011-09-16 15:00:18 [SEVERE] 	at net.minecraft.server.NetworkManager.<init>(NetworkManager.java:56)
    2011-09-16 15:00:18 [SEVERE] 	at net.minecraft.server.NetLoginHandler.<init>(NetLoginHandler.java:22)
    2011-09-16 15:00:18 [SEVERE] 	at net.minecraft.server.NetworkAcceptThread.run(SourceFile:49)
    They do change, but they keep the same "Template" as that.
    This only happens every hour or so.

    I'm currently using a VPS running ubuntu-10.10-x86

    I'm also running craftbukkit build #1130

    java version "1.6.0_26"
    Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
    Java HotSpot(TM) Server VM (build 20.1-b02, mixed mode)

    I'm not running any wrappers.

    I use this command to run craftbukkit:

    java -Xmx2048M -Xmx1590M -jar craftbukkit.jar nogui
    Plugins List:

    I've tried everything on the "you need help we need this information to help you" thread.

    I think it has something to do with a plugin. I've reinstalled every plugin about 5 times now, they are all up to date. I do use mysql for VirtualShop, AuthMe, and HawkEye.

    This problem started before i updated to 1.8!

    All help will be every appreciated.
  2. Offline


    Your I/O on the Harddrive is most likly the cause for the cant keep up messages, but you also have a memory issue. Why dont you take out the second -Xmx and see how it works out.
  3. Thanks for the fast reply, but it didn't work.


    However, this time i didn't get any errors in the console.
  4. Offline


    Thats a new issue, you should search some topics on it, as it has LOTS of them lol

    As for your last issue, you had two memory flags for the same thing, you should only use one. Also your server errors about heap, are saying you need more RAM.
  5. Offline


    2011-09-16 14:59:50 [SEVERE] java.lang.OutOfMemoryError: Java heap space

    You ran of out RAM. You need either more RAM or less plugins/players. It can also be a bad programmed plugin allocating all RAM in a useless way and making bukkit run out of raM quickly
  6. I put the RAM upto 2G before you posted. I've even put it up to 3G before and it still doesn't work (I run other things on the VPS as well, need space for them).

    Do you think i should re-install java or something? I have no idea what to do when it comes around to this subject. :'(
  7. Offline


    Seems like a plugins not doing well. You could try start with no plugins and see if the problems does happen. If it not, add plugins one by one and check every time, and find the wrong one. If it still occurs with no plugins, I think it would be pretty weird, let us know if that's the case, and we may think some solution :S
  8. I've done it all before. Cleaned it, everything worked (Hard to tell, because the problem happens randomly). I put each plugin on one by one, all of them worked fine.

    After i opened the server back up, the problem come back.

    I really have no clue what plugin is causing these errors, and i really need to know soon.
Thread Status:
Not open for further replies.

Share This Page