Randomly dropping everyone on the server. Not sure if MC or Bukkit problem.

Discussion in 'Bukkit Help' started by yummysinsemilla, Apr 3, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Randomly, somewhat frequently, my server will just drop everyone. They can log right back in, but this is the error that happens.

    2011-04-04 01:14:20 [SEVERE] java.net.SocketTimeoutException: Read timed out
    2011-04-04 01:14:20 [SEVERE]    at java.net.SocketInputStream.socketRead0(Native Method)
    2011-04-04 01:14:20 [SEVERE]    at java.net.SocketInputStream.read(SocketInputStream.java:146)
    2011-04-04 01:14:20 [SEVERE]    at java.net.SocketInputStream.read(SocketInputStream.java:199)
    2011-04-04 01:14:20 [SEVERE]    at java.io.FilterInputStream.read(FilterInputStream.java:83)
    2011-04-04 01:14:20 [SEVERE]    at net.minecraft.server.Packet.b(Packet.java:73)
    2011-04-04 01:14:20 [SEVERE]    at net.minecraft.server.NetworkManager.f(NetworkManager.java:130)
    2011-04-04 01:14:20 [SEVERE]    at net.minecraft.server.NetworkManager.c(NetworkManager.java:229)
    2011-04-04 01:14:20 [SEVERE]    at net.minecraft.server.NetworkReaderThread.run(SourceFile:68)
    2011-04-04 01:14:20 [INFO] person1 lost connection: disconnect.genericReason
    2011-04-04 01:14:36 [SEVERE] java.net.SocketTimeoutException: Read timed out
    2011-04-04 01:14:36 [SEVERE]    at java.net.SocketInputStream.socketRead0(Native Method)
    2011-04-04 01:14:36 [SEVERE]    at java.net.SocketInputStream.read(SocketInputStream.java:146)
    2011-04-04 01:14:36 [SEVERE]    at java.io.DataInputStream.readFully(DataInputStream.java:195)
    2011-04-04 01:14:36 [SEVERE]    at java.io.DataInputStream.readLong(DataInputStream.java:416)
    2011-04-04 01:14:36 [SEVERE]    at java.io.DataInputStream.readDouble(DataInputStream.java:468)
    2011-04-04 01:14:36 [SEVERE]    at net.minecraft.server.Packet13PlayerLookMove.a(SourceFile:28)
    2011-04-04 01:14:36 [SEVERE]    at net.minecraft.server.Packet.b(Packet.java:83)
    2011-04-04 01:14:36 [SEVERE]    at net.minecraft.server.NetworkManager.f(NetworkManager.java:130)
    2011-04-04 01:14:36 [SEVERE]    at net.minecraft.server.NetworkManager.c(NetworkManager.java:229)
    2011-04-04 01:14:36 [SEVERE]    at net.minecraft.server.NetworkReaderThread.run(SourceFile:68)
    2011-04-04 01:14:36 [INFO] person2 lost connection: disconnect.genericReason
    2011-04-04 01:14:42 [SEVERE] java.net.SocketTimeoutException: Read timed out
    2011-04-04 01:14:42 [SEVERE]    at java.net.SocketInputStream.socketRead0(Native Method)
    2011-04-04 01:14:42 [SEVERE]    at java.net.SocketInputStream.read(SocketInputStream.java:146)
    2011-04-04 01:14:42 [SEVERE]    at java.net.SocketInputStream.read(SocketInputStream.java:199)
    2011-04-04 01:14:42 [SEVERE]    at java.io.FilterInputStream.read(FilterInputStream.java:83)
    2011-04-04 01:14:42 [SEVERE]    at net.minecraft.server.Packet.b(Packet.java:73)
    2011-04-04 01:14:42 [SEVERE]    at net.minecraft.server.NetworkManager.f(NetworkManager.java:130)
    2011-04-04 01:14:42 [SEVERE]    at net.minecraft.server.NetworkManager.c(NetworkManager.java:229)
    2011-04-04 01:14:42 [SEVERE]    at net.minecraft.server.NetworkReaderThread.run(SourceFile:68)
    2011-04-04 01:14:42 [INFO] myself lost connection: disconnect.genericReason
    I'm not sure if this is something that the Bukkit developers can fix, or if it's just a known problem with the actual MC server. This did happen before 1.4, but it was very rare. Now it's just sort of ridiculous, lol. Just kind of odd that everyone times out at the same time, while the server is still running and my SSH hasn't timed out.

    I'm using CB617 on linux. This doesn't look like a plugin glitch, so I won't bother listing.
  2. Offline


    It may be a plugin glitch please list them. Also may I know the "guts" of your server. It could just be your server doesn't have enough ram or bandwith and gets overloaded and shuts down.
  3. Offline


    I get these as well, as well as the server randomly stopping, by stopping I mean disabling all the plugins as if it has received a stop command. This happens about every six hours after starting up. I also notice large amounts memory being allocated faster then before, before it would be about a day to allocate 1.4GB of memory, now it is within the first 10 minutes. Also increases server load as well. This is without plugins, and with the latest rb #617.

    It has made a very stable server, very unstable.
  4. Offline


    The server is running off a quad core i-7 920. It generally sits at around 70% of the total ram allocated. Maybe more or less depending on who's online. It's a relatively small server. It has a dedicated 100mbit connection.

    I'm atm using Permissions, iConomy, BetterShop, PickBoat, Flow Control, Container Protect, CookieMonster, CrowdControl, iChat, Minecart Mania, Nether, SpawnControl, Turnstile, UnbreakableBoats (and whenever it gets updated, Slots).

    I don't think it's a plugin problem as they are all functional. I'm no java expert by any means, but by the error message it just looks like it's a server issue with how it determines connection timeouts or something along those lines. Unlike the poster before me, I haven't had the plugins unload themselves. It just drops everyone on the server momentarily. It doesn't stop running at all.
  5. Offline


    From me watching top (utility on Linux to see CPU usage and stats), I have noticed that MySQL jumps to 50% or so CPU, then that error starts coming up, so it could be the connection to the MySQL server. I'll investigate more later
  6. Offline


    There's been a ton of people having this problem and there all using CB 617. I think it's a bug wig 617 and you should go back to 612 because it seems to be more stable.
  7. Offline


    I've had this exact same problem starting with CB617. My CPU levels in top have gone from an average of %17 to %30 once two people are one. Every so often, usually after a bunch of people get kicked out the CPU tops at %100 and just holds. No one can join and I have to force stop the server.

    The first thing I did was try CB612, but that hasn't fixed it.
  8. Offline


    I've been running 617 for a while now without any issues, please don't spread misinformation unless it is founded (and if so, provide references).
  9. Offline


    I'm not I had the same problems when I was on 617 but then I downgraded to 612 and it all worked fine.
  10. Offline


    Started getting this issue on #617 aswell
  11. Offline


    The "read timed out" errors seem to be a symptom of other problems on the server, and not actually directly related to the cause. Of course, the lack of direct connection makes tracking down the problem a lot more difficult.

    If a Bukkit dev is interested in investigating, I have found a method which I've proven to cause such a timeout. I'm thinking this method is probably likewise not directly connected with other causes of the crash, but if you start a conversation with me about it I'll point you to code that can cause it along with a brief explanation. Might be helpful, might not be.
Thread Status:
Not open for further replies.

Share This Page