Question Question about Plugin Versions

Discussion in 'Bukkit Help' started by PenguinHax, Dec 15, 2020.

  1. Offline

    PenguinHax

    Hi, so I'm just wondering, if you go into a plugin file versions page, for example, https://dev.bukkit.org/projects/lagmeter/files, when the different versions are listed.
    A plugin might say that the first ever version was 1.0, and it updated all the way to 1.16.4, but does downloading the latest version mean that the version 4.0 for example is 1.16.4 and all below versions also carry into the lastest version of 4.0?
    If this is confusing,
    A plugin may have version 1.0 2.0 3.0 and 4.0 and
    1.0 is for 1.7.10
    and
    2.0 is for 1.8.9
    and
    3.0 is for 1.12.2
    and 4.0 is for 1.16.4.
    Does downloading 4.0 provide support for 1.16.4?
    To simplify even more
    https://dev.bukkit.org/projects/worldedit/files for example.
    If I wanted 1.8.9 support,
    do I download the latest version of 1.16.4 support? Would that carry down to 1.8.9 support too?
    Or do I have to download version 6.1 for 1.8 support?
    Thanks!
    This was a question that was tickling me for ages, because vault said for me to update my 1.8.9 vault, but the latest said 1.16.4,
    Thanks!
     
  2. Offline

    timtower Administrator Administrator Moderator

    @PenguinHax If 4.0 is for 1.16.4 then it does support 1.16.4, otherwise it would not have tagged for it.
    Worldedit has the supported versions in the names.

    Some plugins use version specific code, Vault does not, and if you get errors then you can always ask here what a possible solution might be.
     

Share This Page