Problem/Bug Problem with the WorldBorder plugin 1.14.2

Discussion in 'Bukkit Help' started by tomss, Jun 21, 2019.

Thread Status:
Not open for further replies.
  1. Offline

    tomss

    Hi, first of all, I just set up my server yesterday so I'm obviously not very informed about it. I'm planning to run a server from my Raspberry Pi, so I've started to pregenerate the world with WorldBorder. However, the chunk loading takes way too long it seems to me, and I thought it might be just related to it being version 1.14.2 but I thought my PC should be powerful enough to progress the default 20 chunks per second, which it doesn't.

    The CPU usage is very different, right now it's at around 30/40%, but sometimes it will go up to 90%. I have an AMD FX 6300 which doesn't have the best single-core performance but still should be able to run the server smoothly imo. I'm running it on Windows 10, but I can theoretically switch to Linux if it makes a big difference.
    RAM usage is always the same, it uses around 7GB of RAM from 16 as I set it in the java arguments.
    Disk usage has been up to 0.3% yesterday, but today it stayed on 0% so far. I set fill to autosave every 15 minutes.

    Here is the server log (latest.txt): https://pastebin.com/c6shkwqG
     
  2. Offline

    timtower Moderator Moderator

    @tomss How big is that border?
     
  3. Offline

    tomss

    The border's radius is 5000 blocks. I'd prefer not going lower though we actually already explored chunks further than that radius

    By the way I'm just running wb world fill out of the console without any parameters (didn't change freq or pad) because when I raise the frequency the server crashes after two minutes of running

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jun 22, 2019
  4. Offline

    bwfcwalshy Retired Staff

    There are chunk issues in these newer builds, performance is worse and chunk loading is much slower. It's a well-known 1.14 issue

    What your seeing is very normal for 1.14 sadly, best you can hope for is that they fix it at some point.
     
  5. Offline

    tomss

    Yeah I thought it might be a problem, well is there still an option to make it quicker? I've just tried doing the fill process on my SSD, and it seems to be running quicker (the disc it was slow on was a regular 1TB external disc), but I don't know if it's worth shortening the lifespan of it (I'm just not sure but I'd assume it doesn't affect the lifetime that much)

    I'm going to let it run on the SSD for now. Thanks so far ;)

    EDIT: @timtower or @bwfcwalshy , do you know if Paper would run this better?
     
    Last edited: Jun 22, 2019
Thread Status:
Not open for further replies.

Share This Page